IMGLIB: IMGLIB Function Reference

  • Main Page
  • Modules
  • Files

IMGLIB Function Reference

Release 3.2.0.1

Contents

  1. Introduction
  2. Notational Conventions
  3. Functional Reference
    • Image Analysis
    • Image Filtering and Format Conversion
    • Image Compression and Decompression

Introduction

IMGLIB provides a collection of C-callable high-performance routines that can serve as key enablers for a wide range of image/video processing applications. These functions exploit the high performance capabilities of Texas Instruments DSPs.

All functions in IMGLIB have been developed for a little-endian memory model. Some may work in a big-endian memory model as well, however, their functionality is not guaranteed.

Notational Conventions

All functions within IMGLIB following the naming conventions described below.

  1. Each function begins with the prefix IMG_. This serves to prevent namespace conflicts.
  2. The prefix is followed by a functional descriptor. This descriptor provides insight into the functionality of the routine as well as mask size information when relevant.
  3. A suffix is placed after each function descriptor. The suffix describes the type of inputs the function accepts. Valid suffixes are defined below.
    • Input format: _id[s]
    • Mask format: _cd[s]
    • Input format (only): _d[s]
    • Packed binary data input: _bin
    • Fixed point math format: _iq

For each of the suffixes, d represents the data length in bits and [s] indicates that the letter s may be appended to indicate that the data is signed. All fixed point math input and output data is 32-bit. A few examples follow in the table below.

Kernel Name | Input Format | Mask Format
IMG_conv_5x5_i8_c16s | 8-bit unsigned | 16-bit signed
IMG_conv_3x3_i16_c16s | 16-bit unsigned | 16-bit signed
IMG_corr_gen_iq | 32-bit fixed-point | N/A
IMG_boundary_16s | 16-bit signed | N/A
IMG_dilate_bin | packed binary | N/A

Functional Reference

The following sections provide a detailed reference of all functions within IMGLIB. The functions are organized into the following three categories:

  • Image Analysis
  • Image Filtering and Format Conversion
  • Image Compression and Decompression
Copyright 2014, Texas Instruments Incorporated


IMGLIB: Image Analysis

IMGLIB Function Reference

Image Analysis

This section provides a description of the functions that are commonly applied in image analysis applications.

Image Boundary and Perimeter Functions

Boundary and perimeter computation functions are provided as commonly-used structural operators in vision applications.

  • IMG_boundary_8
  • IMG_boundary_16s
  • IMG_perimeter_8
  • IMG_perimeter_16

Morphological Operation Functions

The morphological operator functions are used to perform basic dilation and erosion operations on binary images. Dilation and erosion are the fundamental building blocks for higher-level morphological operations such as Opening and Closing. These functions are useful in machine vision and medical imaging applications.

  • IMG_dilate_bin
  • IMG_erode_bin

Edge Detection Functions

Edge detection is a commonly-used operation in vision systems. Many algorithms exist for edge detection. One of the most commonly used methods for edge detection is the Sobel algorithm. The following functions are optimized implementation of the Sobel operator with different mask sizes and data formats.

  • IMG_sobel_3x3_8
  • IMG_sobel_3x3_16
  • IMG_sobel_3x3_16s
  • IMG_sobel_5x5_16s
  • IMG_sobel_7x7_16s

Image Histogram Functions

The histogram routines provide the ability to generate an image histogram. An image histogram is basically a count of the intensity levels (or some other statistic) in an image. For example, for a grayscale image with 8-bit pixel intensity values, the histogram will consist of 256 bins corresponding to the 256 possible pixel intensities. Each bin contains a count of pixels within the image that have the particular intensity value. Histogram processing (such as histogram equalization or modification) is used in areas such as vision systems and image/video content generation systems. The 16-bit version can operate on images with data resolution from 1 to 16 bits.

  • IMG_histogram_8
  • IMG_histogram_16

Image Thresholding Functions

Different forms of image thresholding operations are used for various purposes in image/video processing systems. For example, one form of thresholding may be used to convert grayscale image data to binary image data for input to binary morphological processing. Another form of thresholding may be used to clip image data levels into a desired range, and yet another form of thresholding may be used to zero out low-level perturbations in image data due to sensor noise. Thresholding is also found in machine vision applications to provide a simple means for image segmentation.

  • IMG_clipping_16s
  • IMG_thr_gt2max_8
  • IMG_thr_gt2thr_8
  • IMG_thr_le2min_8
  • IMG_thr_le2thr_8
  • IMG_thr_gt2max_16
  • IMG_thr_gt2thr_16
  • IMG_thr_le2min_16
  • IMG_thr_le2thr_16


IMGLIB: Image Filtering and Format Conversion

IMGLIB Function Reference

Image Filtering and Format Conversion

This section provides a description of the functions that are applicable to image filtering and format conversions.

Color Space Conversion Functions

Color space conversion from YCbCr to RGB enables the display of digital video data generated, for instance, by an MPEG or JPEG decoder system on RGB displays.

  • IMG_ycbcr422pl_to_rgb565

These routines take a packed YCrYCb color buffer in big-endian or little-endian format and expand the constituent color elements into separate buffers in little-endian byte ordering.

  • IMG_yc_demux_be16_8
  • IMG_yc_demux_le16_8
  • IMG_yc_demux_be16_16
  • IMG_yc_demux_le16_16

Image Convolution Functions

The convolution functions are used to apply generic filters to the input image. Filter sizes of 3x3, 5x5, 7x7, and 11x11 are supported. Typical applications include, but are not limited to, image smoothing and sharpening.

  • IMG_conv_11x11_i16s_c16s
  • IMG_conv_11x11_i8_c8s
  • IMG_conv_7x7_i16s_c16s
  • IMG_conv_7x7_i8_c16s
  • IMG_conv_7x7_i8_c8s
  • IMG_conv_5x5_i16s_c16s
  • IMG_conv_5x5_i8_c16s
  • IMG_conv_5x5_i8_c8s
  • IMG_conv_3x3_i16s_c16s
  • IMG_conv_3x3_i16_c16s
  • IMG_conv_3x3_i8_c8s

Image Correlation Functions

Correlation functions are provided to enable image matching. Image matching is useful in applications such as machine vision, medical imaging, and security/defense. The following functions implement highly optimized corrrelation for commonly-used filter sizes such as 3x3, 5x5, and 11x11.

  • IMG_corr_3x3_i8_c8
  • IMG_corr_3x3_i8_c16s
  • IMG_corr_3x3_i16s_c16s
  • IMG_corr_3x3_i16_c16
  • IMG_corr_5x5_i16s_c16s
  • IMG_corr_11x11_i8_c16s
  • IMG_corr_11x11_i16s_c16s

The functions below are more generic and can implement correlation for user-specified pixel neighborhood dimensions within documented constraints. The IMG_corr_gen_iq function handles 32-bit Q-point data.

  • IMG_corr_gen_i16s_c16s
  • IMG_corr_gen_iq

Error Diffusion Functions

Error diffusion with binary valued output is useful in printing applications. The most widely-used error diffusion algorithm is the Floyd-Steinberg algorithm. These functions are optimized implementations of this algorithm.

  • IMG_errdif_bin_8
  • IMG_errdif_bin_16

Median Filtering Functions

Median filtering is used in image restoration, to minimize the effects of impulsive noise in imagery. Applications can cover almost any area where impulsive noise may be a problem, including security/defense, machine vision, and video compression systems. Optimized implementation of the median filter for 3x3 pixel neighborhood is provided in the routines below.

  • IMG_median_3x3_8
  • IMG_median_3x3_16s
  • IMG_median_3x3_16

Pixel Expand Functions

The routines IMG_pix_expand and IMG_pix_sat, respectively, expand 8-bit pixels to 16-bit quantities via zero extension, and saturate 16-bit signed numbers to 8-bit unsigned numbers. They can be used to prepare input and output data for other routines such as the horizontal and vertical scaling routines.

  • IMG_pix_expand
  • IMG_pix_sat


IMGLIB: Image Compression and Decompression

IMGLIB Function Reference

Image Compression and Decompression

This section describes the applicable functions for compression/decompression standards such as JPEG, MPEG video, and H.26x.

Forward and Inverse DCT Functions

IMGLIB provides forward and inverse DCT (Discrete Cosine Transform) functions. These functions are applicable for a wide range of compression standards such as JPEG Encode/Decode, MPEG Video Encode/Decode, and H.26x Encode/Decode. These compression standards are used in diverse end-applications:

  • JPEG is used in printing, photography, security systems, etc.
  • MPEG video standards are used in digital TV, DVD players, set-top boxes, video-on-demand systems, video disc applications, multimedia/streaming media applications, etc.
  • H.26x standards are used in video telephony as well as some streaming media applications

Note that the inverse DCT function performs an IEEE 1180-1990 compliant inverse DCT, including rounding and saturation to signed 9-bit quantities. The forward DCT rounds the output values for improved accuracy. These factors can have significant effect on the final result in terms of picture quality, and are important to consider when implementing DCT-based systems or comparing the performance of different DCT-based implementations.

  • IMG_fdct_8x8
  • IMG_idct_8x8_12q4

High Performance Motion Estimation Functions

The following functions are provided to enable high performance motion estimation algorithms that are used in applications such as MPEG Video Encode or H.26x Encode.

  • IMG_mad_8x8
  • IMG_mad_16x16
  • IMG_sad_8x8
  • IMG_sad_16x16

Video encoding is useful in video-on-demand systems, streaming media systems, video telephony, etc. Motion estimation is typically one of the most computationally intensive operations in video encoding systems; the provided functions are highly optimized to significantly improve such systems.

Quantization Functions

Quantization is an integral step in many image/video compression systems, including those based on widely used variations of DCT-based compression such as JPEG, MPEG, and H.26x. The function provided below may be used in such systems to perform the required quantization step.

  • IMG_quantize

Wavelet Processing Functions

Wavelet processing is used in emerging standards such as JPEG2000 and MPEG-4, where it is typically used to provide highly efficient still picture compression. Various proprietary image compression systems are also wavelet-based. This release includes the utilities IMG_wave_horz and IMG_wave_vert for computing horizontal and vertical wavelet transforms. Together, they can compute 2-D wavelet transforms for image data. The routines are flexible enough, within documented constraints, to accommodate a wide range of specific wavelets and image dimensions.

  • IMG_wave_horz
  • IMG_wave_vert


IMGLIB: Module Index

IMGLIB Modules

Here is a list of all modules:
  • IMG_boundary_16s
  • IMG_boundary_8
  • IMG_clipping_16s
  • IMG_conv_11x11_i16s_c16s
  • IMG_conv_11x11_i8_c8s
  • IMG_conv_7x7_i16s_c16s
  • IMG_conv_7x7_i8_c8s
  • IMG_conv_7x7_i8_c16s
  • IMG_conv_5x5_i16s_c16s
  • IMG_conv_5x5_i8_c16s
  • IMG_conv_5x5_i8_c8s
  • IMG_conv_3x3_i16_c16s
  • IMG_conv_3x3_i16s_c16s
  • IMG_conv_3x3_i8_c8s
  • IMG_corr_11x11_i16s_c16s
  • IMG_corr_11x11_i8_c16s
  • IMG_corr_5x5_i16s_c16s
  • IMG_corr_3x3_i16_c16
  • IMG_corr_3x3_i16s_c16s
  • IMG_corr_3x3_i8_c16s
  • IMG_corr_3x3_i8_c8
  • IMG_corr_gen_i16s_c16s
  • IMG_corr_gen_iq
  • IMG_dilate_bin
  • IMG_erode_bin
  • IMG_errdif_bin_16
  • IMG_errdif_bin_8
  • IMG_fdct_8x8
  • IMG_histogram_16
  • IMG_histogram_8
  • IMG_idct_8x8_12q4
  • IMG_mad_16x16
  • IMG_mad_8x8
  • IMG_median_3x3_16s
  • IMG_median_3x3_16
  • IMG_median_3x3_8
  • IMG_perimeter_16
  • IMG_perimeter_8
  • IMG_pix_expand
  • IMG_pix_sat
  • IMG_quantize
  • IMG_sad_16x16
  • IMG_sad_8x8
  • IMG_sobel_3x3_16
  • IMG_sobel_3x3_16s
  • IMG_sobel_3x3_8
  • IMG_sobel_5x5_16s
  • IMG_sobel_7x7_16s
  • IMG_thr_gt2max_16
  • IMG_thr_gt2max_8
  • IMG_thr_gt2thr_16
  • IMG_thr_gt2thr_8
  • IMG_thr_le2min_16
  • IMG_thr_le2min_8
  • IMG_thr_le2thr_16
  • IMG_thr_le2thr_8
  • IMG_wave_horz
  • IMG_wave_vert
  • IMG_yc_demux_be16_8
  • IMG_yc_demux_le16_16
  • IMG_yc_demux_le16_8
  • IMG_ycbcr422pl_to_rgb565


IMGLIB: IMG_boundary_16s

IMG_boundary_16s

Detailed Description

Functions

void IMG_boundary_16s (const short *restrict i_data, int rows, int cols, unsigned int *restrict o_coord, short *restrict o_grey)

Function Documentation

void IMG_boundary_16s | ( | const short *restrict | i_data,
 |  | int | rows,
 |  | int | cols,
 |  | unsigned int *restrict | o_coord,
 |  | short *restrict | o_grey
 | ) |  |

Description:
This routine scans an image looking for non-zero pixels. The locations of those pixels are stored out to the o_coord array as packed Y/X pairs, with Y in the upper 16-bits, and X in the lower 16-bits. The associated grey levels are stored in the o_grey array in parallel.
Parameters:
i_data | Input image of size cols-by-rows
rows | Height of the input image
cols | Width of the input image
o_coord | Array to write output coordinates to
o_grey | Array to write output grey levels to
Algorithm:
Outer and inner loops are merged.
"Inner loop" is unrolled to process four pixels per iteration.
Packed coordinate value is updated directly, rather than by repacking x, y every time it's needed.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • Both output arrays must be 32-bit aligned
  • The input image must be 64-bit aligned.
  • The cols parameter must be a non-zero multiple of 4 less than 32767
  • The rows parameter must be non-zero and less than or equal to 32767
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_boundary_8

IMG_boundary_8

Detailed Description

Functions

void IMG_boundary_8 (const unsigned char *restrict i_data, int rows, int cols, int *restrict o_coord, int *restrict o_grey)

Function Documentation

void IMG_boundary_8 | ( | const unsigned char *restrict | i_data,
 |  | int | rows,
 |  | int | cols,
 |  | int *restrict | o_coord,
 |  | int *restrict | o_grey
 | ) |  |

Description:
This routine scans an image looking for non-zero pixels. The locations of those pixels are stored out to the o_coord array as packed Y/X pairs, with Y in the upper 16-bits, and X in the lower 16-bits. The associated grey levels are stored in the o_grey array in parallel.
Parameters:
i_data | Input image of size cols-by-rows
rows | Height of the input image
cols | Width of the input image
o_coord | Array to write output coordinates to
o_grey | Array to write output grey levels to
Algorithm:
Outer and inner loops are merged.
"Inner loop" is unrolled to process four pixels per iteration.
Packed coordinate value is updated directly, rather than by repacking x, y every time it's needed.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • Input and both output arrays must be 32-bit aligned
  • Output buffers o_coord and o_grey start in different banks
  • The cols parameter must be a non-zero multiple of 4 less than 32767
  • The rows parameter must be non-zero and less than or equal to 32767
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_clipping_16s

IMG_clipping_16s

Detailed Description

Functions

void IMG_clipping_16s (const short *restrict x, short rows, short cols, short *restrict r, short THRES_MAX, short THRES_MIN)

Function Documentation

void IMG_clipping_16s | ( | const short *restrict | x,
 |  | short | rows,
 |  | short | cols,
 |  | short *restrict | r,
 |  | short | THRES_MAX,
 |  | short | THRES_MIN
 | ) |  |

Description:
This function truncates elements of an input image to user defined maximum and minimum values. Each input and output pixel is 16-bit signed and the size of the matrix is defined by the input dimension parameters "rows" and "cols".
The output matrix has the same size as the input matrix and each pixel is clipped to the user defined minimum or maximum values if is less than the minimum or greater than the maximum respectively. Otherwise, the pixel is passed to the output unchanged.
Parameters:
x | Input image of size cols-by-rows
rows | Height of the input image
cols | Width of the input image
r | Output image pointer
THRES_MAX | User-defined MAX threshold value
THRES_MIN | User-defined MIN threshold value
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The input and output arrays must be 64-bit aligned
  • The THRES_MAX parameter must be greater than or equal to THRES_MIN
  • The number of image pixels (cols x rows) must be a multiple of 8
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_11x11_i16s_c16s

IMG_conv_11x11_i16s_c16s

Detailed Description

Functions

void IMG_conv_11x11_i16s_c16s (const short *restrict imgin_ptr, short *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Function Documentation

void IMG_conv_11x11_i16s_c16s | ( | const short *restrict | imgin_ptr,
 |  | short *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts eleven rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 11 pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 121 resulting multiplications are summed together to produce a 40-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to a 16-bit range prior to storing in the output array. The stored result is saturated accordingly. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is covered.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 16-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 32-bit aligned
  • The input and mask arrays must be 16-bit aligned
  • The image pitch must be greater than or equal to the width
  • The width parameter must be a non-zero multiple of 4
  • Internal accuracy of the computations is 40 bits. To ensure correctness on a 16 bit input data, the maximum permissible filter gain in terms of bits is 24-bits i.e. the cumulative sum of the absolute values of the filter coefficients should not exceed 2^24 - 1.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_11x11_i8_c8s

IMG_conv_11x11_i8_c8s

Detailed Description

Functions

void IMG_conv_11x11_i8_c8s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const char *restrict mask_ptr, short shift)

Function Documentation

void IMG_conv_11x11_i8_c8s | ( | const unsigned char *restrict | imgin_ptr,
 |  | unsigned char *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const char *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts eleven rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 11 pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 121 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to an 8-bit range prior to storing in the output array. The stored result is saturated as an unsigned 8-bit quantity. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is processed.
Parameters:
imgin_ptr | Pointer to an input image of 8-bit pixels
imgout_ptr | Pointer to an output image of 8-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to an 8-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 32-bit aligned
  • The image pitch must be greater than or equal to the width
  • The width parameter must be a non-zero multiple of 2
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x/C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_7x7_i16s_c16s

IMG_conv_7x7_i16s_c16s

Detailed Description

Functions

void IMG_conv_7x7_i16s_c16s (const short *restrict imgin_ptr, short *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Function Documentation

void IMG_conv_7x7_i16s_c16s | ( | const short *restrict | imgin_ptr,
 |  | short *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts seven rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 7 pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 49 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to a 16-bit range prior to storing in the output array. The stored result is saturated accordingly. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is covered.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 16-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The input and output arrays must be 64-bit aligned
  • The mask array must be 16-bit aligned
  • The image pitch must be greater than or equal to the width and a multiple of 4
  • The width parameter must be a non-zero multiple of 8
  • Internal accuracy of the computations is 32 bits. To ensure correctness on a 16 bit input data, the maximum permissible filter gain in terms of bits is 24-bits i.e. the cumulative sum of the absolute values of the filter coefficients should not exceed 2^24 - 1.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_7x7_i8_c8s

IMG_conv_7x7_i8_c8s

Detailed Description

Functions

void IMG_conv_7x7_i8_c8s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const char *restrict mask_ptr, short shift)

Function Documentation

void IMG_conv_7x7_i8_c8s | ( | const unsigned char *restrict | imgin_ptr,
 |  | unsigned char *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const char *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts seven rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 7 pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 49 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to an 8-bit range prior to storing in the output array. The stored result is saturated as an unsigned 8-bit quantity. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is processed.
Parameters:
imgin_ptr | Pointer to an input image of 8-bit pixels
imgout_ptr | Pointer to an output image of 8-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to an 8-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 32-bit aligned
  • The width parameter must be a non-zero multiple of 2
  • The image pitch must be greater than or equal to the width
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x/C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_7x7_i8_c16s

IMG_conv_7x7_i8_c16s

Detailed Description

Functions

void IMG_conv_7x7_i8_c16s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, int shift)

Function Documentation

void IMG_conv_7x7_i8_c16s | ( | const unsigned char *restrict | imgin_ptr,
 |  | unsigned char *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | int | shift
 | ) |  |

Description:
The convolution kernel accepts seven rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 7 pixel square filter mask provided on input. The input and output image pixels are provided in 8-bit unsigned format and the mask is in 16-bit signed format.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 49 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to a 8-bit range prior to storing in the output array. The stored result is saturated accordingly. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is covered.
Parameters:
imgin_ptr | Pointer to an input image of 8-bit pixels
imgout_ptr | Pointer to an output image of 8-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The output array must be 32-bit aligned
  • The mask array must be 16-bit aligned
  • The width parameter must be a non-zero multiple of 2
  • The image pitch must be greater than or equal to the width
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_5x5_i16s_c16s

IMG_conv_5x5_i16s_c16s

Detailed Description

Functions

void IMG_conv_5x5_i16s_c16s (const short *restrict imgin_ptr, short *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Function Documentation

void IMG_conv_5x5_i16s_c16s | ( | const short *restrict | imgin_ptr,
 |  | short *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts five rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 5 pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 25 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to a 16-bit range prior to storing in the output array. The stored result is saturated accordingly. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is covered.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 16-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The output image array must be 32-bit aligned
  • The mask and input image array must be 16-bit aligned.
  • The width parameter must be a non-zero multiple of 2
  • The image pitch must be greater than or equal to the width and a multiple of 2
  • Internal accuracy of the computations is 32 bits. To ensure correctness on a 16 bit input data, the maximum permissible filter gain in terms of bits is 16-bits i.e. the cumulative sum of the absolute values of the filter coefficients should not exceed 2^16 - 1.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_5x5_i8_c16s

IMG_conv_5x5_i8_c16s

Detailed Description

Functions

void IMG_conv_5x5_i8_c16s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Function Documentation

void IMG_conv_5x5_i8_c16s | ( | const unsigned char *restrict | imgin_ptr,
 |  | unsigned char *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts five rows of 'pitch' input pixels and produces one row of 'width' output pixels using the five pixel square filter mask provided on input. The input and output image pixels are provided in 8-bit unsigned format and the mask is in 16-bit signed format.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 25 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to a 8-bit range prior to storing in the output array. The stored result is saturated accordingly. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is covered.
Parameters:
imgin_ptr | Pointer to an input image of 8-bit pixels
imgout_ptr | Pointer to an output image of 8-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The output array must be 32-bit aligned
  • The mask array must be 16-bit aligned
  • The width parameter must be a non-zero multiple of 2
  • The image pitch must be greater than or equal to the width
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_5x5_i8_c8s

IMG_conv_5x5_i8_c8s

Detailed Description

Defines

#define | IMG_CONV_5X5_I8_C8S_H_ 1

Functions

void | IMG_conv_5x5_i8_c8s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const char *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_5X5_I8_C8S_H_ 1

Definition at line 42 of file c64P/IMG_conv_5x5_i8_c8s.h.

Function Documentation

void IMG_conv_5x5_i8_c8s | ( | const unsigned char *restrict | imgin_ptr,
 |  | unsigned char *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const char *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts five rows of 'pitch' input pixels and produces one row of 'width' output pixels using the five pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 25 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to an 8-bit range prior to storing in the output array. The stored result is saturated as an unsigned 8-bit quantity. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is processed.
Parameters:
imgin_ptr | Pointer to an input image of 8-bit pixels
imgout_ptr | Pointer to an output image of 8-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to an 8-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 32-bit aligned
  • The width parameter must be a non-zero multiple of 4
  • The image pitch must be greater than or equal to the width
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x/C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_3x3_i16_c16s

IMG_conv_3x3_i16_c16s

Detailed Description

Functions

void IMG_conv_3x3_i16_c16s (const unsigned short *restrict imgin_ptr, unsigned short *restrict imgout_ptr, int width, const short *restrict mask_ptr, int shift)

Function Documentation

void IMG_conv_3x3_i16_c16s | ( | const unsigned short *restrict | imgin_ptr,
 |  | unsigned short *restrict | imgout_ptr,
 |  | int | width,
 |  | const short *restrict | mask_ptr,
 |  | int | shift
 | ) |  |

Description:
The convolution kernel accepts three rows of 'width' input pixels and produces one row of 'width' output pixels using the three pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 9 resulting multiplications are summed together to produce a 40-bit intermediate sum.
The user defined shift value is used to shift the convolution sum down to a 16-bit range prior to storing in the output array. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is covered.
Parameters:
imgin_ptr | Pointer to input image of unsigned 16-bit pixels
imgout_ptr | Pointer to output image of unsigned 16-bit pixels
width | Number of output pixels
mask_ptr | Pointer to a 16-bit signed filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The mask and input/output image arrays must be 16-bit aligned.
  • The width parameter must be a non-zero multiple of 4
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_3x3_i16s_c16s

IMG_conv_3x3_i16s_c16s

Detailed Description

Functions

void IMG_conv_3x3_i16s_c16s (const short *restrict imgin_ptr, short *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Function Documentation

void IMG_conv_3x3_i16s_c16s | ( | const short *restrict | imgin_ptr,
 |  | short *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts three rows of 'pitch' input pixels and produces one row of 'width' output pixels using the three pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 9 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to a 16-bit range prior to storing in the output array. The stored result is saturated accordingly. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is covered.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 16-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The output image array must be 32-bit aligned
  • The mask and input image array must be 16-bit aligned.
  • The width parameter must be a non-zero multiple of 2
  • The image pitch must be greater than or equal to the width and a multiple of 2
  • Internal accuracy of the computations is 32 bits. To ensure correctness on a 16 bit input data, the maximum permissible filter gain in terms of bits is 16-bits i.e. the cumulative sum of the absolute values of the filter coefficients should not exceed 2^16 - 1.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_conv_3x3_i8_c8s

IMG_conv_3x3_i8_c8s

Detailed Description

Defines

#define | IMG_CONV_3X3_I8_C8S_H_ 1

Functions

void | IMG_conv_3x3_i8_c8s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const char *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_3X3_I8_C8S_H_ 1

Definition at line 42 of file c64P/IMG_conv_3x3_i8_c8s.h.

Function Documentation

void IMG_conv_3x3_i8_c8s | ( | const unsigned char *restrict | imgin_ptr,
 |  | unsigned char *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const char *restrict | mask_ptr,
 |  | short | shift
 | ) |  |

Description:
The convolution kernel accepts three rows of 'pitch' input pixels and produces one row of 'width' output pixels using the three pixel square filter mask provided on input.
The input mask is rotated 180 degrees prior to calculating the convolution sum. The convolution sum is calculated as a point by point multiplication of the rotated mask with the input image. The 9 resulting multiplications are summed together to produce a 32-bit intermediate sum. Overflow during accumulation is not prevented, though assumptions may be applied to filter gain to avoid overflow.
The user defined shift value is used to shift the convolution sum down to an 8-bit range prior to storing in the output array. The stored result is saturated as an unsigned 8-bit quantity. The mask is moved one column at a time, advancing the mask over the image until the entire 'width' is processed.
Parameters:
imgin_ptr | Pointer to an input image of 8-bit pixels
imgout_ptr | Pointer to an output image of 8-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to an 8-bit filter mask
shift | User specified right shift on sum
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 32-bit aligned
  • The width parameter must be a non-zero multiple of 4
  • The image pitch must be greater than or equal to the width
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x/C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_11x11_i16s_c16s

IMG_corr_11x11_i16s_c16s

Detailed Description

Functions

void IMG_corr_11x11_i16s_c16s (const short *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift, int round)

Function Documentation

void IMG_corr_11x11_i16s_c16s | ( | const short *restrict | imgin_ptr,
 |  | int *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | short | shift,
 |  | int | round
 | ) |  |

Description:
The convolution kernel accepts eleven rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 11 pixel square filter mask provided on input.
The correlation sum is calculated as a point by point multiplication of the 11x11 mask with the input image. The 121 resulting multiplications are summed together to produce a 40-bit intermediate sum. A rounding constant is added to the sum and then right-shifted to produce a 32-bit output value that is subsequently stored in the output array. Overflow and saturation of the accumulated sum are not explicitly prevented, however assumptions are made on filter gain to avoid them.
The mask is moved one column at a time, advancing the mask over the entire image until the entire 'width' is covered. The mask and the input image pixels are both provided as 16-bit signed values, while the output pixels are 32-bit signed. The mask chosen for correlation is typically part of the input image or another image.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 32-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
round | User specified round value
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 64-bit aligned
  • The input and mask arrays must be 16-bit aligned
  • The image pitch must be greater than or equal to the width
  • The width parameter must be a non-zero multiple of 2
  • Internal accuracy of the computations is 40 bits.
  • Shift should be selected to ensure a 32-bit result. Overflows are not handled.
  • Valid filter mask co-efficient range is -32767 to 32767.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_11x11_i8_c16s

IMG_corr_11x11_i8_c16s

Detailed Description

Functions

void IMG_corr_11x11_i8_c16s (const unsigned char *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr)

Function Documentation

void IMG_corr_11x11_i8_c16s | ( | const unsigned char *restrict | imgin_ptr,
 |  | int *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr
 | ) |  |

Description:
The convolution kernel accepts eleven rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 11 pixel square filter mask provided on input.
The correlation sum is calculated as a point by point multiplication of the 11x11 mask with the input image. The 121 resulting multiplications are summed together to produce a 32-bit sum. This 32-bit sum is stored in the output array. Overflow of the accumulated sum is not possible.
The mask is moved one column at a time, advancing the mask over the entire image until the entire 'width' is covered. The mask is provided as 16-bit signed values and the input image pixels are 8-bit unsigned. The output pixels will be 32-bit signed values. The mask chosen for correlation is typically part of the input image or another image.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 32-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 64-bit aligned
  • The mask arrays must be 16-bit aligned
  • The input image array has no alignment requirements
  • The image pitch must be greater than or equal to the width
  • The width parameter must be a non-zero multiple of 2
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_5x5_i16s_c16s

IMG_corr_5x5_i16s_c16s

Detailed Description

Functions

void IMG_corr_5x5_i16s_c16s (const short *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift, int round)

Function Documentation

void IMG_corr_5x5_i16s_c16s | ( | const short *restrict | imgin_ptr,
 |  | int *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | short | shift,
 |  | int | round
 | ) |  |

Description:
The convolution kernel accepts five rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 5 pixel square filter mask provided on input.
The correlation sum is calculated as a point by point multiplication of the 5x5 mask with the input image. The 25 resulting multiplications are summed together to produce a 40-bit intermediate sum. A rounding constant is added to the sum and then right-shifted to produce a 32-bit output value that is subsequently stored in the output array. Overflow and saturation of the accumulated sum are not explicitly prevented, however assumptions are made on filter gain to avoid them.
The mask is moved one column at a time, advancing the mask over the entire image until the entire 'width' is covered. The mask and the input image pixels are both provided as 16-bit signed values, while the output pixels are 32-bit signed. The mask chosen for correlation is typically part of the input image or another image.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 32-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
round | User specified round value
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 64-bit aligned
  • The input and mask arrays must be 16-bit aligned
  • The image pitch must be greater than or equal to the width
  • The width parameter must be a non-zero multiple of 2
  • Internal accuracy of the computations is 40 bits. To ensure correctness on a 16 bit input data, the maximum permissible filter gain in terms of bits is 24-bits i.e. the cumulative sum of the absolute values of the filter coefficients should not exceed 2^24 - 1.
  • Shift should be selected to ensure a 32-bit result. Overflows are not handled.
  • Valid filter mask co-efficient range is -32767 to 32767.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_3x3_i16_c16

IMG_corr_3x3_i16_c16

Detailed Description

Functions

void IMG_corr_3x3_i16_c16 (const unsigned short *imgin_ptr, unsigned int *restrict imgout_ptr, const unsigned short *mask_ptr, short pitch, short width)

Function Documentation

void IMG_corr_3x3_i16_c16 | ( | const unsigned short * | imgin_ptr,
 |  | unsigned int *restrict | imgout_ptr,
 |  | const unsigned short * | mask_ptr,
 |  | short | pitch,
 |  | short | width
 | ) |  |

Description:
The convolution kernel accepts three rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 3 pixel square filter mask provided on input.
The correlation sum is calculated as a point by point multiplication of the 3x3 mask with the input image. The 9 resulting multiplications are summed together to produce a 40-bit intermediate sum. This sum is used to produce the 32-bit output value that is subsequently stored in the output array. Overflow and saturation of the accumulated sum are not explicitly prevented, however assumptions may be made on filter gain to avoid them.
The mask is moved one column at a time, advancing the mask over the entire image until the entire 'width' is covered. The mask and the input image pixels are both provided as 16-bit unsigned values, while the output pixels are 32-bit signed. The mask chosen for correlation is typically part of the input image or another image.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit unsigned pixels
imgout_ptr | Pointer to an output image of 32-bit pixels
mask_ptr | Pointer to a 16-bit unsigned filter mask
pitch | Number of columns in the image
width | Number of output pixels
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The input, output and mask arrays have no alignment requirements
  • The image pitch must be greater than or equal to the width
  • The width parameter must be a non-zero multiple of 4
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_3x3_i16s_c16s

IMG_corr_3x3_i16s_c16s

Detailed Description

Functions

void IMG_corr_3x3_i16s_c16s (const short *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift, int round)

Function Documentation

void IMG_corr_3x3_i16s_c16s | ( | const short *restrict | imgin_ptr,
 |  | int *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr,
 |  | short | shift,
 |  | int | round
 | ) |  |

Description:
The convolution kernel accepts three rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 3 pixel square filter mask provided on input.
The correlation sum is calculated as a point by point multiplication of the 3x3 mask with the input image. The 9 resulting multiplications are summed together to produce a 40-bit intermediate sum. A rounding constant is added to the sum and then right-shifted to produce a 32-bit output value that is subsequently stored in the output array. Overflow and saturation of the accumulated sum are not explicitly prevented, however assumptions are made on filter gain to avoid them.
The mask is moved one column at a time, advancing the mask over the entire image until the entire 'width' is covered. The mask and the input image pixels are both provided as 16-bit signed values, while the output pixels are 32-bit signed. The mask chosen for correlation is typically part of the input image or another image.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 32-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
shift | User specified right shift on sum
round | User specified round value
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 64-bit aligned
  • The input and mask arrays must be 16-bit aligned
  • The image pitch must be greater than or equal to the width
  • The width parameter must be a non-zero multiple of 4
  • Internal accuracy of the computations is 40 bits. To ensure correctness on a 16 bit input data, the maximum permissible filter gain in terms of bits is 24-bits i.e. the cumulative sum of the absolute values of the filter coefficients should not exceed 2^24 - 1.
  • Shift should be selected to ensure a 32-bit result. Overflows are not handled.
  • Valid filter mask co-efficient range is -32767 to 32767.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_3x3_i8_c16s

IMG_corr_3x3_i8_c16s

Detailed Description

Functions

void IMG_corr_3x3_i8_c16s (const unsigned char *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr)

Function Documentation

void IMG_corr_3x3_i8_c16s | ( | const unsigned char *restrict | imgin_ptr,
 |  | int *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const short *restrict | mask_ptr
 | ) |  |

Description:
The convolution kernel accepts three rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 3 pixel square filter mask provided on input.
The correlation sum is calculated as a point by point multiplication of the 3x3 mask with the input image. The 9 resulting multiplications are summed together to produce a 32-bit sum. This 32-bit sum is stored in the output array. Overflow of the accumulated sum is not possible.
The mask is moved one column at a time, advancing the mask over the entire image until the entire 'width' is covered. The mask is provided as 16-bit signed values and the input image pixels are 8-bit unsigned. The output pixels will be 32-bit signed values. The mask chosen for correlation is typically part of the input image or another image.
Parameters:
imgin_ptr | Pointer to an input image of 16-bit pixels
imgout_ptr | Pointer to an output image of 32-bit pixels
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to a 16-bit filter mask
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The output array must be 64-bit aligned
  • The mask array must be 16-bit aligned
  • The input image array has no alignment requirements
  • The image pitch must be greater than or equal to the width
  • The width parameter must be a non-zero multiple of 2
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_3x3_i8_c8

IMG_corr_3x3_i8_c8

Detailed Description

Functions

void IMG_corr_3x3_i8_c8 (const unsigned char *imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const unsigned char *mask_ptr, short shift, int round)

Function Documentation

void IMG_corr_3x3_i8_c8 | ( | const unsigned char * | imgin_ptr,
 |  | int *restrict | imgout_ptr,
 |  | short | width,
 |  | short | pitch,
 |  | const unsigned char * | mask_ptr,
 |  | short | shift,
 |  | int | round
 | ) |  |

Description:
The convolution kernel accepts three rows of 'pitch' input pixels and produces one row of 'width' output pixels using the 3 pixel square filter mask provided on input.
The correlation sum is calculated as a point by point multiplication of the 3x3 mask with the input image. The 9 resulting multiplications are summed together to produce a 32-bit sum. This 32-bit sum is rounded using the input rounding constant and shifted before being stored to the output array.
The mask is moved one column at a time, advancing the mask over the entire image until the entire 'width' is covered. When 'width' is larger than 'pitch', multiple rows are processed. An application may call this kernel once per row to calculate the correlation for an entire image, or the kernel may be invoked for multiple rows at simultaneously. In the latter case, the two outputs at the end of each row will have meaningless values and the application will have to account for this when interpreting the results.
The mask and input image are provided as 8-bit unsigned values. The output pixels will be 32-bit signed values. The mask chosen for correlation is typically part of the input image or another image.
Parameters:
imgin_ptr | Pointer 8-bit input image
imgout_ptr | Pointer 32-bit output image
width | Number of output pixels
pitch | Number of columns in the image
mask_ptr | Pointer to 8-bit filter mask
shift | User specified right shift on sum
round | User specified round value
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The mask array has no alignment requirements
  • The input and output image arrays have no alignment requirements
  • The image pitch must must be a multiple of 2 greater than 2
  • The width parameter must be a non-zero multiple of 4
  • The image pitch must be greater than or equal to the width
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_gen_i16s_c16s

IMG_corr_gen_i16s_c16s

Detailed Description

Functions

void IMG_corr_gen_i16s_c16s (short *restrict x, short *restrict h, short *restrict y, int m, int pitch)

Function Documentation

void IMG_corr_gen_i16s_c16s | ( | short *restrict | x,
 |  | short *restrict | h,
 |  | short *restrict | y,
 |  | int | m,
 |  | int | pitch
 | ) |  |

Description:
This routine performs a generalized correlation with a 1 by M tap filter. It can be called repetitively to form an arbitrary MxN 2D generalized correlation kernel. The correlation sum is stored as half words. The input pixel and mask coefficient are assumed to be in signed 16-bit format. No restrictions apply to 'pitch' and 'M'.
Parameters:
x | Pointer to an input image of 16-bit pixels
h | Pointer to a 16-bit linear (1xM) filter mask
y | Output correlation sum(s)
m | Length of linear filter (taps)
pitch | Number of columns in input image
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The input array must be 32-bit aligned
  • The output array must be 64-bit aligned
  • The mask array must be 16-bit aligned
  • The internal accuracy is 16 bits. The convloution sum should not exceed 16 bits (signed).
  • The output array size must have at least (pitch - M + 8) elements
  • The pitch parameter must be greater than the filter length (M)
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_corr_gen_iq

IMG_corr_gen_iq

Detailed Description

Functions

void IMG_corr_gen_iq (const int *restrict x, const short *restrict h, int *restrict y, int m, int pitch, int x_qpt, int h_qpt, int y_qpt)

Function Documentation

void IMG_corr_gen_iq | ( | const int *restrict | x,
 |  | const short *restrict | h,
 |  | int *restrict | y,
 |  | int | m,
 |  | int | pitch,
 |  | int | x_qpt,
 |  | int | h_qpt,
 |  | int | y_qpt
 | ) |  |

Description:
The routine performs a generalized correlation with a 1 by M tap filter. It can be called N times repetitively to form an arbitrary MxN 2D generalized correlation kernel. Input image data, mask data and output data are all in Q-format as specified by the inputs x_qpt, h_qpt and y_qpt respectively. The input image and output array are both 32-bit data and the mask array is 16-bit. The intermediate correlation sum is accumulated as a 64-bit value in an intermediate Q-format. This sum is shifted to get the final output in the specified output Q-format. For an imput image with 'pitch' columns and a mask of length 'm' the output array must be allocated for at least (pitch - m) elements.
Overflow may occur while accumulating the intermediate sum in 64- bits or while converting the intermediate sum to the final 32-bit sum. In either case, no saturation is performed by the routine.
Parameters:
x | Pointer to one row of image pixels
h | Pointer to a 16-bit linear (1xM) filter mask
y | Output correlation sum(s)
m | Length of linear filter (taps)
pitch | Number of columns in input image
x_qpt | Q-format of input image array
h_qpt | Q-format of mask array
y_qpt | Q-format of output array
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input, output and mask arrays should not overlap
  • The input, output and mask arrays should be 64-bit aligned
  • The input and output Q-formats should follow the relation: x_qpt + h_qpt >= y_qpt
  • The length of the filter mask (m) must be a positive multiple of 2
  • The number of columns in the input image (pitch) must satisfy the relation: pitch >= m + 2
  • Internal accuracy of the computations is 64-bit. To ensure correctness on 32-bit input data, the maximum permissible filter gain in terms of bits is 32 (i.e. the cumulative sum of the absolute values of the filter coefficients should not exceed 2^32 - 1)
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_dilate_bin

IMG_dilate_bin

Detailed Description

Functions

void IMG_dilate_bin (const unsigned char *restrict in_data, unsigned char *restrict out_data, const char *restrict mask, int cols)

Function Documentation

void IMG_dilate_bin | ( | const unsigned char *restrict | in_data,
 |  | unsigned char *restrict | out_data,
 |  | const char *restrict | mask,
 |  | int | cols
 | ) |  |

Description:
The function IMG_dilate_bin() implements binary dilation using an arbitrary 3x3 mask. The dilation operator generates output pixels by ORing the pixels under the input mask together to generate the output pixel. The input mask specifies whether one or more pixels from the input are to be ignored.
Parameters:
in_data | Input image pointer (packed binary)
out_data | Output image pointer (packed binary)
mask | Dilation filter mask
cols | Number of columns in the image
Algorithm:
The filtering operation for a pixel at (x, y) works as illustrated by the following pseudo-code:
result = 0; if (mask[0][0] != DONT_CARE) result |= input[y + 0][x + 0]; if (mask[0][1] != DONT_CARE) result |= input[y + 1][x + 1]; if (mask[0][2] != DONT_CARE) result |= input[y + 2][x + 2]; if (mask[1][0] != DONT_CARE) result |= input[y + 0][x + 0]; if (mask[1][1] != DONT_CARE) result |= input[y + 1][x + 1]; if (mask[1][2] != DONT_CARE) result |= input[y + 2][x + 2]; if (mask[2][0] != DONT_CARE) result |= input[y + 0][x + 0]; if (mask[2][1] != DONT_CARE) result |= input[y + 1][x + 1]; if (mask[2][2] != DONT_CARE) result |= input[y + 2][x + 2]; output[y][x] = result;

For the above code, "DONT_CARE" is specified by a negative value in the input mask. Non-negative values in the mask cause the corresponding pixel to be included in the dilation operation.
Note that this code operates on a bitmap where each pixel is represented as a single bit within a byte or word. Although the pseudo-code above operates only on one pixel at a time, with a single pixel in each array element, the implementation operates on a bitmap which contains 8 binary pixels per byte.
Pixels are organized within each byte such that the pixel with the smallest index is in the LSB, and the pixel with the largest index is in the MSB. (That is, the code assumes a LITTLE ENDIAN bit ordering.)
Note that the "cols" argument actually specifies the number of BYTES in the output, not the number of columns. The number of columns is 8 times this argument.
The 3x3 dilation mask is applied to 32 output pixels simultaneously. This is achieved via the 32-bit bitwise operators in the register file. To accomlish this, the code reads in a 34-bit input window, and 40-bit operations are used to manipulate the pixels initially.
Because the code reads a 34-bit context for each 32-bits of output, the input needs to be one byte longer than the output in order to make the rightmost two pixels well-defined.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Negative values in the mask specify "DONT_CARE", and non-negative values specify that pixels are included in the dilation operation.
  • The input image needs to have a multiple of 64 pixels (bits) per row. As such, the number of columns (cols) must be a multiple of 8.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code will work for little endian only
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_erode_bin

IMG_erode_bin

Detailed Description

Functions

void IMG_erode_bin (const unsigned char *restrict in_data, unsigned char *restrict out_data, const char *restrict mask, int cols)

Function Documentation

void IMG_erode_bin | ( | const unsigned char *restrict | in_data,
 |  | unsigned char *restrict | out_data,
 |  | const char *restrict | mask,
 |  | int | cols
 | ) |  |

Description:
The function IMG_erode_bin() implements binary erosion using an arbitrary 3x3 mask. The erosion operator generates output pixels by ANDing the pixels under the input mask together to generate the output pixel. The input mask specifies whether one or more pixels from the input are to be ignored.
Parameters:
in_data | Input image pointer (packed binary)
out_data | Output image pointer (packed binary)
mask | Erosion filter mask
cols | Number of columns in the image
Algorithm:
The filtering operation for a pixel at (x, y) works as illustrated by the following pseudo-code:
result = 1; if (mask[0][0] != DONT_CARE) result &= input[y + 0][x + 0]; if (mask[0][1] != DONT_CARE) result &= input[y + 1][x + 1]; if (mask[0][2] != DONT_CARE) result &= input[y + 2][x + 2]; if (mask[1][0] != DONT_CARE) result &= input[y + 0][x + 0]; if (mask[1][1] != DONT_CARE) result &= input[y + 1][x + 1]; if (mask[1][2] != DONT_CARE) result &= input[y + 2][x + 2]; if (mask[2][0] != DONT_CARE) result &= input[y + 0][x + 0]; if (mask[2][1] != DONT_CARE) result &= input[y + 1][x + 1]; if (mask[2][2] != DONT_CARE) result &= input[y + 2][x + 2]; output[y][x] = result;

For the above code, "DONT_CARE" is specified by a negative value in the input mask. Non-negative values in the mask cause the corresponding pixel to be included in the erosion operation.
Note that this code operates on a bitmap where each pixel is represented as a single bit within a byte or word. Although the pseudo-code above operates only on one pixel at a time, with a single pixel in each array element, the implementation operates on a bitmap which contains 8 binary pixels per byte.
Pixels are organized within each byte such that the pixel with the smallest index is in the LSB, and the pixel with the largest index is in the MSB. (That is, the code assumes a LITTLE ENDIAN bit ordering.)
Note that the "cols" argument actually specifies the number of BYTES in the output, not the number of columns. The number of columns is 8 times this argument.
The 3x3 erosion mask is applied to 32 output pixels simultaneously. This is achieved via the 32-bit bitwise operators in the register file. To accomlish this, the code reads in a 34-bit input window, and 40-bit operations are used to manipulate the pixels initially.
Because the code reads a 34-bit context for each 32-bits of output, the input needs to be one byte longer than the output in order to make the rightmost two pixels well-defined.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Negative values in the mask specify "DONT_CARE", and non-negative values specify that pixels are included in the erosion operation.
  • The input image needs to have a multiple of 64 pixels (bits) per row. As such, the number of columns (cols) must be a multiple of 8.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code will work for little endian only
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_errdif_bin_16

IMG_errdif_bin_16

Detailed Description

Functions

void IMG_errdif_bin_16 (unsigned short *restrict errdif_data, int cols, int rows, short *restrict err_buf, unsigned short thresh)

Function Documentation

void IMG_errdif_bin_16 | ( | unsigned short *restrict | errdif_data,
 |  | int | cols,
 |  | int | rows,
 |  | short *restrict | err_buf,
 |  | unsigned short | thresh
 | ) |  |

Description:
The code implements the Binary Floyd-Steinberg error diffusion filter. The filter kernel used is this one:

                                   +---+
                                 P | 7 |
                           +---+---+---+
                           | 3 | 5 | 1 |
                           +---+---+---+
Pixels are processed from left-to-right, top-to-bottom. Each pixel is compared against a user-defined threshold. Pixels that are larger than the threshold are set to 255, and pixels that are smaller or equal to the threshold are set to 0. The error value for the pixel (eg. the difference between the thresholded pixel and its original grey level) is propagated to the neighboring pixels according to the filter above. This error propagation diffuses the error over a larger area, hence the term "error diffusion."
Parameters:
errdif_data | Pointer to an input/output image
cols | Number of columns (Width)
rows | Number of rows (Height)
err_buf | Row-to-row error buffer
thresh | Threshold in range [0x00, 0xFF]
Algorithm:
The processing of the filter itself is inverted so that the errors from previous pixels "propagate into" a given pixel at the time the pixel is processed, rather than "accumulate into" a pixel as its neighbors are processed. This allows us to keep our image as an 8-bit image, and reduces the number of accesses to the image array. The inverted filter kernel performs identically to the kernel's original form. In this form, the weights specify the weighting assigned to the errors coming from the neighboring pixels.

                           +---+---+---+
                           | 1 | 5 | 3 |
                           +---+---+---+
                           | 7 | P
                           +---+
Assumptions:
  • Input and Output buffers do not overlap
  • "cols" must be even
  • "err_buf" must be initialized to zeros for the first call and the returned err_buf should be used for any subsequent calls
  • This code assumes a LITTLE ENDIAN configuration
  • This kernel places no restrictions on the alignment of its input
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • No bank conflicts occur
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_errdif_bin_8

IMG_errdif_bin_8

Detailed Description

Functions

void IMG_errdif_bin_8 (unsigned char *restrict errdif_data, int cols, int rows, short *restrict err_buf, unsigned char thresh)

Function Documentation

void IMG_errdif_bin_8 | ( | unsigned char *restrict | errdif_data,
 |  | int | cols,
 |  | int | rows,
 |  | short *restrict | err_buf,
 |  | unsigned char | thresh
 | ) |  |

Description:
The code implements the Binary Floyd-Steinberg error diffusion filter. The filter kernel used is illustrated below:

                                   +---+
                                 P | 7 |
                           +---+---+---+
                           | 3 | 5 | 1 |
                           +---+---+---+
Pixels are processed from left-to-right, top-to-bottom. Each pixel is compared against a user-defined threshold. Pixels that are larger than the threshold are set to 255, and pixels that are smaller or equal to the threshold are set to 0. The error value for the pixel (eg. the difference between the thresholded pixel and its original grey level) is propagated to the neighboring pixels according to the filter above. This error propagation diffuses the error over a larger area, hence the term "error diffusion."
Parameters:
errdif_data | Pointer to an input/output image
cols | Number of columns (Width)
rows | Number of rows (Height)
err_buf | Row-to-row error buffer
thresh | Threshold in range [0x00, 0xFF]
Algorithm:
The processing of the filter itself is inverted so that the errors from previous pixels "propagate into" a given pixel at the time the pixel is processed, rather than "accumulate into" a pixel as its neighbors are processed. This allows us to keep our image as an 8-bit image, and reduces the number of accesses to the image array. The inverted filter kernel performs identically to the kernel's original form. In this form, the weights specify the weighting assigned to the errors coming from the neighboring pixels.

                           +---+---+---+
                           | 1 | 5 | 3 |
                           +---+---+---+
                           | 7 | P
                           +---+
Assumptions:
  • "err_buf" must be initialized to zeros for the first call and the returned err_buf should be used for any subsequent calls
  • The size of "err_buf" should be (cols+1) bytes
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_fdct_8x8

IMG_fdct_8x8

Detailed Description

Functions

void IMG_fdct_8x8 (short fdct_data[], unsigned num_fdcts)

Function Documentation

void IMG_fdct_8x8 | ( | short | fdct_data[],
 |  | unsigned | num_fdcts
 | ) |  |

Description:
The fdct_8x8 function implements a Chen FDCT. Output values are rounded, providing improved accuracy. Input terms are expected to be signed 11Q0 values, producing signed 15Q0 results. (A smaller dynamic range may be used on the input, producing a correspondingly smaller output range. Typical applications include processing signed 9Q0 and unsigned 8Q0 pixel data, producing signed 13Q0 or 12Q0 outputs, respectively.) No saturation is performed.
The fdct routine accepts a list of 8x8 pixel blocks and performs FDCTs on each. The array should be laid out as "fdct_data[num_fdcts][8][8]". All operations in this array are performed in-place. Input values must be in the range [-512,511]. Larger input values may result in overflow.

Note: This code guarantees correct operation, even in the case that "num_fdcts" is zero. In this case, the function runs for 13 cycles (counting 6 cycles of function-call overhead), due to early-exit code. The early-exit case performs one access to the "fdct_data" array and no access to the stack.

Parameters:
fdct_data | Pointer to 8x8 DCT blocks
num_fdcts | Number of DCT blocks
Algorithm:
The loop nest in the vertical pass has been collapsed into a single-level loop. Both vertical and horizontal loops have been software pipelined.
For performance, portions of the code outside the loops have been inter- scheduled with the prolog and epilog code of the loops. Also, twin stack-pointers are used to accelerate stack accesses. Finally, pointer values and cosine term registers are reused between the horizontal and vertical loops to reduce the impact of pointer and constant reinitialization.
To save code size, prolog and epilog collapsing have been performed to the extent that it does not impact performance.
To reduce register pressure and save some code, the horizontal loop uses the same pair of pointer register for both reading and writing. The pointer increments are on the LDs to permit prolog and epilog collapsing, since LDs can be speculated.
Assumptions:
  • The stack must be 64-bit aligned
  • The "fdct_data" array is laid out as fdct_data[num_fdcts][8][8]
  • Values in "fdct_data" are in the range [-512,511]
  • The "fdct_data" array must be 64-bit aligned
Implementation Notes:
  • This code is fully interruptible
  • This code requires four words of stack for Save-On-Entry registers
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_histogram_16

IMG_histogram_16

Detailed Description

Functions

void IMG_histogram_16 (unsigned short *restrict image, int n, int accumulate, short *restrict t_hist, short *restrict hist, int img_bits)

Function Documentation

void IMG_histogram_16 | ( | unsigned short *restrict | image,
 |  | int | n,
 |  | int | accumulate,
 |  | short *restrict | t_hist,
 |  | short *restrict | hist,
 |  | int | img_bits
 | ) |  |

Description:
This code calculates the histogram of an image array "image" containing "n" pixels, with "img_bits" valid data bits per pixel. It returns a histogram with 2^img_bits bins, one for each of the possible pixel values based on the precision.
The routine can either add-to or subtract-from an existing histogram, through the "accumulate" control. The implementation requires temporary storage for 4 scratch histograms, to reduce bank conflicts.
The length of the "hist" and "t_hist" arrays depend on the pixel precision as specified by "img_bits". The length of "hist" is 2^img_bits and that of "t_hist" is 2^(img_bits+2)
Parameters:
image | Input image pointer containing "n" unsigned 8-bit pixels
n | Size of image in pixels
accumulate | Control to add or subtract from the running histogram. This control is only defined for the values 1 and -1 for ADD and SUBTRACT respectively
t_hist | Scratch buffer for temporary histogram storage (SIZE: 2^(img_bits+2))
hist | Running histogram bins (SIZE: 2^img_bits)
img_bits | Number of valid data bits per pixel
Algorithm:
This code operates on four interleaved histogram bins. The loop is divided into two halves: The "even" half operates on the even-numbered double-words from the input image, and the "odd" half operates on odd double-words. Each half processes four pixels at a time, and both halves operate on the same four sets of histogram bins. This introduces a memory dependency on the histogram bins which ordinarily would degrade performance. To break the memory depenencies, the two halves forward their results to each other via the register file, bypassing memory.
Exact memory access ordering obviates the need to predicate stores within the loop.
The algorithm is ordered as follows:
  1. Load from histogram for even half
  2. Store odd_bin to histogram for odd half (previous iteration)
  3. IF data_even == previous data_odd THEN increment even_bin by 2 ELSE increment even_bin by 1, forward to odd
  4. Load from histogram for odd half (current iteration)
  5. Store even_bin to histogram for even half
  6. IF data_odd == previous data_even THEN increment odd_bin by 2 ELSE increment odd_bin by 1, forward to even
  7. Repeat from 1
With this particular ordering, forwarding is necessary between the even and odd halves when pixels in adjacent halves fall in the same bin. The store is never predicated and occurs speculatively as it will be overwritten by the next value containing the extra forwarded value.
The four scratch histograms are interleaved with each bin spaced four half words apart and each histogram starting in a different memory bank. This allows the four histogram accesses to proceed in any order without worrying about bank conflicts. The diagram below illustrates this: (addresses are halfword offsets)
         0       1       2       3       4       5       6   ...
     | hst 0 | hst 1 | hst 2 | hst 3 | hst 0 | hst 1 | ...   ...
     | bin 0 | bin 0 | bin 0 | bin 0 | bin 1 | bin 1 | ...   ...
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The image and output histogram arrays do not overlap
  • The temporary array, t_hist, is initialized to zero for the first call to the routine (for "accumulate")
  • All arrays (image and histogram) are 64-bit aligned
  • The number of pixels is a non-zero multiple of 8.
  • The number of bits per pixel, "img_bits" is between 1 and 16 (inclusive)
  • The maximum count per bin is 32767
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • No bank conflicts should occur in this code
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_histogram_8

IMG_histogram_8

Detailed Description

Functions

void IMG_histogram_8 (const unsigned char *restrict image, int n, short accumulate, short *restrict t_hist, short *restrict hist)

Function Documentation

void IMG_histogram_8 | ( | const unsigned char *restrict | image,
 |  | int | n,
 |  | short | accumulate,
 |  | short *restrict | t_hist,
 |  | short *restrict | hist
 | ) |  |

Description:
This code takes a histogram of an array of n, 8 bit inputs. It returns the histogram of 256 bins at 16 bit precision. It can either add-to or subtract-from an existing histogram via the 'accumulate' control. The implementation requires temporary storage for 4 256-bin histograms which are summed for the final result.
Parameters:
image | Input image pointer containing "n" unsigned 8-bit pixels
n | Size of image in pixels
accumulate | Control to add or subtract from the running histogram. This control is only defined for the values 1 and -1 for ADD and SUBTRACT respectively
t_hist | Scratch buffer for temporary histogram storage (1024 bytes)
hist | Running histogram bins (256)
Algorithm:
This code operates on four interleaved histogram bins. The loop is divided into two halves. The even half operates on even words of pixels and the odd half operates on odd words. Both halves utilize the same 4 histogram bins. This introduces a memory dependency which would ordinarily degrade performance. To break the memory depenencies, the two halves forward their results to each other. Exact memory access ordering obviates the need to predicate stores.
The algorithm is ordered as follows:
  1. Load from histogram for even half
  2. Store odd_bin to histogram for odd half (previous iteration)
  3. IF data_even == previous data_odd THEN increment even_bin by 2 ELSE increment even_bin by 1, forward to odd
  4. Load from histogram for odd half (current iteration)
  5. Store even_bin to histogram for even half
  6. IF data_odd == previous data_even THEN increment odd_bin by 2 ELSE increment odd_bin by 1, forward to even
  7. Repeat from 1.
With this particular ordering, forwarding is necessary between the even and odd halves when pixels in adjacent halves fall in the same bin. The store is never predicated and occurs speculatively as it will be overwritten by the next value containing the extra forwarded value.
The four scratch histograms are interleaved with each bin spaced four half words apart and each histogram starting in a different memory bank. This allows the four histogram accesses to proceed in any order without worrying about bank conflicts. The diagram below illustrates this: (addresses are halfword offsets)
         0       1       2       3       4       5       6   ...
     | hst 0 | hst 1 | hst 2 | hst 3 | hst 0 | hst 1 | ...   ...
     | bin 0 | bin 0 | bin 0 | bin 0 | bin 1 | bin 1 | ...   ...
Assumptions:
  • The temporary array, t_hist, is initialized to zero for the first call to the routine (for "accumulate")
  • The input array of image data is aligned on a 4 byte boundary
  • The number of pixels is a non-zero multiple of 8.
  • The maximum bin number is 32767.
  • The maximum n is 262143.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • No bank conflicts should occur in this code
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_idct_8x8_12q4

IMG_idct_8x8_12q4

Detailed Description

Functions

void IMG_idct_8x8_12q4 (short idct_data[], unsigned num_idcts)

Function Documentation

void IMG_idct_8x8_12q4 | ( | short | idct_data[],
 |  | unsigned | num_idcts
 | ) |  |

Description:
The idct_8x8_12q4 algorithm performs an IEEE-1180 compliant IDCT, complete with rounding and saturation to signed 9-bit quantities. The input coefficients are assumed to be signed 16-bit DCT coefficients in 12Q4 format.
The idct_8x8_12q4 routine accepts a list of 8x8 DCT coeffient blocks and performs IDCTs on each. The array should be aligned to a 64-bit boundary, and be laid out as "idct_data[num_idcts][8][8]". Input data must be in 12Q4 format. The routine operates entirely in-place, requiring no additional storage for intermediate results.

Note: This code guarantees correct operation, even in the case that "num_idcts" is zero. In this case, the function runs for 13 cycles (counting 6 cycles of function-call overhead), due to early-exit code.

Parameters:
idct_data | Pointer to 8x8 IDCT coefficient blocks
num_idcts | Number of IDCT blocks
Algorithm:
All levels of looping are collapsed into single loops which are pipelined. The outer loop focuses on 8-pt IDCTs, whereas the inner loop controls the column-pointer to handle jumps between IDCT blocks. (The column-pointer adjustment is handled by a four-phase rotating "fixup" constant which takes the place of the original inner-loop).
For performance, portions of the outer-loop code have been inter-scheduled with the prologs and epilogs of both loops. Finally, cosine term registers are reused between the horizontal and vertical loops to save the need for reinitialization.
To save codesize, prolog and epilog collapsing have been performed to the extent that performance is not affected. The remaining prolog and epilog code has been interscheduled with code outside the loops to improve performance.
Additional section-specific optimization notes are provided below.
Assumptions:
  • The "idct_data" array is laid out as idct_data[num_idcts][8][8]
  • The "idct_data" array must be 64-bit aligned
  • This is a LITTLE ENDIAN implementation
Implementation Notes:
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
  • No bank conflicts occur
  • The code may perform speculative reads of up to 128 bytes beyond the end or before the start of the IDCT array. The speculatively accessed data is ignored
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_mad_16x16

IMG_mad_16x16

Detailed Description

Functions

void IMG_mad_16x16 (const unsigned char *restrict refImg, const unsigned char *restrict srcImg, int pitch, int h, int v, unsigned *restrict match)

Function Documentation

void IMG_mad_16x16 | ( | const unsigned char *restrict | refImg,
 |  | const unsigned char *restrict | srcImg,
 |  | int | pitch,
 |  | int | h,
 |  | int | v,
 |  | unsigned *restrict | match
 | ) |  |

Description:
This routine returns the location of the minimum absolute difference between a 16x16 search block and some block in a (h + 16) x (v + 16) search area. h and v are the sizes of the search space for the top left coordinate of the search block. refImg points to the top left pixel of the search area.

            (0,0)          (h,0)      (h+16,0)
              ;--------------+--------;
              ;    search    |        ;
              ;    space     |        ;
              ;              |        ;        search area
              ;--------------+        ;        within reference image
            (0,v)          (h,v)      ;
              ;                       ;
              ;-----------------------;
            (0, v+16)                 (v+16,h+16)
The location is returned relative to the above coordinate system as x and y packed in two 16-bit quantities in a 32-bit word:

                  31             16 15             0
                  +----------------+----------------+
        match[0]:  |       x        |       y        |
                  +----------------+----------------+

                  31                               0
                  +---------------------------------+
        match[1]:  |   SAD value at location x, y    |
                  +---------------------------------+

Parameters:
refImg | Reference image
srcImg | 16x16 block image to look for
pitch | Width of reference image
h | Horizontal size of search area
v | Vertical size of search area (must be a multiple of 2)
match | Result: match[0] is packed x, y match[1] is MAD value
Assumptions:
  • srcImg and refImg do not alias in memory
  • The routine is written for Little Endian configuration
  • Two MADS are performed together and hence it is assumed that the vertical dimension is a multiple of 2
Implementation Notes:
The two outer loops are merged, the two inner loops are merged. The inner loop process 2 lines of 2 search locations in parallel. The search is performed in top-to-bottom, left-to-right order, with the earliest match taking precedence in the case of ties. Further use is made of C64x specific instructions such as SUBABS4 and DOTPU4. The SUBABS4 takes the absolute difference on four 8 bit quantities packed into a 32 bit word. The DOTPU4 performs four 8 bit wide multiplies and adds the results together.
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_mad_8x8

IMG_mad_8x8

Detailed Description

Functions

void IMG_mad_8x8 (const unsigned char *ref_data, const unsigned char *src_data, int pitch, int sx, int sy, unsigned int *match)

Function Documentation

void IMG_mad_8x8 | ( | const unsigned char * | ref_data,
 |  | const unsigned char * | src_data,
 |  | int | pitch,
 |  | int | sx,
 |  | int | sy,
 |  | unsigned int * | match
 | ) |  |

Description:
This routine locates the position in a reference image which most closely matches an 8x8 block from a source image, using the Minimum Absolute Difference metric. Searches over a range that is 'sx' pixels wide and 'sy' pixels tall within a reference image that is 'pitch' pixels wide.
The search is performed in top-to-bottom, left-to-right order, with the earliest match taking precedence in the case of ties.
The match location as well as the Minimum Absolute Difference metric for the match are returned in the 'match' array. The first element contains the packed horizontal and vertical coordinates of the match, with the X coordinate in the upper halfword and the Y coordinate in the lower halfword. The second element contains the MAD value for this match location.
The reference image is an image of width 'pitch'. The mad_8x8 routine searches a (sx,sy) window within the image.
The source image is an 8x8 block of pixels which contain the image block that is being searched for.
The match[] array is where the best match location and MAD value for the best match are stored. The best match position and its absolute difference are returned in match, packed as follows:
                      31             16 15             0
                      +----------------+----------------+
          match[0]:  |    X offset    |    Y offset    |
                      +----------------+----------------+

                      31                               0
                      +---------------------------------+
          match[1]:  |   Minimum Absolute Difference    |
                      +---------------------------------+
Parameters:
ref_data | Reference image to search
src_data | Source 8x8 image block
pitch | Width of reference image
sx | Horizontal size of search area
sy | Vertical size of search area (must be a multiple of 2)
match | Result: match[0] is packed x, y match[1] is MAD value
Assumptions:
  • Src_data and match must be 16-bit aligned
  • The routine is written for Little Endian configuration
  • Two MADS are performed together and hence it is assumed that the vertical dimension is a multiple of 2
Implementation Notes:
The inner loops that perform the 8x8 mads are completely unrolled and the outer two loops are collpaesd together. In addition all source image data is pre-loaded into registers.
The data required for any one row is brought in using non-aligned loads. SUBABS4 and DOTPU4 are used together to do the MAD computation.
To save instructions and fit within an 8 cycle loop, the precise location of a given match is not stored. Rather, the loop iteration that it was encountered on is stored. A short divide loop after the search loop converts this value into X and Y coordinates for the location.
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
  • No bank conflicts occur for this kernel
  • No alignment is required for ref_data
  • This code suppresses interrupts for the entire duration of the call
  • This kernel is Little Endian only
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_median_3x3_16s

IMG_median_3x3_16s

Detailed Description

Functions

void IMG_median_3x3_16s (const short *restrict i_data, int n, short *restrict o_data)

Function Documentation

void IMG_median_3x3_16s | ( | const short *restrict | i_data,
 |  | int | n,
 |  | short *restrict | o_data
 | ) |  |

Description:
This kernel performs a 3x3 median filter operation on 16-bit signed image pixels. The grey level at each pixel is replaced by the median of nine adjacent values. The median of a set of nine numbers is the middle element so that half of the elements in the list are larger and half are smaller. The input image contains 3 adjacent rows from an actual image. The output array will be of size 1 row containing the median values of the middle row of the input. For the first two output's, the two columns outside the image are assumed to be all zeros.
The first 2 values in the output array will not contain any meaningful data. The 3rd value in the output array will be the median of 2nd value in the middle row of input array and so on. The nth value in the output array will be the median of the (n-1)th value in the mid row of input array. Hence the output array will not contain the median values of the first and last elements in the middle row of input image. Instead it will contain two meaningless values at the beginning of the array.
Parameters:
i_data | Input image containing 3 rows (i.e., size of 3 x n)
n | Width of input image in pixels
o_data | Output image containing 1 row (i.e., size of 1 x n)
Algorithm:
This implementation uses an incremental sorting technique to greatly reduce the number of compares and exchanges necessary to sort the image pixels.
The main loop reads three new pixels from the input image each iteration. These three pixels form the right edge of the filter mask. The filter data from the previous iteration is "slid over" by one pixel to form the complete 3x3 mask.
Each 3-pixel "column" is sorted as it is read in from the image, resulting in a "lo", "medium" and "hi" pixel value for the column. This results in a 3x3 filter mask with sorted columns or three rows -- a row of "minimums", a row of "middle values", and a row of "maximums".
The median filter operates from this partially ordered mask. It finds the smallest element in the row of "maximums", the middle element in the row of "middle values", and the largest element in the row of "minimums". The median value of these three values is the median for the entire 3x3 mask.
This process minimizes compares, as the whole mask does not need to be sorted between iterations. Rather, the partial ordering for two of the three columns from one iteration is used directly for the next iteration.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The minimum value for width of input image 'n' is 4
  • The width of input image 'n' must be a multiple of 4
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_median_3x3_16

IMG_median_3x3_16

Detailed Description

Functions

void IMG_median_3x3_16 (const unsigned short *restrict i_data, int n, unsigned short *restrict o_data)

Function Documentation

void IMG_median_3x3_16 | ( | const unsigned short *restrict | i_data,
 |  | int | n,
 |  | unsigned short *restrict | o_data
 | ) |  |

Description:
This kernel performs a 3x3 median filter operation on 16-bit unsigned image pixels. The grey level at each pixel is replaced by the median of nine adjacent values. The median of a set of nine numbers is the middle element so that half of the elements in the list are larger and half are smaller. Median filters remove the effects of extreme values from data, such as salt and pepper noise.
The input image contains 3 adjacent rows from an actual image. The output array will be a single row of the median values of the masked input. For the first two outputs, the two columns outside the image are assumed to be all zeros.
The first 2 values in the output array will not contain any meaningful data. The 3rd value in the output array will be the median of 2nd value in the middle row of input array and so on. The nth value in the output array will be the median of the (n-1)th value in the mid row of input array. Hence the output array will not contain the median values of the first and last elements in the middle row of input image. Instead it will contain two meaningless values at the beginning of the array.
Parameters:
i_data | Input image containing 3 rows (i.e., size of 3 x n)
n | Width of input image in pixels
o_data | Output image containing 1 row (i.e., size of 1 x n)
Algorithm:
This implementation uses an incremental sorting technique to greatly reduce the number of compares and exchanges necessary to sort the image pixels.
The main loop reads three new pixels from the input image each iteration. These three pixels form the right edge of the filter mask. The filter data from the previous iteration is "slid over" by one pixel to form the complete 3x3 mask.
Each 3-pixel "column" is sorted as it is read in from the image, resulting in a "lo", "medium" and "hi" pixel value for the column. This results in a 3x3 filter mask with sorted columns or three rows -- a row of "minimums", a row of "middle values", and a row of "maximums".
The median filter operates from this partially ordered mask. It finds the smallest element in the row of "maximums", the middle element in the row of "middle values", and the largest element in the row of "minimums". The median value of these three values is the median for the entire 3x3 mask.
This process minimizes compares, as the whole mask does not need to be sorted between iterations. Rather, the partial ordering for two of the three columns from one iteration is used directly for the next iteration.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • The minimum value for width of input image 'n' is 4
  • The width of input image 'n' must be a multiple of 4
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • No bank conflicts occur
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_median_3x3_8

IMG_median_3x3_8

Detailed Description

Functions

void IMG_median_3x3_8 (const unsigned char *restrict i_data, int n, unsigned char *restrict o_data)

Function Documentation

void IMG_median_3x3_8 | ( | const unsigned char *restrict | i_data,
 |  | int | n,
 |  | unsigned char *restrict | o_data
 | ) |  |

Description:
This kernel performs a 3x3 median filter operation on 8-bit unsigned image pixels. The median filter comes under the class of non-linear signal processing algorithms.
Rather than replace the grey level at a pixel by a weighted average of the nine pixels including and surrounding it, the grey level at each pixel is replaced by the median of the nine values. The median of a set of nine numbers is the middle element so that half of the elements in the list are larger and half are smaller. Median filters remove the effects of extreme values from data, such as salt and pepper noise. Using a large set of values may result in unacceptable blurring of sharp edges in the original image.
Parameters:
i_data | Input image containing 3 rows (i.e., size of 3 x n)
n | Width of input image in pixels
o_data | Output image containing 1 row (i.e., size of 1 x n)
Algorithm:
This implementation uses an incremental sorting technique to greatly reduce the number of compares and exchanges necessary to sort the image pixels.
The main loop reads three new pixels from the input image each iteration. These three pixels form the right edge of the filter mask. The filter data from the previous iteration is "slid over" by one pixel to form the complete 3x3 mask.
Each 3-pixel "column" is sorted as it is read in from the image, resulting in a "lo", "medium" and "hi" pixel value for the column. This results in a 3x3 filter mask with sorted columns or three rows -- a row of "minimums", a row of "middle values", and a row of "maximums".
The median filter operates from this partially ordered mask. It finds the smallest element in the row of "maximums", the middle element in the row of "middle values", and the largest element in the row of "minimums". The median value of these three values is the median for the entire 3x3 mask.
This process minimizes compares, as the whole mask does not need to be sorted between iterations. Rather, the partial ordering for two of the three columns from one iteration is used directly for the next iteration.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 32-bit aligned
  • The minimum value for width of input image 'n' is 4
  • The width of input image 'n' must be a multiple of 4
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_perimeter_16

IMG_perimeter_16

Detailed Description

Functions

int IMG_perimeter_16 (const unsigned short *restrict in, int cols, unsigned short *restrict out)

Function Documentation

int IMG_perimeter_16 | ( | const unsigned short *restrict | in,
 |  | int | cols,
 |  | unsigned short *restrict | out
 | ) |  |

Description:
This function returns the boundary pixels of an image. Each call of this function calculates one new line of output from a three line window of input.
The input pointer "in" points to the middle line of a three-line window of the image. The perimeter function scans this window looking for pixels in the middle row which are on the perimeter of the image. A pixel is considered to be on the perimeter of the image if the pixel itself is non-zero, but one of its neighbors is zero. The function returns the total count of perimeter pixels identified.
This particular implementation evaluates four neighbors for the perimeter test: The neighbors to the left, right, top and bottom.
Perimeter pixels retain their original grey level in the output. Non-perimeter pixels are set to zero in the output. Pixels on the far left and right edges of a row are defined *not* being on the perimeter and, as such, are always forced to zero.
Parameters:
in | Pointer to middle row of three-row input image data
cols | Width of the input image data
out | Output data pointer
Algorithm:
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The input and output images must be 64-bit aligned.
  • The cols parameter must be a non-zero multiple of 8
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_perimeter_8

IMG_perimeter_8

Detailed Description

Functions

int IMG_perimeter_8 (const unsigned char *restrict in, int cols, unsigned char *restrict out)

Function Documentation

int IMG_perimeter_8 | ( | const unsigned char *restrict | in,
 |  | int | cols,
 |  | unsigned char *restrict | out
 | ) |  |

Description:
This function returns the boundary pixels of a binary image. Each call to this function calculates one new line of output from a three line window of input.
The input pointer "in" points to the middle line of a three-line window of the image. The perimeter function scans this window looking for pixels in the middle row which are on the perimeter of the image. The routine echoes the periemter pixels with a value of 0xFF and sets the other pixels to zero.
Parameters:
in | Pointer to middle row of three-row input image data
cols | Width of the input image data
out | Output data pointer
Algorithm:
Detection of this boundary within a binary image is a segmentation problem that may be estimated by examining the spatial locality of neighboring pixels. We accomplish this via the four connectivity algorithm:

            _____________________________
           |         |         |         |
           |         | px_up   |         |
           |_________|_________|_________|
           |         |         |         |
           | px_lft  | px_cent | px_rgt  |
           |_________|_________|_________|
           |         |         |         |
           |         | pix_dn  |         |
           |_________|_________|_________|
The output pixel at location "px_cent" is echoed as a boundary pixel if px_cent is non-zero and any one of its four neighbors is zero. The four neighbors used in this algorithm are shown above where:

            px_up:  top pixel
            px_lft: left pixel
            px_rgt: right pixel
            px_dn:  bottom pixel
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input and output arrays should not overlap
  • The input and output images must be 64-bit aligned.
  • The cols parameter must be a non-zero multiple of 16
Implementation Notes:
  • The loop is unrolled 16 times
  • Split-compares are used to find boundary pixels, with comparison results reused between adjacent comparisons
  • Multiplies replace some of the conditional operations to reduce the bottleneck on the predication registers
  • This code is fully interruptible
  • No bank conflicts are expected for this kernel
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_pix_expand

IMG_pix_expand

Detailed Description

Functions

void IMG_pix_expand (int n, const unsigned char *restrict in_data, short *restrict out_data)

Function Documentation

void IMG_pix_expand | ( | int | n,
 |  | const unsigned char *restrict | in_data,
 |  | short *restrict | out_data
 | ) |  |

Description:
Reads an array of unsigned 8-bit values and store them to a 16-bit array. This step is often used as the first step when processing pixels or other low-precision data at 16-bit intermediate precision.
Parameters:
n | Number of elements
in_data | Input data
out_data | Output data
Assumptions:
  • The input array and output arrays should be 64-bit aligned
  • The input must be at least 16 elements long and contain a multiple of 16 elements.
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_pix_sat

IMG_pix_sat

Detailed Description

Functions

void IMG_pix_sat (int n, const short *restrict in_data, unsigned char *restrict out_data)

Function Documentation

void IMG_pix_sat | ( | int | n,
 |  | const short *restrict | in_data,
 |  | unsigned char *restrict | out_data
 | ) |  |

Description:
The function IMG_pix_sat() takes signed 16-bit input pixels and saturates them to unsigned 8-bit results. Pixel values above 255 are clamped to 255, and values below 0 are clamped to 0.
Parameters:
n | Number of pixels
in_data | Input data
out_data | Output data
Assumptions:
  • The input must be a multiple of 32 pixels
  • All pointers must be 32-bit aligned
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_quantize

IMG_quantize

Detailed Description

Functions

void IMG_quantize (short *data, unsigned short num_blks, unsigned short blk_size, const short *recip_tbl, int q_pt)

Function Documentation

void IMG_quantize | ( | short * | data,
 |  | unsigned short | num_blks,
 |  | unsigned short | blk_size,
 |  | const short * | recip_tbl,
 |  | int | q_pt
 | ) |  |

Description:
The function quantize() quantizes matrices by multiplying their contents with a second matrix that contains reciprocals of the quantization terms. This step corresponds to the quantization that is performed in 2-D DCT-based compression techniques, although quantize() may be used on any signed 16-bit data using signed 16-bit quantization terms.
quantize() multiplies the contents of the quantization matrix with the data being quantized. Therefore, it may be used for inverse quantization as well, by setting the Q-point appropriately.
The assembly code does not explicitly disable interrupts. On entry to the function, interrupts are masked by branch delay slots for a maximum of 16 cycles.
Parameters:
data | Data to be quantized
num_blks | Number of blocks to process
blk_size | Block size (multiple of 16)
recip_tbl | Quant. values (reciprocals)
q_pt | Q-point of Quant values
Algorithm:
The outer loop is unrolled 16 times to allow greater amounts of work to be performed in the inner loop. The resulting loop- nest was then collapsed and pipelined as a single loop, since the code is not bottlenecked on bandwidth.
Reciprocals and data terms are loaded in groups of four using double-word loads, making best use of the available memory bandwidth.
Assumptions:
  • The recip_tbl[] and data[] must be double-word aligned
  • The block size, blk_size, must be a multiple of 16 and at least 32
  • The number of blocks, num_blks, may be zero
  • The Q-point, q_pt, must be in the range 0 <= q_pt <= 31.
  • The data[] array must be 'num_blks * blk_size' elements
  • The recip_tbl[] array must be 'blk_size' elements
Implementation Notes:
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
  • Twin stack pointers have been used to speed up stack accesses
  • SSHVR is used in the M-unit to avoid an S-unit bottleneck
  • No bank conflicts occur regardless of the relative orientation of recip_tbl[] and data[]
  • Six words of stack frame are used for Save-On-Entry registers
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_sad_16x16

IMG_sad_16x16

Detailed Description

Functions

unsigned IMG_sad_16x16 (const unsigned char *restrict srcImg, const unsigned char *restrict refImg, int pitch)

Function Documentation

unsigned IMG_sad_16x16 | ( | const unsigned char *restrict | srcImg,
 |  | const unsigned char *restrict | refImg,
 |  | int | pitch
 | ) |  |

Description:
The algorithm takes the difference between the pixel values in the source image block and the corresponding pixels in the reference image. It then takes the absolute values of these differences, and accumulates them over the entire 16x16 region. It returns the final accumulation.
Parameters:
srcImg | 16x16 block image to look for
refImg | Reference image
pitch | Width of reference image
The code accepts a pointer to the 16x16 source block (srcImg), and a pointer to the upper-left corner of a target position in a reference image (refImg). The width of the reference image is given by the pitch argument.
The function returns the sum of the absolute differences between the source block and the 16x16 region pointed to in the reference image.
Assumptions:
  • srcImg should be 32-bit aligned
Implementation Notes:
  • This code is compatible with C64x+ processors
  • This code blocks interrupts for 61 cycles
  • No bank conflicts occur
  • This code is Endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_sad_8x8

IMG_sad_8x8

Detailed Description

Functions

unsigned IMG_sad_8x8 (const unsigned char *restrict srcImg, const unsigned char *restrict refImg, int pitch)

Function Documentation

unsigned IMG_sad_8x8 | ( | const unsigned char *restrict | srcImg,
 |  | const unsigned char *restrict | refImg,
 |  | int | pitch
 | ) |  |

Description:
The algorithm takes the difference between the pixel values in the source image block and the corresponding pixels in the reference image. It then takes the absolute values of these differences, and accumulates them over the entire 8x8 region. It returns the final accumulation.
Parameters:
srcImg | Source 8x8 image block
refImg | Reference image to search
pitch | Width of reference image
The code accepts a pointer to the 8x8 source block (srcImg), and a pointer to the upper-left corner of a target position in a reference image (refImg). The width of the reference image is given by the pitch argument.
The function returns the sum of the absolute differences between the source block and the 8x8 region pointed to in the reference image.
Assumptions:
  • srcImg should be 32-bit aligned
Implementation Notes:
  • This code is compatible with C64x+ processors
  • No bank conflicts occur for this kernel
  • This code suppresses interrupts for 25 cycles
  • This kernel is Endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_sobel_3x3_16

IMG_sobel_3x3_16

Detailed Description

Functions

void IMG_sobel_3x3_16 (const unsigned short *restrict in, unsigned short *restrict out, short cols, short rows)

Function Documentation

void IMG_sobel_3x3_16 | ( | const unsigned short *restrict | in,
 |  | unsigned short *restrict | out,
 |  | short | cols,
 |  | short | rows
 | ) |  |

Description:
This function applies 3-by-3 horizontal and vertical Sobel edge detection masks to the input image and produces an output image which is two rows shorter than the input image. Within each row of the output, the first and last pixels will not contain meaningful results.
Parameters:
in | Input image pointer
out | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
Algorithm:
The Sobel edge-detection masks shown below are applied to the input image independently. The absolute value of each mask result are summed together and saturated to 16-bits.

          Horizontal Mask:
              -1 -2 -1
               0  0  0
               1  2  1

          Vertical Mask:
               -1  0  1
               -2  0  2
               -1  0  1

The example below illustrates how the implementation would operate on a given input image. Imagine the following 16-by-6 pixel input image:

              yyyyyyyyyyyyyyyy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yyyyyyyyyyyyyyyy
Where the output is only defined for the inner pixels, x, due to the edge effect of the 3-by-3 pixel mask.
The output image would have the form:

              tXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXt

  Where:   X = sobel(x)   The algorithm is applied to that pixel. The correct
                          output is obtained, the data surrounding the pixel
                          is used

           t              Data in the output buffer in that position is unaltered

           z = sobel(y)   The algorithm is applied to that pixel. The output is
                          not meaningful since the data necessary to process the
                          pixel is not available.
This means that (rows-2) lines of pixels will be processed. Though all pixels within each line are processed, the results for the first and last pixels are not valid. This makes the control code simpler and saves cycles. Note that The first pixel in the first processed row and the last pixel in the last processed row are not generated.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays have no alignment requirements
  • The "cols" input value must be greater than 3 and a multiple of 2
  • The "rows" input value must be greater than or equal to 3
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • The values of the left-most and right-most pixel on each output line are not defined
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_sobel_3x3_16s

IMG_sobel_3x3_16s

Detailed Description

Functions

void IMG_sobel_3x3_16s (const short *restrict in, short *restrict out, short cols, short rows)

Function Documentation

void IMG_sobel_3x3_16s | ( | const short *restrict | in,
 |  | short *restrict | out,
 |  | short | cols,
 |  | short | rows
 | ) |  |

Description:
This function applies 3-by-3 horizontal and vertical Sobel edge detection masks to the input image and produces an output image which is two rows shorter than the input image. Within each row of the output, the first and last pixels will not contain meaningful results.
Parameters:
in | Input image pointer
out | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
Algorithm:
The Sobel edge-detection masks shown below are applied to the input image independently. The absolute value of each mask result are summed together and saturated to 16-bits.

          Horizontal Mask:
              -1 -2 -1
               0  0  0
               1  2  1

          Vertical Mask:
               -1  0  1
               -2  0  2
               -1  0  1

The example below illustrates how the implementation would operate on a given input image. Imagine the following 16-by-6 pixel input image:

              yyyyyyyyyyyyyyyy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yyyyyyyyyyyyyyyy
Where the output is only defined for the inner pixels, x, due to the edge effect of the 3-by-3 pixel mask.
The output image would have the form:

              tXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXt

  Where:   X = sobel(x)   The algorithm is applied to that pixel. The correct
                          output is obtained, the data surrounding the pixel
                          is used

           t              Data in the output buffer in that position is unaltered

           z = sobel(y)   The algorithm is applied to that pixel. The output is
                          not meaningful since the data necessary to process the
                          pixel is not available.
This means that (rows-2) lines of pixels will be processed. Though all pixels within each line are processed, the results for the first and last pixels are not valid. This makes the control code simpler and saves cycles. Note that The first pixel in the first processed row and the last pixel in the last processed row are not generated.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays have no alignment requirements
  • The "cols" input value must be greater than 3 and a multiple of 2
  • The "rows" input value must be greater than or equal to 3
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • The values of the left-most and right-most pixel on each output line are not defined
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_sobel_3x3_8

IMG_sobel_3x3_8

Detailed Description

Functions

void IMG_sobel_3x3_8 (const unsigned char *restrict in, unsigned char *restrict out, short cols, short rows)

Function Documentation

void IMG_sobel_3x3_8 | ( | const unsigned char *restrict | in,
 |  | unsigned char *restrict | out,
 |  | short | cols,
 |  | short | rows
 | ) |  |

Description:
This function applies 3-by-3 horizontal and vertical Sobel edge detection masks to the input image and produces an output image which is two rows shorter than the input image. Within each row of the output, the first and last pixels will not contain meaningful results.
Parameters:
in | Input image pointer
out | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
Algorithm:
The Sobel edge-detection masks shown below are applied to the input image independently. The absolute value of each mask result are summed together and saturated to 8-bits.

          Horizontal Mask:
              -1 -2 -1
               0  0  0
               1  2  1

          Vertical Mask:
               -1  0  1
               -2  0  2
               -1  0  1

The example below illustrates how the implementation would operate on a given input image. Imagine the following 16-by-6 pixel input image:

              yyyyyyyyyyyyyyyy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yxxxxxxxxxxxxxxy
              yyyyyyyyyyyyyyyy
Where the output is only defined for the inner pixels, x, due to the edge effect of the 3-by-3 pixel mask.
The output image would have the form:

              tXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXz
              zXXXXXXXXXXXXXXt

  Where:   X = sobel(x)   The algorithm is applied to that pixel. The correct
                          output is obtained, the data surrounding the pixel
                          is used

           t              Data in the output buffer in that position is unaltered

           z = sobel(y)   The algorithm is applied to that pixel. The output is
                          not meaningful since the data necessary to process the
                          pixel is not available.
This means that (rows-2) lines of pixels will be processed. Though all pixels within each line are processed, the results for the first and last pixels are not valid. This makes the control code simpler and saves cycles. Note that The first pixel in the first processed row and the last pixel in the last processed row are not generated.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays have no alignment requirements
  • The "cols" input value must be even
  • The total number of pixels (cols*rows) must be a multiple of 8
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • The values of the left-most and right-most pixel on each output line are not defined
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_sobel_5x5_16s

IMG_sobel_5x5_16s

Detailed Description

Functions

void IMG_sobel_5x5_16s (const short *restrict in, short *restrict out, short cols, short rows)

Function Documentation

void IMG_sobel_5x5_16s | ( | const short *restrict | in,
 |  | short *restrict | out,
 |  | short | cols,
 |  | short | rows
 | ) |  |

Description:
This function applies 5-by-5 horizontal and vertical Sobel edge detection masks to the input image and produces an output image which is four rows shorter than the input image. Within each row of the output, the first two and the last two pixels will not contain meaningful results.
Parameters:
in | Input image pointer
out | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
Algorithm:
The Sobel edge-detection masks shown below are applied to the input image independently. The absolute value of each mask result are summed together and saturated to 16-bits.

          Horizontal Mask:
              -1  -4  -6  -4  -1
              -2  -8 -12  -8  -2
               0   0   0   0   0
               2   8  12   8   2
               1   4   6   4   1

          Vertical Mask:
               1   2   0  -2  -1
               4   8   0  -8  -4
               6  12   0 -12  -6
               4   8   0  -8  -4
               1   2   0  -2  -1

The example below illustrates how the implementation would operate on a given input image. Imagine the following 7-by-7 pixel input image:

              yyyyyyy
              yyyyyyy
              yyxxxyy
              yyxxxyy
              yyxxxyy
              yyyyyyy
              yyyyyyy
Where the output is only defined for the inner pixels, x, due to the edge effect of the 5-by-5 pixel mask.
The output image would have the form:

              ttXXXzz
              zzXXXzz
              zzXXXtt

  Where:   X = sobel(x)   The algorithm is applied to that pixel. The correct
                          output is obtained, the data surrounding the pixel
                          is used

           t              Data in the output buffer in that position is unaltered

           z = sobel(y)   The algorithm is applied to that pixel. The output is
                          not meaningful since the data necessary to process the
                          pixel is not available.
This means that (rows-4) lines of pixels will be processed. Though all pixels within each line are processed, the results for the first and last pixels are not valid. This makes the control code simpler and saves cycles. Note that The first two pixels in the first processed row and the last two pixels in the last processed row are not generated.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 16-bit aligned
  • The "cols" input value must be greater than 5 and a multiple of 2
  • The "rows" input value must be greater than or equal to 5
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • The values of the two left-most and two right-most pixels on each output line are not defined
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_sobel_7x7_16s

IMG_sobel_7x7_16s

Detailed Description

Functions

void IMG_sobel_7x7_16s (const short *restrict in, short *restrict out, short cols, short rows)

Function Documentation

void IMG_sobel_7x7_16s | ( | const short *restrict | in,
 |  | short *restrict | out,
 |  | short | cols,
 |  | short | rows
 | ) |  |

Description:
This function applies 7-by-7 horizontal and vertical Sobel edge detection masks to the input image and produces an output image which is six rows shorter than the input image. Within each row of the output, the first three and the last three pixels will not contain meaningful results.
Parameters:
in | Input image pointer
out | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
Algorithm:
The Sobel edge-detection masks shown below are applied to the input image independently. The absolute value of each mask result are summed together and saturated to 16-bits.

          Horizontal Mask:
              -1 -1 -1 -2 -1 -1 -1
              -1 -1 -1 -2 -1 -1 -1
              -1 -1 -1 -2 -1 -1 -1
               0  0  0  0  0  0  0
               1  1  1  2  1  1  1
               1  1  1  2  1  1  1
               1  1  1  2  1  1  1

          Vertical Mask:
              -1 -1 -1  0  1  1  1
              -1 -1 -1  0  1  1  1
              -1 -1 -1  0  1  1  1
              -2 -2 -2  0  2  2  2
              -1 -1 -1  0  1  1  1
              -1 -1 -1  0  1  1  1
              -1 -1 -1  0  1  1  1

The example below illustrates how the implementation would operate on a given input image. Imagine the following 10-by-16 pixel input image:

              yyyyyyyyyyyyyyyy
              yyyyyyyyyyyyyyyy
              yyyyyyyyyyyyyyyy
              yyyxxxxxxxxxxyyy
              yyyxxxxxxxxxxyyy
              yyyxxxxxxxxxxyyy
              yyyxxxxxxxxxxyyy
              yyyyyyyyyyyyyyyy
              yyyyyyyyyyyyyyyy
              yyyyyyyyyyyyyyyy
Where the output is only defined for the inner pixels, x, due to the edge effect of the 7-by-7 pixel mask.
The output image would have the form:

              tttXXXXXXXXXXzzz
              zzzXXXXXXXXXXzzz
              zzzXXXXXXXXXXzzz
              zzzXXXXXXXXXXttt

  Where:   X = sobel(x)   The algorithm is applied to that pixel. The correct
                          output is obtained, the data surrounding the pixel
                          is used

           t              Data in the output buffer in that position is unaltered

           z = sobel(y)   The algorithm is applied to that pixel. The output is
                          not meaningful since the data necessary to process the
                          pixel is not available.
This means that (rows-6) lines of pixels will be processed. Though all pixels within each line are processed, the results for the first three and last three pixels are not valid, yet still provided. This makes the control code simpler and saves cycles. Note that The first three pixels in the first processed row and the last three pixels in the last processed row are not generated.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 16-bit aligned
  • The "cols" input value must be greater than 7 and a multiple of 2
  • The "rows" input value must be greater than or equal to 7
  • The value (cols * (rows - 6) - 6) must be at least 2
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • The values of the three left-most and three right-most pixels on each output line are not defined
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_thr_gt2max_16

IMG_thr_gt2max_16

Detailed Description

Functions

void IMG_thr_gt2max_16 (const unsigned short *restrict in_data, unsigned short *restrict out_data, short cols, short rows, unsigned short threshold)

Function Documentation

void IMG_thr_gt2max_16 | ( | const unsigned short *restrict | in_data,
 |  | unsigned short *restrict | out_data,
 |  | short | cols,
 |  | short | rows,
 |  | unsigned short | threshold
 | ) |  |

Description:
This kernel performs a thresholding operation on the input image "in_data" with dimensions as specified by the input arguments "cols" and "rows". The thresholded pixels are written to the output image pointed to by "out_data". The input and output images are of the same dimensions.
Pixels with values equal-to or below the threshold are passed out unmodified. Pixels with values greater than the threshold are set to the maximum unsigned 16-bit value (65535) in the output image.
Parameters:
in_data | Input image pointer
out_data | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
threshold | The (unsigned 16-bit) threshold
Algorithm:
The thresholding function is illustrated in the transfer function diagram below:

              65535_|          _________
                    |         |
                    |         |
           O        |         |
           U        |         |
           T    th _|. . . . .|
           P        |        /.
           U        |      /  .
           T        |    /    .
                    |  /      .
                  0_|/________.__________
                    |         |        |
                    0        th       65535

                            INPUT
The main thresholding loop is unrolled sixteen times. Packed-data processing techniques allow us to process all 16 pixels in parallel.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The number of image pixels (cols x rows) must be a multiple of 16
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_thr_gt2max_8

IMG_thr_gt2max_8

Detailed Description

Functions

void IMG_thr_gt2max_8 (const unsigned char *in_data, unsigned char *restrict out_data, short cols, short rows, unsigned char threshold)

Function Documentation

void IMG_thr_gt2max_8 | ( | const unsigned char * | in_data,
 |  | unsigned char *restrict | out_data,
 |  | short | cols,
 |  | short | rows,
 |  | unsigned char | threshold
 | ) |  |

Description:
This kernel performs a thresholding operation on the input image "in_data" with dimensions as specified by the input arguments "cols" and "rows". The thresholded pixels are written to the output image pointed to by "out_data". The input and output images are of the same dimensions.
Pixels with values equal-to or below the threshold are passed out unmodified. Pixels with values greater than the threshold are set to the maximum unsigned 8-bit value (255) in the output image.
Parameters:
in_data | Input image pointer
out_data | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
threshold | The (unsigned 8-bit) threshold
Algorithm:
The thresholding function is illustrated in the transfer function diagram below:

                 255_|          _________
                     |         |
                     |         |
            O        |         |
            U        |         |
            T    th _|. . . . .|
            P        |        /.
            U        |      /  .
            T        |    /    .
                     |  /      .
                   0_|/________.__________
                     |         |        |
                     0        th       255

                             INPUT
The main thresholding loop is manually unrolled four times. The compiler is instructed to unroll by an additional factor of four, yielding a total unroll factor of 16.
A packed-data processing techniques is used to allow the processing of four pixels in parallel. The _amem4_const() intrinsic brings in four pixels, designated p0 thru p3. These pixels are packed into an unsigned integer variable p3p2p1p0 as illustrated below:

                         31  24   16    8    0
                         +----+----+----+----+
                p3p2p1p0 | p3 | p2 | p1 | p0 |
                         +----+----+----+----+
(Note that this illustration assumes a little endian memory configuration). We compare this packed word to a (4x) packed copy of the threshold. The packed threshold contains four copies of the threshold value, one per byte:

                       31  24   16    8    0
                         +----+----+----+----+
                thththth | th | th | th | th |
                         +----+----+----+----+
We compare using the intrinsic _cmpgtu4(). The comparison results are then expanded to masks using _xpnd4(). The result is a four-byte mask (x3210) which contains 0xFF in bytes that are greater than the threshold, and 0x00 in bytes that are less than or equal to the threshold.
To complete the thresholding process, we compute the logical OR between our original pixel values and the mask. This forces values above the threshold to 0xFF, and leaves the other values unmodified. The four pixels are then written with a single _amem4().
In this version of the code, we rely on the compiler to unroll the loop 4x (as noted above), and convert the _amem4_const() and _amem4() calls into _amemd8_const()/_amemd8() as part of its automatic optimizations.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The number of image pixels (cols x rows) must be a multiple of 16
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_thr_gt2thr_16

IMG_thr_gt2thr_16

Detailed Description

Functions

void IMG_thr_gt2thr_16 (const unsigned short *in_data, unsigned short *restrict out_data, short cols, short rows, unsigned short threshold)

Function Documentation

void IMG_thr_gt2thr_16 | ( | const unsigned short * | in_data,
 |  | unsigned short *restrict | out_data,
 |  | short | cols,
 |  | short | rows,
 |  | unsigned short | threshold
 | ) |  |

Description:
This kernel performs a thresholding operation on the input image "in_data" with dimensions as specified by the input arguments "cols" and "rows". The thresholded pixels are written to the output image pointed to by "out_data". The input and output images are of the same dimensions.
Pixels that are below the threshold value are written to the output unmodified. Pixels with values greater than the threshold are set to the threshold value in the output image.
Parameters:
in_data | Input image pointer
out_data | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
threshold | The (unsigned 16-bit) threshold
Algorithm:
The thresholding function is illustrated in the transfer function diagram below:

               65535_|
                     |
                     |
            O        |
            U        |
            T    th _|. . . . . _________
            P        |        /.
            U        |      /  .
            T        |    /    .
                     |  /      .
                   0_|/________.__________
                     |         |        |
                     0        th       65535

                             INPUT
The main thresholding loop is unrolled sixteen times. Packed-data processing techniques allow us to process all 16 pixels in parallel.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The number of image pixels (cols x rows) must be a multiple of 16
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_thr_gt2thr_8

IMG_thr_gt2thr_8

Detailed Description

Functions

void IMG_thr_gt2thr_8 (const unsigned char *in_data, unsigned char *restrict out_data, short cols, short rows, unsigned char threshold)

Function Documentation

void IMG_thr_gt2thr_8 | ( | const unsigned char * | in_data,
 |  | unsigned char *restrict | out_data,
 |  | short | cols,
 |  | short | rows,
 |  | unsigned char | threshold
 | ) |  |

Description:
This kernel performs a thresholding operation on the input image "in_data" with dimensions as specified by the input arguments "cols" and "rows". The thresholded pixels are written to the output image pointed to by "out_data". The input and output images are of the same dimensions.
Pixels with values equal-to or below the threshold are passed out unmodified. Pixels with values greater than the threshold are clipped to the threshold value in the output image.
Parameters:
in_data | Input image pointer
out_data | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
threshold | The (unsigned 8-bit) threshold
Algorithm:
The thresholding function is illustrated in the transfer function diagram below:

                 255_|
                     |
                     |
            O        |
            U        |
            T    th _|. . . . . _________
            P        |        /.
            U        |      /  .
            T        |    /    .
                     |  /      .
                   0_|/________.__________
                     |         |        |
                     0        th       255

                             INPUT
The main thresholding loop is manually unrolled four times. The compiler is instructed to unroll by an additional factor of four, yielding a total unroll factor of 16.
A packed-data processing techniques is used to allow the processing of four pixels in parallel. The _amem4_const() intrinsic brings in four pixels, designated p0 thru p3. These pixels are packed into an unsigned integer variable p3p2p1p0 as illustrated below:

                         31  24   16    8    0
                         +----+----+----+----+
                p3p2p1p0 | p3 | p2 | p1 | p0 |
                         +----+----+----+----+
(Note that this illustration assumes a little endian memory configuration). We compare this packed word to a (4x) packed copy of the threshold. The packed threshold contains four copies of the threshold value, one per byte:

                       31  24   16    8    0
                         +----+----+----+----+
                thththth | th | th | th | th |
                         +----+----+----+----+
We compare using the intrinsic _minu4(). This instruction selects the smaller value (p3p2p1p0 versus thththth) for all four pixels in parallel. The result is that input values above the threshold are clipped to the threshold value.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The number of image pixels (cols x rows) must be a multiple of 16
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_thr_le2min_16

IMG_thr_le2min_16

Detailed Description

Functions

void IMG_thr_le2min_16 (const unsigned short *restrict in_data, unsigned short *restrict out_data, short cols, short rows, unsigned short threshold)

Function Documentation

void IMG_thr_le2min_16 | ( | const unsigned short *restrict | in_data,
 |  | unsigned short *restrict | out_data,
 |  | short | cols,
 |  | short | rows,
 |  | unsigned short | threshold
 | ) |  |

Description:
This kernel performs a thresholding operation on the input image "in_data" with dimensions as specified by the input arguments "cols" and "rows". The thresholded pixels are written to the output image pointed to by "out_data". The input and output images are of the same dimensions.
Pixels that are above the threshold value are written to the output unmodified. Pixels that are less than or equal to the threshold are set to zero in the output image.
Parameters:
in_data | Input image pointer
out_data | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
threshold | The (unsigned 16-bit) threshold
Algorithm:
The thresholding function is illustrated in the transfer function diagram below:

              65535_|
                    |                  /
                    |                /
           O        |              /
           U        |            /
           T    th _|. . . . . /
           P        |         |
           U        |         |
           T        |         |
                    |         |
                  0_|_________|__________
                    |         |        |
                    0        th     65535

                          INPUT
The main thresholding loop is unrolled sixteen times. Packed-data processing techniques allow us to process all 16 pixels in parallel.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The number of image pixels (cols x rows) must be a multiple of 16
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_thr_le2min_8

IMG_thr_le2min_8

Detailed Description

Functions

void IMG_thr_le2min_8 (const unsigned char *in_data, unsigned char *restrict out_data, short cols, short rows, unsigned char threshold)

Function Documentation

void IMG_thr_le2min_8 | ( | const unsigned char * | in_data,
 |  | unsigned char *restrict | out_data,
 |  | short | cols,
 |  | short | rows,
 |  | unsigned char | threshold
 | ) |  |

Description:
This kernel performs a thresholding operation on the input image "in_data" with dimensions as specified by the input arguments "cols" and "rows". The thresholded pixels are written to the output image pointed to by "out_data". The input and output images are of the same dimensions.
Pixels that are above the threshold value are written to the output unmodified. Pixels that are less than or equal to the threshold are set to 0 in the output image.
Parameters:
in_data | Input image pointer
out_data | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
threshold | The (unsigned 8-bit) threshold
Algorithm:
The thresholding function is illustrated in the transfer function diagram below:

               255_|
                   |                  /
                   |                /
          O        |              /
          U        |            /
          T    th _|. . . . . /
          P        |         |
          U        |         |
          T        |         |
                   |         |
                 0_|_________|__________
                   |         |        |
                   0        th       255

                           INPUT
The main thresholding loop is manually unrolled four times. The compiler is instructed to unroll by an additional factor of four, yielding a total unroll factor of 16.
A packed-data processing techniques is used to allow the processing of four pixels in parallel. The _amem4_const() intrinsic brings in four pixels, designated p0 thru p3. These pixels are packed into an unsigned integer variable p3p2p1p0 as illustrated below:

                         31  24   16    8    0
                         +----+----+----+----+
                p3p2p1p0 | p3 | p2 | p1 | p0 |
                         +----+----+----+----+
(Note that this illustration assumes a little endian memory configuration). We compare this packed word to a (4x) packed copy of the threshold. The packed threshold contains four copies of the threshold value, one per byte:

                       31  24   16    8    0
                         +----+----+----+----+
                thththth | th | th | th | th |
                         +----+----+----+----+
We compare using the intrinsic _cmpgtu4(). The comparison results are then expanded to masks using _xpnd4(). The result is a four-byte mask (x3210) which contains 0xFF in bytes that are greater than the threshold, and 0x00 in bytes that are less than or equal to the threshold.
To complete the thresholding process, we compute the logical AND between our original pixel values and the mask. This forces values less than or equal to threshold to 0x00, and leaves the other values unmodified. The four pixels are then written with a single _amem4().
In this version of the code, we rely on the compiler to unroll the loop 4x (as noted above), and convert the _amem4_const() and _amem4() calls into _amemd8_const()/_amemd8() as part of its automatic optimizations.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The number of image pixels (cols x rows) must be a multiple of 16
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_thr_le2thr_16

IMG_thr_le2thr_16

Detailed Description

Functions

void IMG_thr_le2thr_16 (const unsigned short *in_data, unsigned short *restrict out_data, short cols, short rows, unsigned short threshold)

Function Documentation

void IMG_thr_le2thr_16 | ( | const unsigned short * | in_data,
 |  | unsigned short *restrict | out_data,
 |  | short | cols,
 |  | short | rows,
 |  | unsigned short | threshold
 | ) |  |

Description:
This kernel performs a thresholding operation on the input image "in_data" with dimensions as specified by the input arguments "cols" and "rows". The thresholded pixels are written to the output image pointed to by "out_data". The input and output images are of the same dimensions.
Pixels that are above the threshold value are written to the output unmodified. Pixels that are less than or equal to the threshold are set to the threshold value in the output image.
Parameters:
in_data | Input image pointer
out_data | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
threshold | The (unsigned 16-bit) threshold
Algorithm:
The thresholding function is illustrated in the transfer function diagram below:

               65535_|
                     |                  /
                     |                /
            O        |              /
            U        |            /
            T    th _|_________ /
            P        |         .
            U        |         .
            T        |         .
                     |         .
                   0_|_________.__________
                     |         |        |
                     0        th       65535

                             INPUT
The main thresholding loop is unrolled sixteen times. Packed-data processing techniques allow us to process all 16 pixels in parallel.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The number of image pixels (cols x rows) must be a multiple of 16
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_thr_le2thr_8

IMG_thr_le2thr_8

Detailed Description

Functions

void IMG_thr_le2thr_8 (const unsigned char *in_data, unsigned char *restrict out_data, short cols, short rows, unsigned char threshold)

Function Documentation

void IMG_thr_le2thr_8 | ( | const unsigned char * | in_data,
 |  | unsigned char *restrict | out_data,
 |  | short | cols,
 |  | short | rows,
 |  | unsigned char | threshold
 | ) |  |

Description:
This kernel performs a thresholding operation on the input image "in_data" with dimensions as specified by the input arguments "cols" and "rows". The thresholded pixels are written to the output image pointed to by "out_data". The input and output images are of the same dimensions.
Pixels that are equal to or above the threshold value are written to the output unmodified. Pixels that are less than the threshold are set to the threshold value in the output image.
Parameters:
in_data | Input image pointer
out_data | Output image pointer
cols | Number of columns in the image
rows | Number of rows in the image
threshold | The (unsigned 8-bit) threshold
Algorithm:
The thresholding function is illustrated in the transfer function diagram below:

               255_|
                   |                  /
                   |                /
          O        |              /
          U        |            /
          T    th _|_________ /
          P        |         .
          U        |         .
          T        |         .
                   |         .
                 0_|_________.__________
                   |         |        |
                   0        th       255

                           INPUT
The main thresholding loop is manually unrolled four times. The compiler is instructed to unroll by an additional factor of four, yielding a total unroll factor of 16.
A packed-data processing techniques is used to allow the processing of four pixels in parallel. The _amem4_const() intrinsic brings in four pixels, designated p0 thru p3. These pixels are packed into an unsigned integer variable p3p2p1p0 as illustrated below:

                         31  24   16    8    0
                         +----+----+----+----+
                p3p2p1p0 | p3 | p2 | p1 | p0 |
                         +----+----+----+----+
(Note that this illustration assumes a little endian memory configuration). We compare this packed word to a (4x) packed copy of the threshold. The packed threshold contains four copies of the threshold value, one per byte:

                       31  24   16    8    0
                         +----+----+----+----+
                thththth | th | th | th | th |
                         +----+----+----+----+
We compare using the intrinsic _maxu4(). This instruction will select the larger value between the input pixels and the threshold value. The result is that input values below the threshold are clamped to the threshold value. The four pixels are then written with a single _amem4().
In this version of the code, we rely on the compiler to unroll the loop 4x (as noted above), and convert the _amem4_const() and _amem4() calls into _amemd8_const()/_amemd8() as part of its automatic optimizations.
The natural C implementation has no restrictions. The optimized intrinsic C code has restrictions as noted in Assumptions below.
Assumptions:
  • The input array and output array should not overlap
  • Both input and output arrays must be 64-bit aligned
  • The number of image pixels (cols x rows) must be a multiple of 16
Implementation Notes:
  • This code is fully interruptible
  • This code is compatible with C64x+ processors
  • This code is endian neutral
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_wave_horz

IMG_wave_horz

Detailed Description

Functions

void | IMG_wave_horz (short *iptr, short *qmf, short *filter, short *optr, int ish_x_dim)
void | IMG_yc_demux_be16_16 (int n, const unsigned short *yc, short *restrict y, short *restrict cr, short *restrict cb)

Function Documentation

void IMG_wave_horz | ( | short * | iptr,
 |  | short * | qmf,
 |  | short * | filter,
 |  | short * | optr,
 |  | int | ish_x_dim
 | ) |  |

Description:
This kernel performs a 1D Periodic Orthogonal Wavelet decomposition. This also performs athe row decomposition in a 2D wavelet transform. An in put signal x[n] is first low pass and high pass filterd and decimated by two. This results in a reference signal r1[n] which is the decimated output obtained by dropping the odd samples of the low pass filtered output and a detail signal d[n] obtained by dropping the odd samples of the high-pass output. A circular convolution algorithm is implemented and hence the wavelet transform is periodic. The reference signal and the detail signal are half the size of the original signal. The reference signal may then be iterated again to perform another scale of multi-resolution analysis.
Parameters:
iptr | Input row of data
qmf | Qmf filter-bank for Low-Pass
filter | Mirror qmf filter bank for High-pass
optr | Output row of detailed/reference decimated outputs
ish_x_dim | Width of the input row
Algorithm:
The main idea behind the optimized C code is to issue one set of reads to the x array and to perform low-pass and high pass filtering together and to perfrom the filtering operations together to maximize the number of multiplies. The last 6 elements of the low-pass filter and the first 6 elements of the high pass filter use the same input This is used to appropraitely change the output pointer to the low pass filter after 6 iterations. However for the first six iterations pointer wrap-around can occurr and hence this creates a dependency. Pre-reading those 6 values outside the array prevents the checks that introduce this dependency. In addtion the input data is read as word wide quantities and the low-pass and high-pass filter coefficients are stored in registers allowing for the input loop to be completely unrolled. Thus the intrinsic C code has only one loop. A predication register is used to reset the low-pass output pointer after three iterations. The merging of the loops in this fashion allows for the maximum number of multiplies with the minimum number of reads.
Assumptions:
  • This kernel places no restrictions on the alignment of its input
Implementation Notes:
  • This kernel uses the Daubechies D4 filter bank for analysis with 4 vansishing moments. Hence the length of the analyzing low-pass and high pass filters is 8
  • The optimized kernel should not have any bank conflicts
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.

void IMG_yc_demux_be16_16 | ( | int | n,
 |  | const unsigned short * | yc,
 |  | short *restrict | y,
 |  | short *restrict | cr,
 |  | short *restrict | cb
 | ) |  |

Description:
This function reads the halfword-oriented pixel data, zero-extends it, and then writes it to the appropriate result array. Both the luma and chroma values are expected to be unsigned.
The data is expected to be in an order consistent with reading byte oriented data from a word-oriented peripheral that is operating in BIG ENDIAN mode, while the CPU is in LITTLE ENDIAN mode. This results in a pixel ordering which is not immediately obvious. This function correctly reorders the pixel values so that further processing may proceed in LITTLE ENDIAN mode.
Parameters:
n | Number of luma pixels
yc | Interleaved luma/chroma
y | Luma plane (16-bit)
cr | Cr chroma plane (16-bit)
cb | Cb chroma plane (16-bit)
Algorithm:
The input array 'yc' is expected to be an interleaved 4:2:2 video stream. The input is expected in BIG ENDIAN byte order within each 4-byte word. This is consistent with reading the video stream from a word-oriented BIG ENDIAN device while the C6000 device is in a LITTLE ENDIAN configuration.
In other words, the expected pixel order is:

                  Word 0           Word 1          Word 2
              +---------------+---------------+---------------+--
        Byte# | 0   1   2   3 | 4   5   6   7 | 8   9  10  11 |...
              |  cb0      y1  |  cr0      y0  |  cb1     y2   |...
              +---------------+---------------+---------------+--
The output arrays 'y', 'cr', and 'cb' are expected to not overlap. The de-interleaved pixels are written as half-words in LITTLE ENDIAN order.

Assumptions:
  • Input and output arrays should be 32-bit aligned.
  • The input must be a multiple of 16 luma pixels
Implementation Notes:
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
  • The loop has been unrolled a total of 16 times to allow for processing 8 pixels in each datapath.
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_wave_vert

IMG_wave_vert

Detailed Description

Functions

void IMG_wave_vert (const short *restrict *restrict in_data, const short *restrict qmf, const short *restrict mqmf, short *restrict out_ldata, short *restrict out_hdata, int cols)

Function Documentation

void IMG_wave_vert | ( | const short *restrict *restrict | in_data,
 |  | const short *restrict | qmf,
 |  | const short *restrict | mqmf,
 |  | short *restrict | out_ldata,
 |  | short *restrict | out_hdata,
 |  | int | cols
 | ) |  |

Description:
The benchmark performs the vertical pass of 2D wavelet transform It performs a vertical filter on 8 rows which are pointed to by the pointers contained in an array of pointers. It produces two lines worth of output, one being the low-pass and the other being the high pass result. Instead of performing a transpose on the column and re-using the wave_horz kernel, the vertical filter is traversed over the entire width of the line and the low pass and high pass filtering kernels are performed together.
This implies that the low-pass and highpass filters be overlapped in execution so that the input data array may be loaded once and both filters can be exceuted in parallel.
Parameters:
in_data | Array of (8) row pointers
qmf | Low pass QMF filter
mqmf | High pass QMF filter
out_ldata | Low pass output data
out_hdata | High pass output data
cols | Length of rows to process
Algorithm:
The inner loop that advances along each filter tap is totally optimized by unrolling. Double-word loads are performed, and paired multiplies are used to perform four iterations of low-pass filter in parallel.
For the high-pass kernel, the same loop is reused, in order to save codesize. This is done by loading the filter coefficients in a special order.
The kernels assume that the number of filter taps is exactly 8. In addition data that is loaded for producing out_ldata[0] and out_hdata[0] is not identical. The data loaded for producing out_hdata[0] produces results at the location
            out_lstart = o_im + ((rows >> 1) - 3) * cols
            out_hstart = o_im +  (rows >> 1) * cols
Where o_im is start of output image, rows is the number of rows in the input image, and cols is the number of columns in the output image.
The following table illustrates how ylptr and yhptr need to be updated at the start of each call to this function:
        Call#        out_ldata                  out_hdata
          1          out_lstart                 out_hstart
          2          out_lstart + cols          out_hstart + cols
          3          out_lstart + 2*cols        out_hstart + 2*cols
At this point ylptr wraps around to become o_im, while yhptr proceeds as usual:
          4          o_im                       out_hstart + 3*cols

In addition the kernel accepts a pointer to an array of pointers for each input line so that a working buffer of 10 lines can be used to effectively mix DMA's and processing as illustrated below:

        ihptr                        LINE BUFFER
        ptr0   ---->|-------------------------------------------------|
        ptr1   ---->|-------------------------------------------------|
        ...
        ptr7   ---->|-------------------------------------------------|

At the start of the kernel 8 input lines are filled to the first 8 lines and processing begins. In the background the next two lines are fetched. The pointers are moved up by 2 namely ptr[i] = ptr[i+2] and the last two lines now point to lines 9 and 10 and processing starts again. In the background the next two lines are brought in the first two lines of the line buffer. Pointers move up again by 2 but now the last two pointers to line 0 and 1. This pattern then repeats.

The first line to begin filtering is always obtained from ptr[0], the next from ptr[1] and so on.
Assumptions:
  • The input image dimensions (rows and cols) are assumed to be powers of 2
  • The input filters qmf and mqmf are assumed to be word aligned and have exactly 8 taps.
  • The output data and input data on any line is assumed to be double-word aligned.
Implementation Notes:
  • This code is a LITTLE ENDIAN implementation
  • In order to eliminate bank conflicts succesive lines in the line buffer or the pointers to these lines are seperated by exactly two banks (one word) so that loads to any succesive lines may be parallelized together
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_yc_demux_be16_8

IMG_yc_demux_be16_8

Detailed Description

Functions

void IMG_yc_demux_be16_8 (int n, const unsigned char *restrict yc, short *restrict y, short *restrict cr, short *restrict cb)

Function Documentation

void IMG_yc_demux_be16_8 | ( | int | n,
 |  | const unsigned char *restrict | yc,
 |  | short *restrict | y,
 |  | short *restrict | cr,
 |  | short *restrict | cb
 | ) |  |

Description:
This function reads the byte-oriented pixel data, zero-extends it, and then writes it to the appropriate result array. Both the luma and chroma values are expected to be unsigned.
The data is expected to be in an order consistent with reading byte oriented data from a word-oriented peripheral that is operating in BIG ENDIAN mode, while the CPU is in LITTLE ENDIAN mode. This results in a pixel ordering which is not immediately obvious. This function correctly reorders the pixel values so that further processing may proceed in LITTLE ENDIAN mode.
Parameters:
n | Number of luma pixels
yc | Interleaved luma/chroma
y | Luma plane (16-bit)
cr | Cr chroma plane (16-bit)
cb | Cb chroma plane (16-bit)
Algorithm:
The input array 'yc' is expected to be an interleaved 4:2:2 video stream. The input is expected in BIG ENDIAN byte order within each 4-byte word. This is consistent with reading the video stream from a word-oriented BIG ENDIAN device while the C6000 device is in a LITTLE ENDIAN configuration.
In other words, the expected pixel order is:

                    Word 0           Word 1          Word 2
                +---------------+---------------+---------------+--
          Byte# | 0   1   2   3 | 4   5   6   7 | 8   9  10  11 |...
                |cb0 y1  cr0 y0 |cb2 y3  cr2 y2 |cb4 y5  cr4 y4 |...
                +---------------+---------------+---------------+--
The output arrays 'y', 'cr', and 'cb' are expected to not overlap. The de-interleaved pixels are written as half-words in LITTLE ENDIAN order.

Assumptions:
  • Input and output arrays should be 32-bit aligned.
  • The input must be a multiple of 16 luma pixels
Implementation Notes:
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
  • The loop has been unrolled a total of 16 times to allow for processing 8 pixels in each datapath.
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_yc_demux_le16_16

IMG_yc_demux_le16_16

Detailed Description

Functions

void IMG_yc_demux_le16_16 (int n, const unsigned short *yc, short *restrict y, short *restrict cr, short *restrict cb)

Function Documentation

void IMG_yc_demux_le16_16 | ( | int | n,
 |  | const unsigned short * | yc,
 |  | short *restrict | y,
 |  | short *restrict | cr,
 |  | short *restrict | cb
 | ) |  |

Description:
This function reads the halfword-oriented pixel data, zero-extends it, and then writes it to the appropriate result array. Both the luma and chroma values are expected to be unsigned.
The data is expected to be in an order consistent with reading byte oriented data from a word-oriented peripheral that is operating in LITTLE ENDIAN mode, while the CPU is in LITTLE ENDIAN mode. This function unpacks the byte-oriented data so that further processing may proceed in LITTLE ENDIAN mode.
Parameters:
n | Number of luma pixels
yc | Interleaved luma/chroma
y | Luma plane (16-bit)
cr | Cr chroma plane (16-bit)
cb | Cb chroma plane (16-bit)
Algorithm:
The input array 'yc' is expected to be an interleaved 4:2:2 video stream. The input is expected in LITTLE ENDIAN byte order within each 4-byte word. This is consistent with reading the video stream from a word-oriented LITTLE ENDIAN device while the C6000 device is in a LITTLE ENDIAN configuration.
In other words, the expected pixel order is:

                      Word 0           Word 1          Word 2
                +-----------------+-----------------+-----------------+--
          Byte# | 0   1  |  2   3 | 4   5  |  6   7 | 8   9  | 10  11 |...
                |   y0   |   cr0  |   y1   |   cb0  |   y2   |   cr2  |...
                +-----------------+-----------------+-----------------+--
The output arrays 'y', 'cr', and 'cb' are expected to not overlap. The de-interleaved pixels are written as half-words in LITTLE ENDIAN order.
Please see the IMGLIB function IMB_yc_demux_be16_16 for code which handles input coming from a BIG ENDIAN device.
Assumptions:
  • Input and output arrays should be 32-bit aligned.
  • The input must be a multiple of 16 luma pixels
Implementation Notes:
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
  • The loop has been unrolled a total of 16 times to allow for processing 8 pixels in each datapath.
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_yc_demux_le16_8

IMG_yc_demux_le16_8

Detailed Description

Functions

void IMG_yc_demux_le16_8 (int n, const unsigned char *restrict yc, short *restrict y, short *restrict cr, short *restrict cb)

Function Documentation

void IMG_yc_demux_le16_8 | ( | int | n,
 |  | const unsigned char *restrict | yc,
 |  | short *restrict | y,
 |  | short *restrict | cr,
 |  | short *restrict | cb
 | ) |  |

Description:
This function reads the byte-oriented pixel data, zero-extends it, and then writes it to the appropriate result array. Both the luma and chroma values are expected to be unsigned.
The data is expected to be in an order consistent with reading byte oriented data from a word-oriented peripheral that is operating in LITTLE ENDIAN mode, while the CPU is in LITTLE ENDIAN mode. This function unpacks the byte-oriented data so that further processing may proceed in LITTLE ENDIAN mode.
Parameters:
n | Number of luma pixels
yc | Interleaved luma/chroma
y | Luma plane (16-bit)
cr | Cr chroma plane (16-bit)
cb | Cb chroma plane (16-bit)
Algorithm:
The input array 'yc' is expected to be an interleaved 4:2:2 video stream. The input is expected in LITTLE ENDIAN byte order within each 4-byte word. This is consistent with reading the video stream from a word-oriented LITTLE ENDIAN device while the C6000 device is in a LITTLE ENDIAN configuration.
In other words, the expected pixel order is:

                    Word 0           Word 1          Word 2
                +---------------+---------------+---------------+--
          Byte# | 0   1   2   3 | 4   5   6   7 | 8   9  10  11 |...
                | y0 cr0 y1 cb0 | y2 cr2 y3 cb2 | y4 cr4 y5 cb4 |...
                +---------------+---------------+---------------+--
The output arrays 'y', 'cr', and 'cb' are expected to not overlap. The de-interleaved pixels are written as half-words in LITTLE ENDIAN order.
Please see the IMGLIB function IMB_yc_demux_be16_8 for code which handles input coming from a BIG ENDIAN device.
Assumptions:
  • Input and output arrays should be 32-bit aligned.
  • The input must be a multiple of 16 luma pixels
Implementation Notes:
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
  • The loop has been unrolled a total of 16 times to allow for processing 8 pixels in each datapath.
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: IMG_ycbcr422pl_to_rgb565

IMG_ycbcr422pl_to_rgb565

Detailed Description

Functions

void IMG_ycbcr422pl_to_rgb565 (const short coeff[5], const unsigned char *restrict y_data, const unsigned char *restrict cb_data, const unsigned char *restrict cr_data, unsigned short *restrict rgb_data, unsigned num_pixels)

Function Documentation

void IMG_ycbcr422pl_to_rgb565 | ( | const short | coeff[5],
 |  | const unsigned char *restrict | y_data,
 |  | const unsigned char *restrict | cb_data,
 |  | const unsigned char *restrict | cr_data,
 |  | unsigned short *restrict | rgb_data,
 |  | unsigned | num_pixels
 | ) |  |

Description:
This kernel performs Y'CbCr to RGB conversion. From the Color FAQ, http://home.inforamp.net/~poynton/ColorFAQ.html:
Various scale factors are applied to (B'-Y') and (R'-Y') for different applications. The Y'PbPr scale factors are optimized for component analog video. The Y'CbCr scaling is appropriate for component digital video, JPEG and MPEG. Kodak's PhotoYCC(tm) uses scale factors optimized for the gamut of film colors. Y'UV scaling is appropriate as an intermediate step in the formation of composite NTSC or PAL video signals, but is not appropriate when the components are keps separate. Y'UV nomenclature is now used rather loosely, and it sometimes denotes any scaling of (B'-Y') and (R'-Y'). Y'IQ coding is obsolete.
This code can perform various flavors of Y'CbCr to RGB conversion as long as the offsets on Y, Cb, and Cr are -16, -128, and -128, respectively, and the coefficients match the pattern shown.
The kernel implements the following matrix form, which involves 5 unique coefficients:

          [ coeff[0] 0.0000   coeff[1] ]   [ Y' -  16 ]     [ R']
          [ coeff[0] coeff[2] coeff[3] ] * [ Cb - 128 ]  =  [ G']
          [ coeff[0] coeff[4] 0.0000   ]   [ Cr - 128 ]     [ B']
Below are some common coefficient sets, along with the matrix equation that they correspond to. Coefficients are in signed Q13 notation, which gives a suitable balance between precision and range.

      1.  Y'CbCr -> RGB conversion with RGB levels that correspond to
          the 219-level range of Y'.  Expected ranges are [16..235] for
          Y' and [16..240] for Cb and Cr.

          coeff[] = { 0x2000, 0x2BDD, -0x0AC5, -0x1658, 0x3770 };

          [ 1.0000    0.0000    1.3707 ]   [ Y' -  16 ]     [ R']
          [ 1.0000   -0.3365   -0.6982 ] * [ Cb - 128 ]  =  [ G']
          [ 1.0000    1.7324    0.0000 ]   [ Cr - 128 ]     [ B']

      2.  Y'CbCr -> RGB conversion with the 219-level range of Y'
          expanded to fill the full RGB dynamic range.  (The matrix
          has been scaled by 255/219.)  Expected ranges are [16..235]
          for Y' and [16..240] for Cb and Cr.

          coeff[] = { 0x2543, 0x3313, -0x0C8A, -0x1A04, 0x408D };

          [ 1.1644    0.0000    1.5960 ]   [ Y' -  16 ]     [ R']
          [ 1.1644   -0.3918   -0.8130 ] * [ Cb - 128 ]  =  [ G']
          [ 1.1644    2.0172    0.0000 ]   [ Cr - 128 ]     [ B']

      3.  Y'CbCr -> BGR conversion with RGB levels that correspond to
          the 219-level range of Y'.  This is equivalent to #1 above,
          except that the R, G, and B output order in the packed
          pixels is reversed.  Note:  The 'cr_data' and 'cb_data'
          input arguments must be exchanged for this example as
          indicated under USAGE above.

          coeff[] = { 0x2000, 0x3770, -0x1658, -0x0AC5, 0x2BDD };

          [ 1.0000    0.0000    1.7324 ]   [ Y' -  16 ]     [ B']
          [ 1.0000   -0.6982   -0.3365 ] * [ Cr - 128 ]  =  [ G']
          [ 1.0000    1.3707    0.0000 ]   [ Cb - 128 ]     [ R']

      4.  Y'CbCr -> BGR conversion with the 219-level range of Y'
          expanded to fill the full RGB dynamic range.  This is
          equivalent to #2 above, except that the R, G, and B output
          order in the packed pixels is reversed.  Note:  The
          'cr_data' and 'cb_data' input arguments must be exchanged
          for this example as indicated under USAGE above.

          coeff[] = { 0x2000, 0x408D, -0x1A04, -0x0C8A, 0x3313 };

          [ 1.0000    0.0000    2.0172 ]   [ Y' -  16 ]     [ B']
          [ 1.0000   -0.8130   -0.3918 ] * [ Cr - 128 ]  =  [ G']
          [ 1.0000    1.5960    0.0000 ]   [ Cb - 128 ]     [ R']

Other scalings of the color differences (B'-Y') and (R'-Y') (sometimes incorrectly referred to as U and V) are supported, as long as the color differences are unsigned values centered around 128 rather than signed values centered around 0, as noted above.

In addition to performing plain color-space conversion, color saturation can be adjusted by scaling coeff[1] through coeff[4]. Similarly, brightness can be adjusted by scaling coeff[0]. General hue adjustment can not be performed, however, due to the two zeros hard-coded in the matrix.
Usage:
This function takes the following parameters:
Parameters:
coeff | Matrix coefficients.
y_data | Luminence data (Y')
cb_data | Blue color-diff (B'-Y')
cr_data | Red color-diff (R'-Y')
rgb_data | RGB 5:6:5 packed pixel out.
num_pixels | Number of luma pixels to process
The 'coeff[]' array contains the color-space-conversion matrix coefficients. The 'y_data', 'cb_data' and 'cr_data' pointers point to the separate input image planes. The 'rgb_data' pointer points to the output image buffer. See below for alignment constraints on these buffers.
The kernel is designed to process arbitrary amounts of 4:2:2 image data, although 4:2:0 image data may be processed as well. For 4:2:2 input data, the 'y_data', 'cb_data' and 'cr_data' arrays may hold an arbitrary amount of image data, including multiple scan lines of image data.
For 4:2:0 input data, only a single scan-line (or portion thereof) may be processed at a time. This is achieved by calling the function twice using the same row data for 'cr_data' and 'cb_data', and providing new row data for 'y_data'. This is numerically equivalent to replicating the Cr and Cb pixels vertically.
The coefficients in the coeff array must be in signed Q13 form. These coefficients correspond to the following matrix equation:

          [ coeff[0] 0.0000   coeff[1] ]   [ Y' -  16 ]     [ R']
          [ coeff[0] coeff[2] coeff[3] ] * [ Cb - 128 ]  =  [ G']
          [ coeff[0] coeff[4] 0.0000   ]   [ Cr - 128 ]     [ B']
The output from this kernel is 16-bit RGB in 5:6:5 format. The RGB components are packed into halfwords as shown below.

                      15      11 10       5 4        0
                    +----------+----------+----------+
                    |   Red    |  Green   |   Blue   |
                    +----------+----------+----------+

This kernel can also return the red, green, and blue values in the opposite order if a particular application requires it. This is achieved by exchanging the 'cb_data' and 'cr_data' arguments when calling the function, and by reversing the order of coefficients in coeff[1] through coeff[4]. This essentially implements the following matrix multiply:

          [ coeff[0] 0.0000   coeff[4] ]   [ Y' -  16 ]     [ B']
          [ coeff[0] coeff[3] coeff[2] ] * [ Cr - 128 ]  =  [ G']
          [ coeff[0] coeff[1] 0.0000   ]   [ Cb - 128 ]     [ R']

The reversed RGB ordering output by this mode is as follows:

                      15      11 10       5 4        0
                    +----------+----------+----------+
                    |   Blue   |  Green   |   Red    |
                    +----------+----------+----------+

Assumptions:
  • The number of luma samples must to be a multiple of 8
  • The input Y array should be 32-bit aligned
  • The input Cr and Cb arrays should be 16-bit aligned
  • The output image should be 32-bit aligned
Implementation Notes:
  • This code is fully interruptible and fully reentrant
  • This code is compatible with C64x+ processors
Benchmarks:
See IMGLIB_Test_Report.html for cycle and memory information.


IMGLIB: File Index

  • File List
  • Globals

IMGLIB File List

Here is a list of all files with brief descriptions:
doxygen.h [code]
IMG_boundary_16s.h [code]
c64P/IMG_boundary_16s.h [code]
IMG_boundary_8.h [code]
c64P/IMG_boundary_8.h [code]
IMG_clipping_16s.h [code]
c64P/IMG_clipping_16s.h [code]
IMG_conv_11x11_i16s_c16s.h [code]
c64P/IMG_conv_11x11_i16s_c16s.h [code]
IMG_conv_11x11_i8_c8s.h [code]
c64P/IMG_conv_11x11_i8_c8s.h [code]
IMG_conv_3x3_i16_c16s.h [code]
c64P/IMG_conv_3x3_i16_c16s.h [code]
IMG_conv_3x3_i16s_c16s.h [code]
c64P/IMG_conv_3x3_i16s_c16s.h [code]
IMG_conv_3x3_i8_c8s.h [code]
c64P/IMG_conv_3x3_i8_c8s.h [code]
IMG_conv_5x5_i16s_c16s.h [code]
c64P/IMG_conv_5x5_i16s_c16s.h [code]
IMG_conv_5x5_i8_c16s.h [code]
c64P/IMG_conv_5x5_i8_c16s.h [code]
IMG_conv_5x5_i8_c8s.h [code]
c64P/IMG_conv_5x5_i8_c8s.h [code]
IMG_conv_7x7_i16s_c16s.h [code]
c64P/IMG_conv_7x7_i16s_c16s.h [code]
IMG_conv_7x7_i8_c16s.h [code]
c64P/IMG_conv_7x7_i8_c16s.h [code]
IMG_conv_7x7_i8_c8s.h [code]
c64P/IMG_conv_7x7_i8_c8s.h [code]
IMG_corr_11x11_i16s_c16s.h [code]
c64P/IMG_corr_11x11_i16s_c16s.h [code]
IMG_corr_11x11_i8_c16s.h [code]
c64P/IMG_corr_11x11_i8_c16s.h [code]
IMG_corr_3x3_i16_c16.h [code]
c64P/IMG_corr_3x3_i16_c16.h [code]
IMG_corr_3x3_i16s_c16s.h [code]
c64P/IMG_corr_3x3_i16s_c16s.h [code]
IMG_corr_3x3_i8_c16s.h [code]
c64P/IMG_corr_3x3_i8_c16s.h [code]
IMG_corr_3x3_i8_c8.h [code]
c64P/IMG_corr_3x3_i8_c8.h [code]
IMG_corr_5x5_i16s_c16s.h [code]
c64P/IMG_corr_5x5_i16s_c16s.h [code]
IMG_corr_gen_i16s_c16s.h [code]
c64P/IMG_corr_gen_i16s_c16s.h [code]
IMG_corr_gen_iq.h [code]
c64P/IMG_corr_gen_iq.h [code]
IMG_dilate_bin.h [code]
c64P/IMG_dilate_bin.h [code]
IMG_erode_bin.h [code]
c64P/IMG_erode_bin.h [code]
IMG_errdif_bin_16.h [code]
c64P/IMG_errdif_bin_16.h [code]
IMG_errdif_bin_8.h [code]
c64P/IMG_errdif_bin_8.h [code]
IMG_fdct_8x8.h [code]
c64P/IMG_fdct_8x8.h [code]
IMG_histogram_16.h [code]
c64P/IMG_histogram_16.h [code]
IMG_histogram_8.h [code]
c64P/IMG_histogram_8.h [code]
IMG_idct_8x8_12q4.h [code]
c64P/IMG_idct_8x8_12q4.h [code]
IMG_mad_16x16.h [code]
c64P/IMG_mad_16x16.h [code]
IMG_mad_8x8.h [code]
c64P/IMG_mad_8x8.h [code]
IMG_median_3x3_16.h [code]
c64P/IMG_median_3x3_16.h [code]
IMG_median_3x3_16s.h [code]
c64P/IMG_median_3x3_16s.h [code]
IMG_median_3x3_8.h [code]
c64P/IMG_median_3x3_8.h [code]
IMG_perimeter_16.h [code]
c64P/IMG_perimeter_16.h [code]
IMG_perimeter_8.h [code]
c64P/IMG_perimeter_8.h [code]
IMG_pix_expand.h [code]
c64P/IMG_pix_expand.h [code]
IMG_pix_sat.h [code]
c64P/IMG_pix_sat.h [code]
IMG_quantize.h [code]
c64P/IMG_quantize.h [code]
IMG_sad_16x16.h [code]
c64P/IMG_sad_16x16.h [code]
IMG_sad_8x8.h [code]
c64P/IMG_sad_8x8.h [code]
IMG_sobel_3x3_16.h [code]
c64P/IMG_sobel_3x3_16.h [code]
IMG_sobel_3x3_16s.h [code]
c64P/IMG_sobel_3x3_16s.h [code]
IMG_sobel_3x3_8.h [code]
c64P/IMG_sobel_3x3_8.h [code]
IMG_sobel_5x5_16s.h [code]
c64P/IMG_sobel_5x5_16s.h [code]
IMG_sobel_7x7_16s.h [code]
c64P/IMG_sobel_7x7_16s.h [code]
IMG_thr_gt2max_16.h [code]
c64P/IMG_thr_gt2max_16.h [code]
IMG_thr_gt2max_8.h [code]
c64P/IMG_thr_gt2max_8.h [code]
IMG_thr_gt2thr_16.h [code]
c64P/IMG_thr_gt2thr_16.h [code]
IMG_thr_gt2thr_8.h [code]
c64P/IMG_thr_gt2thr_8.h [code]
IMG_thr_le2min_16.h [code]
c64P/IMG_thr_le2min_16.h [code]
IMG_thr_le2min_8.h [code]
c64P/IMG_thr_le2min_8.h [code]
IMG_thr_le2thr_16.h [code]
c64P/IMG_thr_le2thr_16.h [code]
IMG_thr_le2thr_8.h [code]
c64P/IMG_thr_le2thr_8.h [code]
IMG_wave_horz.h [code]
c64P/IMG_wave_horz.h [code]
IMG_wave_vert.h [code]
c64P/IMG_wave_vert.h [code]
IMG_yc_demux_be16_16.h [code]
c64P/IMG_yc_demux_be16_16.h [code]
IMG_yc_demux_be16_8.h [code]
c64P/IMG_yc_demux_be16_8.h [code]
IMG_yc_demux_le16_16.h [code]
c64P/IMG_yc_demux_le16_16.h [code]
IMG_yc_demux_le16_8.h [code]
c64P/IMG_yc_demux_le16_8.h [code]
IMG_ycbcr422pl_to_rgb565.h [code]
c64P/IMG_ycbcr422pl_to_rgb565.h [code]


IMGLIB: doxygen.h File Reference

doxygen.h File Reference

Go to the source code of this file.


IMGLIB: IMG_boundary_16s.h File Reference

IMG_boundary_16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_BOUNDARY_16S_H_ 1

Define Documentation

#define _IMG_BOUNDARY_16S_H_ 1

Definition at line 40 of file IMG_boundary_16s.h.


IMGLIB: IMG_boundary_16s.h File Reference

IMG_boundary_16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_BOUNDARY_16S_H_ 1

Functions

void | IMG_boundary_16s (const short *restrict i_data, int rows, int cols, unsigned int *restrict o_coord, short *restrict o_grey)

Define Documentation

#define IMG_BOUNDARY_16S_H_ 1

Definition at line 38 of file c64P/IMG_boundary_16s.h.


IMGLIB: IMG_boundary_8.h File Reference

IMG_boundary_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_BOUNDARY_8_H_ 1

Define Documentation

#define _IMG_BOUNDARY_8_H_ 1

Definition at line 40 of file IMG_boundary_8.h.


IMGLIB: IMG_boundary_8.h File Reference

IMG_boundary_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_BOUNDARY_8_H_ 1

Functions

void | IMG_boundary_8 (const unsigned char *restrict i_data, int rows, int cols, int *restrict o_coord, int *restrict o_grey)

Define Documentation

#define IMG_BOUNDARY_8_H_ 1

Definition at line 38 of file c64P/IMG_boundary_8.h.


IMGLIB: IMG_clipping_16s.h File Reference

IMG_clipping_16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CLIPPING_16S_H_ 1

Define Documentation

#define _IMG_CLIPPING_16S_H_ 1

Definition at line 40 of file IMG_clipping_16s.h.


IMGLIB: IMG_clipping_16s.h File Reference

IMG_clipping_16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CLIPPING_16S_H_ 1

Functions

void | IMG_clipping_16s (const short *restrict x, short rows, short cols, short *restrict r, short THRES_MAX, short THRES_MIN)

Define Documentation

#define IMG_CLIPPING_16S_H_ 1

Definition at line 38 of file c64P/IMG_clipping_16s.h.


IMGLIB: IMG_conv_11x11_i16s_c16s.h File Reference

IMG_conv_11x11_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_11X11_I16S_C16S_H_ 1

Define Documentation

#define _IMG_CONV_11X11_I16S_C16S_H_ 1

Definition at line 40 of file IMG_conv_11x11_i16s_c16s.h.


IMGLIB: IMG_conv_11x11_i16s_c16s.h File Reference

IMG_conv_11x11_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_11X11_I16S_C16S_H_ 1

Functions

void | IMG_conv_11x11_i16s_c16s (const short *restrict imgin_ptr, short *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_11X11_I16S_C16S_H_ 1

Definition at line 38 of file c64P/IMG_conv_11x11_i16s_c16s.h.


IMGLIB: IMG_conv_11x11_i8_c8s.h File Reference

IMG_conv_11x11_i8_c8s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_11X11_I8_C8S_H_ 1

Define Documentation

#define _IMG_CONV_11X11_I8_C8S_H_ 1

Definition at line 40 of file IMG_conv_11x11_i8_c8s.h.


IMGLIB: IMG_conv_11x11_i8_c8s.h File Reference

IMG_conv_11x11_i8_c8s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_11X11_I8_C8S_H_ 1

Functions

void | IMG_conv_11x11_i8_c8s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const char *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_11X11_I8_C8S_H_ 1

Definition at line 38 of file c64P/IMG_conv_11x11_i8_c8s.h.


IMGLIB: IMG_conv_3x3_i16_c16s.h File Reference

IMG_conv_3x3_i16_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_3X3_I16_C16S_H_ 1

Define Documentation

#define _IMG_CONV_3X3_I16_C16S_H_ 1

Definition at line 40 of file IMG_conv_3x3_i16_c16s.h.


IMGLIB: IMG_conv_3x3_i16_c16s.h File Reference

IMG_conv_3x3_i16_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_3X3_I16_C16S_H_ 1

Functions

void | IMG_conv_3x3_i16_c16s (const unsigned short *restrict imgin_ptr, unsigned short *restrict imgout_ptr, int width, const short *restrict mask_ptr, int shift)

Define Documentation

#define IMG_CONV_3X3_I16_C16S_H_ 1

Definition at line 38 of file c64P/IMG_conv_3x3_i16_c16s.h.


IMGLIB: IMG_conv_3x3_i16s_c16s.h File Reference

IMG_conv_3x3_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_3X3_I16S_C16S_H_ 1

Define Documentation

#define _IMG_CONV_3X3_I16S_C16S_H_ 1

Definition at line 40 of file IMG_conv_3x3_i16s_c16s.h.


IMGLIB: IMG_conv_3x3_i16s_c16s.h File Reference

IMG_conv_3x3_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_3X3_I16S_C16S_H_ 1

Functions

void | IMG_conv_3x3_i16s_c16s (const short *restrict imgin_ptr, short *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_3X3_I16S_C16S_H_ 1

Definition at line 38 of file c64P/IMG_conv_3x3_i16s_c16s.h.


IMGLIB: IMG_conv_3x3_i8_c8s.h File Reference

IMG_conv_3x3_i8_c8s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_3X3_I8_C8S_H_ 1

Define Documentation

#define _IMG_CONV_3X3_I8_C8S_H_ 1

Definition at line 40 of file IMG_conv_3x3_i8_c8s.h.


IMGLIB: IMG_conv_3x3_i8_c8s.h File Reference

IMG_conv_3x3_i8_c8s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_3X3_I8_C8S_H_ 1

Functions

void | IMG_conv_3x3_i8_c8s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const char *restrict mask_ptr, short shift)


IMGLIB: IMG_conv_5x5_i16s_c16s.h File Reference

IMG_conv_5x5_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_5X5_I16S_C16S_H_ 1

Define Documentation

#define _IMG_CONV_5X5_I16S_C16S_H_ 1

Definition at line 40 of file IMG_conv_5x5_i16s_c16s.h.


IMGLIB: IMG_conv_5x5_i16s_c16s.h File Reference

IMG_conv_5x5_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_5X5_I16S_C16S_H_ 1

Functions

void | IMG_conv_5x5_i16s_c16s (const short *restrict imgin_ptr, short *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_5X5_I16S_C16S_H_ 1

Definition at line 38 of file c64P/IMG_conv_5x5_i16s_c16s.h.


IMGLIB: IMG_conv_5x5_i8_c16s.h File Reference

IMG_conv_5x5_i8_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_5X5_I8_C16S_H_ 1

Define Documentation

#define _IMG_CONV_5X5_I8_C16S_H_ 1

Definition at line 40 of file IMG_conv_5x5_i8_c16s.h.


IMGLIB: IMG_conv_5x5_i8_c16s.h File Reference

IMG_conv_5x5_i8_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_5X5_I8_C16S_H_ 1

Functions

void | IMG_conv_5x5_i8_c16s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_5X5_I8_C16S_H_ 1

Definition at line 38 of file c64P/IMG_conv_5x5_i8_c16s.h.


IMGLIB: IMG_conv_5x5_i8_c8s.h File Reference

IMG_conv_5x5_i8_c8s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_5X5_I8_C8S_H_ 1

Define Documentation

#define _IMG_CONV_5X5_I8_C8S_H_ 1

Definition at line 40 of file IMG_conv_5x5_i8_c8s.h.


IMGLIB: IMG_conv_5x5_i8_c8s.h File Reference

IMG_conv_5x5_i8_c8s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_5X5_I8_C8S_H_ 1

Functions

void | IMG_conv_5x5_i8_c8s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const char *restrict mask_ptr, short shift)


IMGLIB: IMG_conv_7x7_i16s_c16s.h File Reference

IMG_conv_7x7_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_7X7_I16S_C16S_H_ 1

Define Documentation

#define _IMG_CONV_7X7_I16S_C16S_H_ 1

Definition at line 40 of file IMG_conv_7x7_i16s_c16s.h.


IMGLIB: IMG_conv_7x7_i16s_c16s.h File Reference

IMG_conv_7x7_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_7X7_I16S_C16S_H_ 1

Functions

void | IMG_conv_7x7_i16s_c16s (const short *restrict imgin_ptr, short *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_7X7_I16S_C16S_H_ 1

Definition at line 38 of file c64P/IMG_conv_7x7_i16s_c16s.h.


IMGLIB: IMG_conv_7x7_i8_c16s.h File Reference

IMG_conv_7x7_i8_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_7X7_I8_C16S_H_ 1

Define Documentation

#define _IMG_CONV_7X7_I8_C16S_H_ 1

Definition at line 40 of file IMG_conv_7x7_i8_c16s.h.


IMGLIB: IMG_conv_7x7_i8_c16s.h File Reference

IMG_conv_7x7_i8_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_7X7_I8_C16S_H_ 1

Functions

void | IMG_conv_7x7_i8_c16s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, int shift)

Define Documentation

#define IMG_CONV_7X7_I8_C16S_H_ 1

Definition at line 38 of file c64P/IMG_conv_7x7_i8_c16s.h.


IMGLIB: IMG_conv_7x7_i8_c8s.h File Reference

IMG_conv_7x7_i8_c8s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CONV_7X7_I8_C8S_H_ 1

Define Documentation

#define _IMG_CONV_7X7_I8_C8S_H_ 1

Definition at line 40 of file IMG_conv_7x7_i8_c8s.h.


IMGLIB: IMG_conv_7x7_i8_c8s.h File Reference

IMG_conv_7x7_i8_c8s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CONV_7X7_I8_C8S_H_ 1

Functions

void | IMG_conv_7x7_i8_c8s (const unsigned char *restrict imgin_ptr, unsigned char *restrict imgout_ptr, short width, short pitch, const char *restrict mask_ptr, short shift)

Define Documentation

#define IMG_CONV_7X7_I8_C8S_H_ 1

Definition at line 38 of file c64P/IMG_conv_7x7_i8_c8s.h.


IMGLIB: IMG_corr_11x11_i16s_c16s.h File Reference

IMG_corr_11x11_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_11X11_I16S_C16S_H_ 1

Define Documentation

#define _IMG_CORR_11X11_I16S_C16S_H_ 1

Definition at line 40 of file IMG_corr_11x11_i16s_c16s.h.


IMGLIB: IMG_corr_11x11_i16s_c16s.h File Reference

IMG_corr_11x11_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_11X11_I16S_C16S_H_ 1

Functions

void | IMG_corr_11x11_i16s_c16s (const short *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift, int round)

Define Documentation

#define IMG_CORR_11X11_I16S_C16S_H_ 1

Definition at line 38 of file c64P/IMG_corr_11x11_i16s_c16s.h.


IMGLIB: IMG_corr_11x11_i8_c16s.h File Reference

IMG_corr_11x11_i8_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_11X11_I8_C16S_H_ 1

Define Documentation

#define _IMG_CORR_11X11_I8_C16S_H_ 1

Definition at line 40 of file IMG_corr_11x11_i8_c16s.h.


IMGLIB: IMG_corr_11x11_i8_c16s.h File Reference

IMG_corr_11x11_i8_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_11X11_I8_C16S_H_ 1

Functions

void | IMG_corr_11x11_i8_c16s (const unsigned char *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr)

Define Documentation

#define IMG_CORR_11X11_I8_C16S_H_ 1

Definition at line 38 of file c64P/IMG_corr_11x11_i8_c16s.h.


IMGLIB: IMG_corr_3x3_i16_c16.h File Reference

IMG_corr_3x3_i16_c16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_3X3_I16_C16_H_ 1

Define Documentation

#define _IMG_CORR_3X3_I16_C16_H_ 1

Definition at line 40 of file IMG_corr_3x3_i16_c16.h.


IMGLIB: IMG_corr_3x3_i16_c16.h File Reference

IMG_corr_3x3_i16_c16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_3X3_I16_C16_H_ 1

Functions

void | IMG_corr_3x3_i16_c16 (const unsigned short *imgin_ptr, unsigned int *restrict imgout_ptr, const unsigned short *mask_ptr, short pitch, short width)

Define Documentation

#define IMG_CORR_3X3_I16_C16_H_ 1

Definition at line 38 of file c64P/IMG_corr_3x3_i16_c16.h.


IMGLIB: IMG_corr_3x3_i16s_c16s.h File Reference

IMG_corr_3x3_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_3X3_I16S_C16S_H_ 1

Define Documentation

#define _IMG_CORR_3X3_I16S_C16S_H_ 1

Definition at line 40 of file IMG_corr_3x3_i16s_c16s.h.


IMGLIB: IMG_corr_3x3_i16s_c16s.h File Reference

IMG_corr_3x3_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_3X3_I16S_C16S_H_ 1

Functions

void | IMG_corr_3x3_i16s_c16s (const short *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift, int round)

Define Documentation

#define IMG_CORR_3X3_I16S_C16S_H_ 1

Definition at line 38 of file c64P/IMG_corr_3x3_i16s_c16s.h.


IMGLIB: IMG_corr_3x3_i8_c16s.h File Reference

IMG_corr_3x3_i8_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_3X3_I8_C16S_H_ 1

Define Documentation

#define _IMG_CORR_3X3_I8_C16S_H_ 1

Definition at line 40 of file IMG_corr_3x3_i8_c16s.h.


IMGLIB: IMG_corr_3x3_i8_c16s.h File Reference

IMG_corr_3x3_i8_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_3X3_I8_C16S_H_ 1

Functions

void | IMG_corr_3x3_i8_c16s (const unsigned char *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr)

Define Documentation

#define IMG_CORR_3X3_I8_C16S_H_ 1

Definition at line 38 of file c64P/IMG_corr_3x3_i8_c16s.h.


IMGLIB: IMG_corr_3x3_i8_c8.h File Reference

IMG_corr_3x3_i8_c8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_3X3_I8_C8_H_ 1

Define Documentation

#define _IMG_CORR_3X3_I8_C8_H_ 1

Definition at line 40 of file IMG_corr_3x3_i8_c8.h.


IMGLIB: IMG_corr_3x3_i8_c8.h File Reference

IMG_corr_3x3_i8_c8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_3X3_I8_C8_H_ 1

Functions

void | IMG_corr_3x3_i8_c8 (const unsigned char *imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const unsigned char *mask_ptr, short shift, int round)

Define Documentation

#define IMG_CORR_3X3_I8_C8_H_ 1

Definition at line 38 of file c64P/IMG_corr_3x3_i8_c8.h.


IMGLIB: IMG_corr_5x5_i16s_c16s.h File Reference

IMG_corr_5x5_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_5X5_I16S_C16S_H_ 1

Define Documentation

#define _IMG_CORR_5X5_I16S_C16S_H_ 1

Definition at line 40 of file IMG_corr_5x5_i16s_c16s.h.


IMGLIB: IMG_corr_5x5_i16s_c16s.h File Reference

IMG_corr_5x5_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_5X5_I16S_C16S_H_ 1

Functions

void | IMG_corr_5x5_i16s_c16s (const short *restrict imgin_ptr, int *restrict imgout_ptr, short width, short pitch, const short *restrict mask_ptr, short shift, int round)

Define Documentation

#define IMG_CORR_5X5_I16S_C16S_H_ 1

Definition at line 38 of file c64P/IMG_corr_5x5_i16s_c16s.h.


IMGLIB: IMG_corr_gen_i16s_c16s.h File Reference

IMG_corr_gen_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_GEN_I16S_C16S_H_ 1

Define Documentation

#define _IMG_CORR_GEN_I16S_C16S_H_ 1

Definition at line 40 of file IMG_corr_gen_i16s_c16s.h.


IMGLIB: IMG_corr_gen_i16s_c16s.h File Reference

IMG_corr_gen_i16s_c16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_GEN_I16S_C16S_H_ 1

Functions

void | IMG_corr_gen_i16s_c16s (short *restrict x, short *restrict h, short *restrict y, int m, int pitch)

Define Documentation

#define IMG_CORR_GEN_I16S_C16S_H_ 1

Definition at line 38 of file c64P/IMG_corr_gen_i16s_c16s.h.


IMGLIB: IMG_corr_gen_iq.h File Reference

IMG_corr_gen_iq.h File Reference

Go to the source code of this file.

Defines

#define _IMG_CORR_GEN_IQ_H_ 1

Define Documentation

#define _IMG_CORR_GEN_IQ_H_ 1

Definition at line 40 of file IMG_corr_gen_iq.h.


IMGLIB: IMG_corr_gen_iq.h File Reference

IMG_corr_gen_iq.h File Reference

Go to the source code of this file.

Defines

#define | IMG_CORR_GEN_IQ_H_ 1

Functions

void | IMG_corr_gen_iq (const int *restrict x, const short *restrict h, int *restrict y, int m, int pitch, int x_qpt, int h_qpt, int y_qpt)

Define Documentation

#define IMG_CORR_GEN_IQ_H_ 1

Definition at line 38 of file c64P/IMG_corr_gen_iq.h.


IMGLIB: IMG_dilate_bin.h File Reference

IMG_dilate_bin.h File Reference

Go to the source code of this file.

Defines

#define _IMG_DILATE_BIN_H_ 1

Define Documentation

#define _IMG_DILATE_BIN_H_ 1

Definition at line 40 of file IMG_dilate_bin.h.


IMGLIB: IMG_dilate_bin.h File Reference

IMG_dilate_bin.h File Reference

Go to the source code of this file.

Defines

#define | IMG_DILATE_BIN_H_ 1

Functions

void | IMG_dilate_bin (const unsigned char *restrict in_data, unsigned char *restrict out_data, const char *restrict mask, int cols)

Define Documentation

#define IMG_DILATE_BIN_H_ 1

Definition at line 38 of file c64P/IMG_dilate_bin.h.


IMGLIB: IMG_erode_bin.h File Reference

IMG_erode_bin.h File Reference

Go to the source code of this file.

Defines

#define _IMG_ERODE_BIN_H_ 1

Define Documentation

#define _IMG_ERODE_BIN_H_ 1

Definition at line 40 of file IMG_erode_bin.h.


IMGLIB: IMG_erode_bin.h File Reference

IMG_erode_bin.h File Reference

Go to the source code of this file.

Defines

#define | IMG_ERODE_BIN_H_ 1

Functions

void | IMG_erode_bin (const unsigned char *restrict in_data, unsigned char *restrict out_data, const char *restrict mask, int cols)

Define Documentation

#define IMG_ERODE_BIN_H_ 1

Definition at line 38 of file c64P/IMG_erode_bin.h.


IMGLIB: IMG_errdif_bin_16.h File Reference

IMG_errdif_bin_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_ERRDIF_BIN_16_H_ 1

Define Documentation

#define _IMG_ERRDIF_BIN_16_H_ 1

Definition at line 40 of file IMG_errdif_bin_16.h.


IMGLIB: IMG_errdif_bin_16.h File Reference

IMG_errdif_bin_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_ERRDIF_BIN_16_H_ 1

Functions

void | IMG_errdif_bin_16 (unsigned short *restrict errdif_data, int cols, int rows, short *restrict err_buf, unsigned short thresh)

Define Documentation

#define IMG_ERRDIF_BIN_16_H_ 1

Definition at line 38 of file c64P/IMG_errdif_bin_16.h.


IMGLIB: IMG_errdif_bin_8.h File Reference

IMG_errdif_bin_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_ERRDIF_BIN_8_H_ 1

Define Documentation

#define _IMG_ERRDIF_BIN_8_H_ 1

Definition at line 40 of file IMG_errdif_bin_8.h.


IMGLIB: IMG_errdif_bin_8.h File Reference

IMG_errdif_bin_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_ERRDIF_BIN_8_H_ 1

Functions

void | IMG_errdif_bin_8 (unsigned char *restrict errdif_data, int cols, int rows, short *restrict err_buf, unsigned char thresh)

Define Documentation

#define IMG_ERRDIF_BIN_8_H_ 1

Definition at line 38 of file c64P/IMG_errdif_bin_8.h.


IMGLIB: IMG_fdct_8x8.h File Reference

IMG_fdct_8x8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_FDCT_8X8_H_ 1

Define Documentation

#define _IMG_FDCT_8X8_H_ 1

Definition at line 40 of file IMG_fdct_8x8.h.


IMGLIB: IMG_fdct_8x8.h File Reference

IMG_fdct_8x8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_FDCT_8X8_H_ 1

Functions

void | IMG_fdct_8x8 (short fdct_data[], unsigned num_fdcts)

Define Documentation

#define IMG_FDCT_8X8_H_ 1

Definition at line 38 of file c64P/IMG_fdct_8x8.h.


IMGLIB: IMG_histogram_16.h File Reference

IMG_histogram_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_HISTOGRAM_16_H_ 1

Define Documentation

#define _IMG_HISTOGRAM_16_H_ 1

Definition at line 40 of file IMG_histogram_16.h.


IMGLIB: IMG_histogram_16.h File Reference

IMG_histogram_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_HISTOGRAM_16_H_ 1

Functions

void | IMG_histogram_16 (unsigned short *restrict image, int n, int accumulate, short *restrict t_hist, short *restrict hist, int img_bits)

Define Documentation

#define IMG_HISTOGRAM_16_H_ 1

Definition at line 38 of file c64P/IMG_histogram_16.h.


IMGLIB: IMG_histogram_8.h File Reference

IMG_histogram_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_HISTOGRAM_8_H_ 1

Define Documentation

#define _IMG_HISTOGRAM_8_H_ 1

Definition at line 40 of file IMG_histogram_8.h.


IMGLIB: IMG_histogram_8.h File Reference

IMG_histogram_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_HISTOGRAM_8_H_ 1

Functions

void | IMG_histogram_8 (const unsigned char *restrict image, int n, short accumulate, short *restrict t_hist, short *restrict hist)

Define Documentation

#define IMG_HISTOGRAM_8_H_ 1

Definition at line 38 of file c64P/IMG_histogram_8.h.


IMGLIB: IMG_idct_8x8_12q4.h File Reference

IMG_idct_8x8_12q4.h File Reference

Go to the source code of this file.

Defines

#define _IMG_IDCT_8X8_12Q4_H_ 1

Define Documentation

#define _IMG_IDCT_8X8_12Q4_H_ 1

Definition at line 40 of file IMG_idct_8x8_12q4.h.


IMGLIB: IMG_idct_8x8_12q4.h File Reference

IMG_idct_8x8_12q4.h File Reference

Go to the source code of this file.

Defines

#define | IMG_IDCT_8X8_12Q4_H_ 1

Functions

void | IMG_idct_8x8_12q4 (short idct_data[], unsigned num_idcts)

Define Documentation

#define IMG_IDCT_8X8_12Q4_H_ 1

Definition at line 38 of file c64P/IMG_idct_8x8_12q4.h.


IMGLIB: IMG_mad_16x16.h File Reference

IMG_mad_16x16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_MAD_16X16_H_ 1

Define Documentation

#define _IMG_MAD_16X16_H_ 1

Definition at line 40 of file IMG_mad_16x16.h.


IMGLIB: IMG_mad_16x16.h File Reference

IMG_mad_16x16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_MAD_16X16_H_ 1

Functions

void | IMG_mad_16x16 (const unsigned char *restrict refImg, const unsigned char *restrict srcImg, int pitch, int h, int v, unsigned *restrict match)

Define Documentation

#define IMG_MAD_16X16_H_ 1

Definition at line 38 of file c64P/IMG_mad_16x16.h.


IMGLIB: IMG_mad_8x8.h File Reference

IMG_mad_8x8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_MAD_8X8_H_ 1

Define Documentation

#define _IMG_MAD_8X8_H_ 1

Definition at line 40 of file IMG_mad_8x8.h.


IMGLIB: IMG_mad_8x8.h File Reference

IMG_mad_8x8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_MAD_8X8_H_ 1

Functions

void | IMG_mad_8x8 (const unsigned char *ref_data, const unsigned char *src_data, int pitch, int sx, int sy, unsigned int *match)

Define Documentation

#define IMG_MAD_8X8_H_ 1

Definition at line 38 of file c64P/IMG_mad_8x8.h.


IMGLIB: IMG_median_3x3_16.h File Reference

IMG_median_3x3_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_MEDIAN_3X3_16_H_ 1

Define Documentation

#define _IMG_MEDIAN_3X3_16_H_ 1

Definition at line 40 of file IMG_median_3x3_16.h.


IMGLIB: IMG_median_3x3_16.h File Reference

IMG_median_3x3_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_MEDIAN_3X3_16_H_ 1

Functions

void | IMG_median_3x3_16 (const unsigned short *restrict i_data, int n, unsigned short *restrict o_data)

Define Documentation

#define IMG_MEDIAN_3X3_16_H_ 1

Definition at line 38 of file c64P/IMG_median_3x3_16.h.


IMGLIB: IMG_median_3x3_16s.h File Reference

IMG_median_3x3_16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_MEDIAN_3X3_16S_H_ 1

Define Documentation

#define _IMG_MEDIAN_3X3_16S_H_ 1

Definition at line 40 of file IMG_median_3x3_16s.h.


IMGLIB: IMG_median_3x3_16s.h File Reference

IMG_median_3x3_16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_MEDIAN_3X3_16S_H_ 1

Functions

void | IMG_median_3x3_16s (const short *restrict i_data, int n, short *restrict o_data)

Define Documentation

#define IMG_MEDIAN_3X3_16S_H_ 1

Definition at line 38 of file c64P/IMG_median_3x3_16s.h.


IMGLIB: IMG_median_3x3_8.h File Reference

IMG_median_3x3_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_MEDIAN_3X3_8_H_ 1

Define Documentation

#define _IMG_MEDIAN_3X3_8_H_ 1

Definition at line 40 of file IMG_median_3x3_8.h.


IMGLIB: IMG_median_3x3_8.h File Reference

IMG_median_3x3_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_MEDIAN_3X3_8_H_ 1

Functions

void | IMG_median_3x3_8 (const unsigned char *restrict i_data, int n, unsigned char *restrict o_data)

Define Documentation

#define IMG_MEDIAN_3X3_8_H_ 1

Definition at line 38 of file c64P/IMG_median_3x3_8.h.


IMGLIB: IMG_perimeter_16.h File Reference

IMG_perimeter_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_PERIMETER_16_H_ 1

Define Documentation

#define _IMG_PERIMETER_16_H_ 1

Definition at line 40 of file IMG_perimeter_16.h.


IMGLIB: IMG_perimeter_16.h File Reference

IMG_perimeter_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_PERIMETER_16_H_ 1

Functions

int | IMG_perimeter_16 (const unsigned short *restrict in, int cols, unsigned short *restrict out)

Define Documentation

#define IMG_PERIMETER_16_H_ 1

Definition at line 38 of file c64P/IMG_perimeter_16.h.


IMGLIB: IMG_perimeter_8.h File Reference

IMG_perimeter_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_PERIMETER_8_H_ 1

Define Documentation

#define _IMG_PERIMETER_8_H_ 1

Definition at line 40 of file IMG_perimeter_8.h.


IMGLIB: IMG_perimeter_8.h File Reference

IMG_perimeter_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_PERIMETER_8_H_ 1

Functions

int | IMG_perimeter_8 (const unsigned char *restrict in, int cols, unsigned char *restrict out)

Define Documentation

#define IMG_PERIMETER_8_H_ 1

Definition at line 38 of file c64P/IMG_perimeter_8.h.


IMGLIB: IMG_pix_expand.h File Reference

IMG_pix_expand.h File Reference

Go to the source code of this file.

Defines

#define _IMG_PIX_EXPAND_H_ 1

Define Documentation

#define _IMG_PIX_EXPAND_H_ 1

Definition at line 40 of file IMG_pix_expand.h.


IMGLIB: IMG_pix_expand.h File Reference

IMG_pix_expand.h File Reference

Go to the source code of this file.

Defines

#define | IMG_PIX_EXPAND_H_ 1

Functions

void | IMG_pix_expand (int n, const unsigned char *restrict in_data, short *restrict out_data)

Define Documentation

#define IMG_PIX_EXPAND_H_ 1

Definition at line 38 of file c64P/IMG_pix_expand.h.


IMGLIB: IMG_pix_sat.h File Reference

IMG_pix_sat.h File Reference

Go to the source code of this file.

Defines

#define _IMG_PIX_SAT_H_ 1

Define Documentation

#define _IMG_PIX_SAT_H_ 1

Definition at line 40 of file IMG_pix_sat.h.


IMGLIB: IMG_pix_sat.h File Reference

IMG_pix_sat.h File Reference

Go to the source code of this file.

Defines

#define | IMG_PIX_SAT_H_ 1

Functions

void | IMG_pix_sat (int n, const short *restrict in_data, unsigned char *restrict out_data)

Define Documentation

#define IMG_PIX_SAT_H_ 1

Definition at line 38 of file c64P/IMG_pix_sat.h.


IMGLIB: IMG_quantize.h File Reference

IMG_quantize.h File Reference

Go to the source code of this file.

Defines

#define _IMG_QUANTIZE_H_ 1

Define Documentation

#define _IMG_QUANTIZE_H_ 1

Definition at line 40 of file IMG_quantize.h.


IMGLIB: IMG_quantize.h File Reference

IMG_quantize.h File Reference

Go to the source code of this file.

Defines

#define | IMG_QUANTIZE_H_ 1

Functions

void | IMG_quantize (short *data, unsigned short num_blks, unsigned short blk_size, const short *recip_tbl, int q_pt)

Define Documentation

#define IMG_QUANTIZE_H_ 1

Definition at line 38 of file c64P/IMG_quantize.h.


IMGLIB: IMG_sad_16x16.h File Reference

IMG_sad_16x16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_SAD_16X16_H_ 1

Define Documentation

#define _IMG_SAD_16X16_H_ 1

Definition at line 40 of file IMG_sad_16x16.h.


IMGLIB: IMG_sad_16x16.h File Reference

IMG_sad_16x16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_SAD_16X16_H_ 1

Functions

unsigned | IMG_sad_16x16 (const unsigned char *restrict srcImg, const unsigned char *restrict refImg, int pitch)

Define Documentation

#define IMG_SAD_16X16_H_ 1

Definition at line 38 of file c64P/IMG_sad_16x16.h.


IMGLIB: IMG_sad_8x8.h File Reference

IMG_sad_8x8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_SAD_8X8_H_ 1

Define Documentation

#define _IMG_SAD_8X8_H_ 1

Definition at line 40 of file IMG_sad_8x8.h.


IMGLIB: IMG_sad_8x8.h File Reference

IMG_sad_8x8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_SAD_8X8_H_ 1

Functions

unsigned | IMG_sad_8x8 (const unsigned char *restrict srcImg, const unsigned char *restrict refImg, int pitch)

Define Documentation

#define IMG_SAD_8X8_H_ 1

Definition at line 38 of file c64P/IMG_sad_8x8.h.


IMGLIB: IMG_sobel_3x3_16.h File Reference

IMG_sobel_3x3_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_SOBEL_3X3_16_H_ 1

Define Documentation

#define _IMG_SOBEL_3X3_16_H_ 1

Definition at line 40 of file IMG_sobel_3x3_16.h.


IMGLIB: IMG_sobel_3x3_16.h File Reference

IMG_sobel_3x3_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_SOBEL_3X3_16_H_ 1

Functions

void | IMG_sobel_3x3_16 (const unsigned short *restrict in, unsigned short *restrict out, short cols, short rows)

Define Documentation

#define IMG_SOBEL_3X3_16_H_ 1

Definition at line 38 of file c64P/IMG_sobel_3x3_16.h.


IMGLIB: IMG_sobel_3x3_16s.h File Reference

IMG_sobel_3x3_16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_SOBEL_3X3_16S_H_ 1

Define Documentation

#define _IMG_SOBEL_3X3_16S_H_ 1

Definition at line 40 of file IMG_sobel_3x3_16s.h.


IMGLIB: IMG_sobel_3x3_16s.h File Reference

IMG_sobel_3x3_16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_SOBEL_3X3_16S_H_ 1

Functions

void | IMG_sobel_3x3_16s (const short *restrict in, short *restrict out, short cols, short rows)

Define Documentation

#define IMG_SOBEL_3X3_16S_H_ 1

Definition at line 38 of file c64P/IMG_sobel_3x3_16s.h.


IMGLIB: IMG_sobel_3x3_8.h File Reference

IMG_sobel_3x3_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_SOBEL_3X3_8_H_ 1

Define Documentation

#define _IMG_SOBEL_3X3_8_H_ 1

Definition at line 40 of file IMG_sobel_3x3_8.h.


IMGLIB: IMG_sobel_3x3_8.h File Reference

IMG_sobel_3x3_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_SOBEL_3x3_8_H_ 1

Functions

void | IMG_sobel_3x3_8 (const unsigned char *restrict in, unsigned char *restrict out, short cols, short rows)

Define Documentation

#define IMG_SOBEL_3x3_8_H_ 1

Definition at line 38 of file c64P/IMG_sobel_3x3_8.h.


IMGLIB: IMG_sobel_5x5_16s.h File Reference

IMG_sobel_5x5_16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_SOBEL_5X5_16S_H_ 1

Define Documentation

#define _IMG_SOBEL_5X5_16S_H_ 1

Definition at line 40 of file IMG_sobel_5x5_16s.h.


IMGLIB: IMG_sobel_5x5_16s.h File Reference

IMG_sobel_5x5_16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_SOBEL_5X5_16S_H_ 1

Functions

void | IMG_sobel_5x5_16s (const short *restrict in, short *restrict out, short cols, short rows)

Define Documentation

#define IMG_SOBEL_5X5_16S_H_ 1

Definition at line 38 of file c64P/IMG_sobel_5x5_16s.h.


IMGLIB: IMG_sobel_7x7_16s.h File Reference

IMG_sobel_7x7_16s.h File Reference

Go to the source code of this file.

Defines

#define _IMG_SOBEL_7X7_16S_H_ 1

Define Documentation

#define _IMG_SOBEL_7X7_16S_H_ 1

Definition at line 40 of file IMG_sobel_7x7_16s.h.


IMGLIB: IMG_sobel_7x7_16s.h File Reference

IMG_sobel_7x7_16s.h File Reference

Go to the source code of this file.

Defines

#define | IMG_SOBEL_7x7_16s_H_ 1

Functions

void | IMG_sobel_7x7_16s (const short *restrict in, short *restrict out, short cols, short rows)

Define Documentation

#define IMG_SOBEL_7x7_16s_H_ 1

Definition at line 38 of file c64P/IMG_sobel_7x7_16s.h.


IMGLIB: IMG_thr_gt2max_16.h File Reference

IMG_thr_gt2max_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_THR_GT2MAX_16_H_ 1

Define Documentation

#define _IMG_THR_GT2MAX_16_H_ 1

Definition at line 40 of file IMG_thr_gt2max_16.h.


IMGLIB: IMG_thr_gt2max_16.h File Reference

IMG_thr_gt2max_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_THR_GT2MAX_16_H_ 1

Functions

void | IMG_thr_gt2max_16 (const unsigned short *restrict in_data, unsigned short *restrict out_data, short cols, short rows, unsigned short threshold)

Define Documentation

#define IMG_THR_GT2MAX_16_H_ 1

Definition at line 38 of file c64P/IMG_thr_gt2max_16.h.


IMGLIB: IMG_thr_gt2max_8.h File Reference

IMG_thr_gt2max_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_THR_GT2MAX_8_H_ 1

Define Documentation

#define _IMG_THR_GT2MAX_8_H_ 1

Definition at line 40 of file IMG_thr_gt2max_8.h.


IMGLIB: IMG_thr_gt2max_8.h File Reference

IMG_thr_gt2max_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_THR_GT2MAX_8_H_ 1

Functions

void | IMG_thr_gt2max_8 (const unsigned char *in_data, unsigned char *restrict out_data, short cols, short rows, unsigned char threshold)

Define Documentation

#define IMG_THR_GT2MAX_8_H_ 1

Definition at line 38 of file c64P/IMG_thr_gt2max_8.h.


IMGLIB: IMG_thr_gt2thr_16.h File Reference

IMG_thr_gt2thr_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_THR_GT2THR_16_H_ 1

Define Documentation

#define _IMG_THR_GT2THR_16_H_ 1

Definition at line 40 of file IMG_thr_gt2thr_16.h.


IMGLIB: IMG_thr_gt2thr_16.h File Reference

IMG_thr_gt2thr_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_THR_GT2THR_16_H_ 1

Functions

void | IMG_thr_gt2thr_16 (const unsigned short *in_data, unsigned short *restrict out_data, short cols, short rows, unsigned short threshold)

Define Documentation

#define IMG_THR_GT2THR_16_H_ 1

Definition at line 38 of file c64P/IMG_thr_gt2thr_16.h.


IMGLIB: IMG_thr_gt2thr_8.h File Reference

IMG_thr_gt2thr_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_THR_GT2THR_8_H_ 1

Define Documentation

#define _IMG_THR_GT2THR_8_H_ 1

Definition at line 40 of file IMG_thr_gt2thr_8.h.


IMGLIB: IMG_thr_gt2thr_8.h File Reference

IMG_thr_gt2thr_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_THR_GT2THR_8_H_ 1

Functions

void | IMG_thr_gt2thr_8 (const unsigned char *in_data, unsigned char *restrict out_data, short cols, short rows, unsigned char threshold)

Define Documentation

#define IMG_THR_GT2THR_8_H_ 1

Definition at line 38 of file c64P/IMG_thr_gt2thr_8.h.


IMGLIB: IMG_thr_le2min_16.h File Reference

IMG_thr_le2min_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_THR_LE2MIN_16_H_ 1

Define Documentation

#define _IMG_THR_LE2MIN_16_H_ 1

Definition at line 40 of file IMG_thr_le2min_16.h.


IMGLIB: IMG_thr_le2min_16.h File Reference

IMG_thr_le2min_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_THR_LE2MIN_16_H_ 1

Functions

void | IMG_thr_le2min_16 (const unsigned short *restrict in_data, unsigned short *restrict out_data, short cols, short rows, unsigned short threshold)

Define Documentation

#define IMG_THR_LE2MIN_16_H_ 1

Definition at line 38 of file c64P/IMG_thr_le2min_16.h.


IMGLIB: IMG_thr_le2min_8.h File Reference

IMG_thr_le2min_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_THR_LE2MIN_8_H_ 1

Define Documentation

#define _IMG_THR_LE2MIN_8_H_ 1

Definition at line 40 of file IMG_thr_le2min_8.h.


IMGLIB: IMG_thr_le2min_8.h File Reference

IMG_thr_le2min_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_THR_LE2MIN_8_H_ 1

Functions

void | IMG_thr_le2min_8 (const unsigned char *in_data, unsigned char *restrict out_data, short cols, short rows, unsigned char threshold)

Define Documentation

#define IMG_THR_LE2MIN_8_H_ 1

Definition at line 38 of file c64P/IMG_thr_le2min_8.h.


IMGLIB: IMG_thr_le2thr_16.h File Reference

IMG_thr_le2thr_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_THR_LE2THR_16_H_ 1

Define Documentation

#define _IMG_THR_LE2THR_16_H_ 1

Definition at line 40 of file IMG_thr_le2thr_16.h.


IMGLIB: IMG_thr_le2thr_16.h File Reference

IMG_thr_le2thr_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_THR_LE2THR_16_H_ 1

Functions

void | IMG_thr_le2thr_16 (const unsigned short *in_data, unsigned short *restrict out_data, short cols, short rows, unsigned short threshold)

Define Documentation

#define IMG_THR_LE2THR_16_H_ 1

Definition at line 38 of file c64P/IMG_thr_le2thr_16.h.


IMGLIB: IMG_thr_le2thr_8.h File Reference

IMG_thr_le2thr_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_THR_LE2THR_8_H_ 1

Define Documentation

#define _IMG_THR_LE2THR_8_H_ 1

Definition at line 40 of file IMG_thr_le2thr_8.h.


IMGLIB: IMG_thr_le2thr_8.h File Reference

IMG_thr_le2thr_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_THR_LE2THR_8_H_ 1

Functions

void | IMG_thr_le2thr_8 (const unsigned char *in_data, unsigned char *restrict out_data, short cols, short rows, unsigned char threshold)

Define Documentation

#define IMG_THR_LE2THR_8_H_ 1

Definition at line 38 of file c64P/IMG_thr_le2thr_8.h.


IMGLIB: IMG_wave_horz.h File Reference

IMG_wave_horz.h File Reference

Go to the source code of this file.

Defines

#define _IMG_WAVE_HORZ_H_ 1

Define Documentation

#define _IMG_WAVE_HORZ_H_ 1

Definition at line 40 of file IMG_wave_horz.h.


IMGLIB: IMG_wave_horz.h File Reference

IMG_wave_horz.h File Reference

Go to the source code of this file.

Defines

#define | IMG_WAVE_HORZ_H_ 1

Functions

void | IMG_wave_horz (short *iptr, short *qmf, short *filter, short *optr, int ish_x_dim)

Define Documentation

#define IMG_WAVE_HORZ_H_ 1

Definition at line 38 of file c64P/IMG_wave_horz.h.


IMGLIB: IMG_wave_vert.h File Reference

IMG_wave_vert.h File Reference

Go to the source code of this file.

Defines

#define _IMG_WAVE_VERT_H_ 1

Define Documentation

#define _IMG_WAVE_VERT_H_ 1

Definition at line 40 of file IMG_wave_vert.h.


IMGLIB: IMG_wave_vert.h File Reference

IMG_wave_vert.h File Reference

Go to the source code of this file.

Defines

#define | IMG_WAVE_VERT_H_ 1

Functions

void | IMG_wave_vert (const short *restrict *restrict in_data, const short *restrict qmf, const short *restrict mqmf, short *restrict out_ldata, short *restrict out_hdata, int cols)

Define Documentation

#define IMG_WAVE_VERT_H_ 1

Definition at line 38 of file c64P/IMG_wave_vert.h.


IMGLIB: IMG_yc_demux_be16_16.h File Reference

IMG_yc_demux_be16_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_YC_DEMUX_BE16_16_H_ 1

Define Documentation

#define _IMG_YC_DEMUX_BE16_16_H_ 1

Definition at line 40 of file IMG_yc_demux_be16_16.h.


IMGLIB: IMG_yc_demux_be16_16.h File Reference

IMG_yc_demux_be16_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_WAVE_HORZ_H_ 1

Functions

void | IMG_yc_demux_be16_16 (int n, const unsigned short *yc, short *restrict y, short *restrict cr, short *restrict cb)

Define Documentation

#define IMG_WAVE_HORZ_H_ 1

Definition at line 38 of file c64P/IMG_yc_demux_be16_16.h.


IMGLIB: IMG_yc_demux_be16_8.h File Reference

IMG_yc_demux_be16_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_YC_DEMUX_BE16_8_H_ 1

Define Documentation

#define _IMG_YC_DEMUX_BE16_8_H_ 1

Definition at line 40 of file IMG_yc_demux_be16_8.h.


IMGLIB: IMG_yc_demux_be16_8.h File Reference

IMG_yc_demux_be16_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_YC_DEMUX_BE16_8_H_ 1

Functions

void | IMG_yc_demux_be16_8 (int n, const unsigned char *restrict yc, short *restrict y, short *restrict cr, short *restrict cb)

Define Documentation

#define IMG_YC_DEMUX_BE16_8_H_ 1

Definition at line 38 of file c64P/IMG_yc_demux_be16_8.h.


IMGLIB: IMG_yc_demux_le16_16.h File Reference

IMG_yc_demux_le16_16.h File Reference

Go to the source code of this file.

Defines

#define _IMG_YC_DEMUX_LE16_16_H_ 1

Define Documentation

#define _IMG_YC_DEMUX_LE16_16_H_ 1

Definition at line 40 of file IMG_yc_demux_le16_16.h.


IMGLIB: IMG_yc_demux_le16_16.h File Reference

IMG_yc_demux_le16_16.h File Reference

Go to the source code of this file.

Defines

#define | IMG_YC_DEMUX_LE16_16_H_ 1

Functions

void | IMG_yc_demux_le16_16 (int n, const unsigned short *yc, short *restrict y, short *restrict cr, short *restrict cb)

Define Documentation

#define IMG_YC_DEMUX_LE16_16_H_ 1

Definition at line 38 of file c64P/IMG_yc_demux_le16_16.h.


IMGLIB: IMG_yc_demux_le16_8.h File Reference

IMG_yc_demux_le16_8.h File Reference

Go to the source code of this file.

Defines

#define _IMG_YC_DEMUX_LE16_8_H_ 1

Define Documentation

#define _IMG_YC_DEMUX_LE16_8_H_ 1

Definition at line 40 of file IMG_yc_demux_le16_8.h.


IMGLIB: IMG_yc_demux_le16_8.h File Reference

IMG_yc_demux_le16_8.h File Reference

Go to the source code of this file.

Defines

#define | IMG_YC_DEMUX_LE16_8_H_ 1

Functions

void | IMG_yc_demux_le16_8 (int n, const unsigned char *restrict yc, short *restrict y, short *restrict cr, short *restrict cb)

Define Documentation

#define IMG_YC_DEMUX_LE16_8_H_ 1

Definition at line 38 of file c64P/IMG_yc_demux_le16_8.h.


IMGLIB: IMG_ycbcr422pl_to_rgb565.h File Reference

IMG_ycbcr422pl_to_rgb565.h File Reference

Go to the source code of this file.

Defines

#define _IMG_YCBCR422PL_TO_RGB565_H_ 1

Define Documentation

#define _IMG_YCBCR422PL_TO_RGB565_H_ 1

Definition at line 40 of file IMG_ycbcr422pl_to_rgb565.h.


IMGLIB: IMG_ycbcr422pl_to_rgb565.h File Reference

IMG_ycbcr422pl_to_rgb565.h File Reference

Go to the source code of this file.

Defines

#define | IMG_YCBCR422PL_TO_RGB565_H_ 1

Functions

void | IMG_ycbcr422pl_to_rgb565 (const short coeff[5], const unsigned char *restrict y_data, const unsigned char *restrict cb_data, const unsigned char *restrict cr_data, unsigned short *restrict rgb_data, unsigned num_pixels)

Define Documentation

#define IMG_YCBCR422PL_TO_RGB565_H_ 1

Definition at line 38 of file c64P/IMG_ycbcr422pl_to_rgb565.h.


IMGLIB: Data Fields

  • All
  • Functions
  • Defines
  • _
  • i

Here is a list of all functions, variables, defines, enums, and typedefs with links to the files they belong to:

- _ -

  • _IMG_BOUNDARY_16S_H_ : IMG_boundary_16s.h
  • _IMG_BOUNDARY_8_H_ : IMG_boundary_8.h
  • _IMG_CLIPPING_16S_H_ : IMG_clipping_16s.h
  • _IMG_CONV_11X11_I16S_C16S_H_ : IMG_conv_11x11_i16s_c16s.h
  • _IMG_CONV_11X11_I8_C8S_H_ : IMG_conv_11x11_i8_c8s.h
  • _IMG_CONV_3X3_I16_C16S_H_ : IMG_conv_3x3_i16_c16s.h
  • _IMG_CONV_3X3_I16S_C16S_H_ : IMG_conv_3x3_i16s_c16s.h
  • _IMG_CONV_3X3_I8_C8S_H_ : IMG_conv_3x3_i8_c8s.h
  • _IMG_CONV_5X5_I16S_C16S_H_ : IMG_conv_5x5_i16s_c16s.h
  • _IMG_CONV_5X5_I8_C16S_H_ : IMG_conv_5x5_i8_c16s.h
  • _IMG_CONV_5X5_I8_C8S_H_ : IMG_conv_5x5_i8_c8s.h
  • _IMG_CONV_7X7_I16S_C16S_H_ : IMG_conv_7x7_i16s_c16s.h
  • _IMG_CONV_7X7_I8_C16S_H_ : IMG_conv_7x7_i8_c16s.h
  • _IMG_CONV_7X7_I8_C8S_H_ : IMG_conv_7x7_i8_c8s.h
  • _IMG_CORR_11X11_I16S_C16S_H_ : IMG_corr_11x11_i16s_c16s.h
  • _IMG_CORR_11X11_I8_C16S_H_ : IMG_corr_11x11_i8_c16s.h
  • _IMG_CORR_3X3_I16_C16_H_ : IMG_corr_3x3_i16_c16.h
  • _IMG_CORR_3X3_I16S_C16S_H_ : IMG_corr_3x3_i16s_c16s.h
  • _IMG_CORR_3X3_I8_C16S_H_ : IMG_corr_3x3_i8_c16s.h
  • _IMG_CORR_3X3_I8_C8_H_ : IMG_corr_3x3_i8_c8.h
  • _IMG_CORR_5X5_I16S_C16S_H_ : IMG_corr_5x5_i16s_c16s.h
  • _IMG_CORR_GEN_I16S_C16S_H_ : IMG_corr_gen_i16s_c16s.h
  • _IMG_CORR_GEN_IQ_H_ : IMG_corr_gen_iq.h
  • _IMG_DILATE_BIN_H_ : IMG_dilate_bin.h
  • _IMG_ERODE_BIN_H_ : IMG_erode_bin.h
  • _IMG_ERRDIF_BIN_16_H_ : IMG_errdif_bin_16.h
  • _IMG_ERRDIF_BIN_8_H_ : IMG_errdif_bin_8.h
  • _IMG_FDCT_8X8_H_ : IMG_fdct_8x8.h
  • _IMG_HISTOGRAM_16_H_ : IMG_histogram_16.h
  • _IMG_HISTOGRAM_8_H_ : IMG_histogram_8.h
  • _IMG_IDCT_8X8_12Q4_H_ : IMG_idct_8x8_12q4.h
  • _IMG_MAD_16X16_H_ : IMG_mad_16x16.h
  • _IMG_MAD_8X8_H_ : IMG_mad_8x8.h
  • _IMG_MEDIAN_3X3_16_H_ : IMG_median_3x3_16.h
  • _IMG_MEDIAN_3X3_16S_H_ : IMG_median_3x3_16s.h
  • _IMG_MEDIAN_3X3_8_H_ : IMG_median_3x3_8.h
  • _IMG_PERIMETER_16_H_ : IMG_perimeter_16.h
  • _IMG_PERIMETER_8_H_ : IMG_perimeter_8.h
  • _IMG_PIX_EXPAND_H_ : IMG_pix_expand.h
  • _IMG_PIX_SAT_H_ : IMG_pix_sat.h
  • _IMG_QUANTIZE_H_ : IMG_quantize.h
  • _IMG_SAD_16X16_H_ : IMG_sad_16x16.h
  • _IMG_SAD_8X8_H_ : IMG_sad_8x8.h
  • _IMG_SOBEL_3X3_16_H_ : IMG_sobel_3x3_16.h
  • _IMG_SOBEL_3X3_16S_H_ : IMG_sobel_3x3_16s.h
  • _IMG_SOBEL_3X3_8_H_ : IMG_sobel_3x3_8.h
  • _IMG_SOBEL_5X5_16S_H_ : IMG_sobel_5x5_16s.h
  • _IMG_SOBEL_7X7_16S_H_ : IMG_sobel_7x7_16s.h
  • _IMG_THR_GT2MAX_16_H_ : IMG_thr_gt2max_16.h
  • _IMG_THR_GT2MAX_8_H_ : IMG_thr_gt2max_8.h
  • _IMG_THR_GT2THR_16_H_ : IMG_thr_gt2thr_16.h
  • _IMG_THR_GT2THR_8_H_ : IMG_thr_gt2thr_8.h
  • _IMG_THR_LE2MIN_16_H_ : IMG_thr_le2min_16.h
  • _IMG_THR_LE2MIN_8_H_ : IMG_thr_le2min_8.h
  • _IMG_THR_LE2THR_16_H_ : IMG_thr_le2thr_16.h
  • _IMG_THR_LE2THR_8_H_ : IMG_thr_le2thr_8.h
  • _IMG_WAVE_HORZ_H_ : IMG_wave_horz.h
  • _IMG_WAVE_VERT_H_ : IMG_wave_vert.h
  • _IMG_YC_DEMUX_BE16_16_H_ : IMG_yc_demux_be16_16.h
  • _IMG_YC_DEMUX_BE16_8_H_ : IMG_yc_demux_be16_8.h
  • _IMG_YC_DEMUX_LE16_16_H_ : IMG_yc_demux_le16_16.h
  • _IMG_YC_DEMUX_LE16_8_H_ : IMG_yc_demux_le16_8.h
  • _IMG_YCBCR422PL_TO_RGB565_H_ : IMG_ycbcr422pl_to_rgb565.h

- i -

  • IMG_boundary_16s() : c64P/IMG_boundary_16s.h
  • IMG_BOUNDARY_16S_H_ : c64P/IMG_boundary_16s.h
  • IMG_boundary_8() : c64P/IMG_boundary_8.h
  • IMG_BOUNDARY_8_H_ : c64P/IMG_boundary_8.h
  • IMG_clipping_16s() : c64P/IMG_clipping_16s.h
  • IMG_CLIPPING_16S_H_ : c64P/IMG_clipping_16s.h
  • IMG_conv_11x11_i16s_c16s() : c64P/IMG_conv_11x11_i16s_c16s.h
  • IMG_CONV_11X11_I16S_C16S_H_ : c64P/IMG_conv_11x11_i16s_c16s.h
  • IMG_conv_11x11_i8_c8s() : c64P/IMG_conv_11x11_i8_c8s.h
  • IMG_CONV_11X11_I8_C8S_H_ : c64P/IMG_conv_11x11_i8_c8s.h
  • IMG_conv_3x3_i16_c16s() : c64P/IMG_conv_3x3_i16_c16s.h
  • IMG_CONV_3X3_I16_C16S_H_ : c64P/IMG_conv_3x3_i16_c16s.h
  • IMG_conv_3x3_i16s_c16s() : c64P/IMG_conv_3x3_i16s_c16s.h
  • IMG_CONV_3X3_I16S_C16S_H_ : c64P/IMG_conv_3x3_i16s_c16s.h
  • IMG_conv_3x3_i8_c8s() : c64P/IMG_conv_3x3_i8_c8s.h
  • IMG_CONV_3X3_I8_C8S_H_ : c64P/IMG_conv_3x3_i8_c8s.h
  • IMG_conv_5x5_i16s_c16s() : c64P/IMG_conv_5x5_i16s_c16s.h
  • IMG_CONV_5X5_I16S_C16S_H_ : c64P/IMG_conv_5x5_i16s_c16s.h
  • IMG_conv_5x5_i8_c16s() : c64P/IMG_conv_5x5_i8_c16s.h
  • IMG_CONV_5X5_I8_C16S_H_ : c64P/IMG_conv_5x5_i8_c16s.h
  • IMG_conv_5x5_i8_c8s() : c64P/IMG_conv_5x5_i8_c8s.h
  • IMG_CONV_5X5_I8_C8S_H_ : c64P/IMG_conv_5x5_i8_c8s.h
  • IMG_conv_7x7_i16s_c16s() : c64P/IMG_conv_7x7_i16s_c16s.h
  • IMG_CONV_7X7_I16S_C16S_H_ : c64P/IMG_conv_7x7_i16s_c16s.h
  • IMG_conv_7x7_i8_c16s() : c64P/IMG_conv_7x7_i8_c16s.h
  • IMG_CONV_7X7_I8_C16S_H_ : c64P/IMG_conv_7x7_i8_c16s.h
  • IMG_conv_7x7_i8_c8s() : c64P/IMG_conv_7x7_i8_c8s.h
  • IMG_CONV_7X7_I8_C8S_H_ : c64P/IMG_conv_7x7_i8_c8s.h
  • IMG_corr_11x11_i16s_c16s() : c64P/IMG_corr_11x11_i16s_c16s.h
  • IMG_CORR_11X11_I16S_C16S_H_ : c64P/IMG_corr_11x11_i16s_c16s.h
  • IMG_corr_11x11_i8_c16s() : c64P/IMG_corr_11x11_i8_c16s.h
  • IMG_CORR_11X11_I8_C16S_H_ : c64P/IMG_corr_11x11_i8_c16s.h
  • IMG_corr_3x3_i16_c16() : c64P/IMG_corr_3x3_i16_c16.h
  • IMG_CORR_3X3_I16_C16_H_ : c64P/IMG_corr_3x3_i16_c16.h
  • IMG_corr_3x3_i16s_c16s() : c64P/IMG_corr_3x3_i16s_c16s.h
  • IMG_CORR_3X3_I16S_C16S_H_ : c64P/IMG_corr_3x3_i16s_c16s.h
  • IMG_corr_3x3_i8_c16s() : c64P/IMG_corr_3x3_i8_c16s.h
  • IMG_CORR_3X3_I8_C16S_H_ : c64P/IMG_corr_3x3_i8_c16s.h
  • IMG_corr_3x3_i8_c8() : c64P/IMG_corr_3x3_i8_c8.h
  • IMG_CORR_3X3_I8_C8_H_ : c64P/IMG_corr_3x3_i8_c8.h
  • IMG_corr_5x5_i16s_c16s() : c64P/IMG_corr_5x5_i16s_c16s.h
  • IMG_CORR_5X5_I16S_C16S_H_ : c64P/IMG_corr_5x5_i16s_c16s.h
  • IMG_corr_gen_i16s_c16s() : c64P/IMG_corr_gen_i16s_c16s.h
  • IMG_CORR_GEN_I16S_C16S_H_ : c64P/IMG_corr_gen_i16s_c16s.h
  • IMG_corr_gen_iq() : c64P/IMG_corr_gen_iq.h
  • IMG_CORR_GEN_IQ_H_ : c64P/IMG_corr_gen_iq.h
  • IMG_dilate_bin() : c64P/IMG_dilate_bin.h
  • IMG_DILATE_BIN_H_ : c64P/IMG_dilate_bin.h
  • IMG_erode_bin() : c64P/IMG_erode_bin.h
  • IMG_ERODE_BIN_H_ : c64P/IMG_erode_bin.h
  • IMG_errdif_bin_16() : c64P/IMG_errdif_bin_16.h
  • IMG_ERRDIF_BIN_16_H_ : c64P/IMG_errdif_bin_16.h
  • IMG_errdif_bin_8() : c64P/IMG_errdif_bin_8.h
  • IMG_ERRDIF_BIN_8_H_ : c64P/IMG_errdif_bin_8.h
  • IMG_fdct_8x8() : c64P/IMG_fdct_8x8.h
  • IMG_FDCT_8X8_H_ : c64P/IMG_fdct_8x8.h
  • IMG_histogram_16() : c64P/IMG_histogram_16.h
  • IMG_HISTOGRAM_16_H_ : c64P/IMG_histogram_16.h
  • IMG_histogram_8() : c64P/IMG_histogram_8.h
  • IMG_HISTOGRAM_8_H_ : c64P/IMG_histogram_8.h
  • IMG_idct_8x8_12q4() : c64P/IMG_idct_8x8_12q4.h
  • IMG_IDCT_8X8_12Q4_H_ : c64P/IMG_idct_8x8_12q4.h
  • IMG_mad_16x16() : c64P/IMG_mad_16x16.h
  • IMG_MAD_16X16_H_ : c64P/IMG_mad_16x16.h
  • IMG_mad_8x8() : c64P/IMG_mad_8x8.h
  • IMG_MAD_8X8_H_ : c64P/IMG_mad_8x8.h
  • IMG_median_3x3_16() : c64P/IMG_median_3x3_16.h
  • IMG_MEDIAN_3X3_16_H_ : c64P/IMG_median_3x3_16.h
  • IMG_median_3x3_16s() : c64P/IMG_median_3x3_16s.h
  • IMG_MEDIAN_3X3_16S_H_ : c64P/IMG_median_3x3_16s.h
  • IMG_median_3x3_8() : c64P/IMG_median_3x3_8.h
  • IMG_MEDIAN_3X3_8_H_ : c64P/IMG_median_3x3_8.h
  • IMG_perimeter_16() : c64P/IMG_perimeter_16.h
  • IMG_PERIMETER_16_H_ : c64P/IMG_perimeter_16.h
  • IMG_perimeter_8() : c64P/IMG_perimeter_8.h
  • IMG_PERIMETER_8_H_ : c64P/IMG_perimeter_8.h
  • IMG_pix_expand() : c64P/IMG_pix_expand.h
  • IMG_PIX_EXPAND_H_ : c64P/IMG_pix_expand.h
  • IMG_pix_sat() : c64P/IMG_pix_sat.h
  • IMG_PIX_SAT_H_ : c64P/IMG_pix_sat.h
  • IMG_quantize() : c64P/IMG_quantize.h
  • IMG_QUANTIZE_H_ : c64P/IMG_quantize.h
  • IMG_sad_16x16() : c64P/IMG_sad_16x16.h
  • IMG_SAD_16X16_H_ : c64P/IMG_sad_16x16.h
  • IMG_sad_8x8() : c64P/IMG_sad_8x8.h
  • IMG_SAD_8X8_H_ : c64P/IMG_sad_8x8.h
  • IMG_sobel_3x3_16() : c64P/IMG_sobel_3x3_16.h
  • IMG_SOBEL_3X3_16_H_ : c64P/IMG_sobel_3x3_16.h
  • IMG_sobel_3x3_16s() : c64P/IMG_sobel_3x3_16s.h
  • IMG_SOBEL_3X3_16S_H_ : c64P/IMG_sobel_3x3_16s.h
  • IMG_sobel_3x3_8() : c64P/IMG_sobel_3x3_8.h
  • IMG_SOBEL_3x3_8_H_ : c64P/IMG_sobel_3x3_8.h
  • IMG_sobel_5x5_16s() : c64P/IMG_sobel_5x5_16s.h
  • IMG_SOBEL_5X5_16S_H_ : c64P/IMG_sobel_5x5_16s.h
  • IMG_sobel_7x7_16s() : c64P/IMG_sobel_7x7_16s.h
  • IMG_SOBEL_7x7_16s_H_ : c64P/IMG_sobel_7x7_16s.h
  • IMG_thr_gt2max_16() : c64P/IMG_thr_gt2max_16.h
  • IMG_THR_GT2MAX_16_H_ : c64P/IMG_thr_gt2max_16.h
  • IMG_thr_gt2max_8() : c64P/IMG_thr_gt2max_8.h
  • IMG_THR_GT2MAX_8_H_ : c64P/IMG_thr_gt2max_8.h
  • IMG_thr_gt2thr_16() : c64P/IMG_thr_gt2thr_16.h
  • IMG_THR_GT2THR_16_H_ : c64P/IMG_thr_gt2thr_16.h
  • IMG_thr_gt2thr_8() : c64P/IMG_thr_gt2thr_8.h
  • IMG_THR_GT2THR_8_H_ : c64P/IMG_thr_gt2thr_8.h
  • IMG_thr_le2min_16() : c64P/IMG_thr_le2min_16.h
  • IMG_THR_LE2MIN_16_H_ : c64P/IMG_thr_le2min_16.h
  • IMG_thr_le2min_8() : c64P/IMG_thr_le2min_8.h
  • IMG_THR_LE2MIN_8_H_ : c64P/IMG_thr_le2min_8.h
  • IMG_thr_le2thr_16() : c64P/IMG_thr_le2thr_16.h
  • IMG_THR_LE2THR_16_H_ : c64P/IMG_thr_le2thr_16.h
  • IMG_thr_le2thr_8() : c64P/IMG_thr_le2thr_8.h
  • IMG_THR_LE2THR_8_H_ : c64P/IMG_thr_le2thr_8.h
  • IMG_wave_horz() : c64P/IMG_wave_horz.h
  • IMG_WAVE_HORZ_H_ : c64P/IMG_wave_horz.h , c64P/IMG_yc_demux_be16_16.h
  • IMG_wave_vert() : c64P/IMG_wave_vert.h
  • IMG_WAVE_VERT_H_ : c64P/IMG_wave_vert.h
  • IMG_yc_demux_be16_16() : c64P/IMG_yc_demux_be16_16.h
  • IMG_yc_demux_be16_8() : c64P/IMG_yc_demux_be16_8.h
  • IMG_YC_DEMUX_BE16_8_H_ : c64P/IMG_yc_demux_be16_8.h
  • IMG_yc_demux_le16_16() : c64P/IMG_yc_demux_le16_16.h
  • IMG_YC_DEMUX_LE16_16_H_ : c64P/IMG_yc_demux_le16_16.h
  • IMG_yc_demux_le16_8() : c64P/IMG_yc_demux_le16_8.h
  • IMG_YC_DEMUX_LE16_8_H_ : c64P/IMG_yc_demux_le16_8.h
  • IMG_ycbcr422pl_to_rgb565() : c64P/IMG_ycbcr422pl_to_rgb565.h
  • IMG_YCBCR422PL_TO_RGB565_H_ : c64P/IMG_ycbcr422pl_to_rgb565.h


IMGLIB: IMG_boundary_8.h Source File

IMG_boundary_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_boundary_8.h -- Optimized C source interface header file            *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_BOUNDARY_8_H_
00040 #define _IMG_BOUNDARY_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_boundary_8/c66/IMG_boundary_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_boundary_8/c64P/IMG_boundary_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_BOUNDARY_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_boundary_8.h                                          */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_boundary_16s.h Source File

IMG_boundary_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_boundary_16s.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_BOUNDARY_16S_H_
00040 #define _IMG_BOUNDARY_16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_boundary_16s/c66/IMG_boundary_16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_boundary_16s/c64P/IMG_boundary_16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_BOUNDARY_16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_boundary_16s.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_clipping_16s.h Source File

IMG_clipping_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_clipping_16s.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CLIPPING_16S_H_
00040 #define _IMG_CLIPPING_16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_clipping_16s/c66/IMG_clipping_16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_clipping_16s/c64P/IMG_clipping_16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CLIPPING_16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_clipping_16s.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_3x3_i8_c8s.h Source File

IMG_conv_3x3_i8_c8s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_3x3_i8_c8s.h -- Optimized C source interface header file       *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_3X3_I8_C8S_H_
00040 #define _IMG_CONV_3X3_I8_C8S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_3x3_i8_c8s/c66/IMG_conv_3x3_i8_c8s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_3x3_i8_c8s/c64P/IMG_conv_3x3_i8_c8s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_3X3_I8_C8S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_3x3_i8_c8s.h                                     */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_3x3_i16_c16s.h Source File

IMG_conv_3x3_i16_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_3x3_i16_c16s.h -- Optimized C source interface header file     *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_3X3_I16_C16S_H_
00040 #define _IMG_CONV_3X3_I16_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_3x3_i16_c16s/c66/IMG_conv_3x3_i16_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_3x3_i16_c16s/c64P/IMG_conv_3x3_i16_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_3X3_I16_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_3x3_i16_c16s.h                                   */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_3x3_i16s_c16s.h Source File

IMG_conv_3x3_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_3x3_i16s_c16s.h -- Optimized C source interface header file    *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_3X3_I16S_C16S_H_
00040 #define _IMG_CONV_3X3_I16S_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_3x3_i16s_c16s/c66/IMG_conv_3x3_i16s_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_3x3_i16s_c16s/c64P/IMG_conv_3x3_i16s_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_3X3_I16S_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_3x3_i16s_c16s.h                                  */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_5x5_i8_c8s.h Source File

IMG_conv_5x5_i8_c8s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_5x5_i8_c8s.h -- Optimized C source interface header file       *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_5X5_I8_C8S_H_
00040 #define _IMG_CONV_5X5_I8_C8S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_5x5_i8_c8s/c66/IMG_conv_5x5_i8_c8s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_5x5_i8_c8s/c64P/IMG_conv_5x5_i8_c8s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_5X5_I8_C8S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_5x5_i8_c8s.h                                     */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_5x5_i8_c16s.h Source File

IMG_conv_5x5_i8_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_5x5_i8_c16s.h -- Optimized C source interface header file      *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_5X5_I8_C16S_H_
00040 #define _IMG_CONV_5X5_I8_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_5x5_i8_c16s/c66/IMG_conv_5x5_i8_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_5x5_i8_c16s/c64P/IMG_conv_5x5_i8_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_5X5_I8_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_5x5_i8_c16s.h                                    */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_5x5_i16s_c16s.h Source File

IMG_conv_5x5_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_5x5_i16s_c16s.h -- Optimized C source interface header file    *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_5X5_I16S_C16S_H_
00040 #define _IMG_CONV_5X5_I16S_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_5x5_i16s_c16s/c66/IMG_conv_5x5_i16s_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_5x5_i16s_c16s/c64P/IMG_conv_5x5_i16s_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_5X5_I16S_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_5x5_i16s_c16s.h                                  */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_7x7_i8_c8s.h Source File

IMG_conv_7x7_i8_c8s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_7x7_i8_c8s.h -- Optimized C source interface header file       *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_7X7_I8_C8S_H_
00040 #define _IMG_CONV_7X7_I8_C8S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_7x7_i8_c8s/c66/IMG_conv_7x7_i8_c8s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_7x7_i8_c8s/c64P/IMG_conv_7x7_i8_c8s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_7X7_I8_C8S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_7x7_i8_c8s.h                                     */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_7x7_i8_c16s.h Source File

IMG_conv_7x7_i8_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_7x7_i8_c16s.h -- Optimized C source interface header file      *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_7X7_I8_C16S_H_
00040 #define _IMG_CONV_7X7_I8_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_7x7_i8_c16s/c66/IMG_conv_7x7_i8_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_7x7_i8_c16s/c64P/IMG_conv_7x7_i8_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_7X7_I8_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_7x7_i8_c16s.h                                    */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_7x7_i16s_c16s.h Source File

IMG_conv_7x7_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_7x7_i16s_c16s.h -- Optimized C source interface header file    *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_7X7_I16S_C16S_H_
00040 #define _IMG_CONV_7X7_I16S_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_7x7_i16s_c16s/c66/IMG_conv_7x7_i16s_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_7x7_i16s_c16s/c64P/IMG_conv_7x7_i16s_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_7X7_I16S_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_7x7_i16s_c16s.h                                  */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_11x11_i8_c8s.h Source File

IMG_conv_11x11_i8_c8s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_11x11_i8_c8s.h -- Optimized C source interface header file     *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_11X11_I8_C8S_H_
00040 #define _IMG_CONV_11X11_I8_C8S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_11x11_i8_c8s/c66/IMG_conv_11x11_i8_c8s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_11x11_i8_c8s/c64P/IMG_conv_11x11_i8_c8s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_11X11_I8_C8S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_11x11_i8_c8s.h                                   */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_conv_11x11_i16s_c16s.h Source File

IMG_conv_11x11_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_conv_11x11_i16s_c16s.h -- Optimized C source interface header file  *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CONV_11X11_I16S_C16S_H_
00040 #define _IMG_CONV_11X11_I16S_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_conv_11x11_i16s_c16s/c66/IMG_conv_11x11_i16s_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_conv_11x11_i16s_c16s/c64P/IMG_conv_11x11_i16s_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CONV_11X11_I16S_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_conv_11x11_i16s_c16s.h                                */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_3x3_i8_c8.h Source File

IMG_corr_3x3_i8_c8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_3x3_i8_c8.h -- Optimized C source interface header file        *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_3X3_I8_C8_H_
00040 #define _IMG_CORR_3X3_I8_C8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_3x3_i8_c8/c66/IMG_corr_3x3_i8_c8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_3x3_i8_c8/c64P/IMG_corr_3x3_i8_c8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_3X3_I8_C8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_3x3_i8_c8.h                                      */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_3x3_i8_c16s.h Source File

IMG_corr_3x3_i8_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_3x3_i8_c16s.h -- Optimized C source interface header file      *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_3X3_I8_C16S_H_
00040 #define _IMG_CORR_3X3_I8_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_3x3_i8_c16s/c66/IMG_corr_3x3_i8_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_3x3_i8_c16s/c64P/IMG_corr_3x3_i8_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_3X3_I8_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_3x3_i8_c16s.h                                    */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_3x3_i16_c16.h Source File

IMG_corr_3x3_i16_c16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_3x3_i16_c16.h -- Optimized C source interface header file      *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_3X3_I16_C16_H_
00040 #define _IMG_CORR_3X3_I16_C16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_3x3_i16_c16/c66/IMG_corr_3x3_i16_c16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_3x3_i16_c16/c64P/IMG_corr_3x3_i16_c16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_3X3_I16_C16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_3x3_i16_c16.h                                    */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_3x3_i16s_c16s.h Source File

IMG_corr_3x3_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_3x3_i16s_c16s.h -- Optimized C source interface header file    *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_3X3_I16S_C16S_H_
00040 #define _IMG_CORR_3X3_I16S_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_3x3_i16s_c16s/c66/IMG_corr_3x3_i16s_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_3x3_i16s_c16s/c64P/IMG_corr_3x3_i16s_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_3X3_I16S_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_3x3_i16s_c16s.h                                  */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_5x5_i16s_c16s.h Source File

IMG_corr_5x5_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_5x5_i16s_c16s.h -- Optimized C source interface header file    *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_5X5_I16S_C16S_H_
00040 #define _IMG_CORR_5X5_I16S_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_5x5_i16s_c16s/c66/IMG_corr_5x5_i16s_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_5x5_i16s_c16s/c64P/IMG_corr_5x5_i16s_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_5X5_I16S_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_5x5_i16s_c16s.h                                  */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_11x11_i8_c16s.h Source File

IMG_corr_11x11_i8_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_11x11_i8_c16s.h -- Optimized C source interface header file    *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_11X11_I8_C16S_H_
00040 #define _IMG_CORR_11X11_I8_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_11x11_i8_c16s/c66/IMG_corr_11x11_i8_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_11x11_i8_c16s/c64P/IMG_corr_11x11_i8_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_11X11_I8_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_11x11_i8_c16s.h                                  */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_11x11_i16s_c16s.h Source File

IMG_corr_11x11_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_11x11_i16s_c16s.h -- Optimized C source interface header file  *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_11X11_I16S_C16S_H_
00040 #define _IMG_CORR_11X11_I16S_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_11x11_i16s_c16s/c66/IMG_corr_11x11_i16s_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_11x11_i16s_c16s/c64P/IMG_corr_11x11_i16s_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_11X11_I16S_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_11x11_i16s_c16s.h                                */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_gen_i16s_c16s.h Source File

IMG_corr_gen_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_gen_i16s_c16s.h -- Optimized C source interface header file    *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_GEN_I16S_C16S_H_
00040 #define _IMG_CORR_GEN_I16S_C16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_gen_i16s_c16s/c66/IMG_corr_gen_i16s_c16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_gen_i16s_c16s/c64P/IMG_corr_gen_i16s_c16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_GEN_I16S_C16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_gen_i16s_c16s.h                                  */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_corr_gen_iq.h Source File

IMG_corr_gen_iq.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_corr_gen_iq.h -- Optimized C source interface header file           *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_CORR_GEN_IQ_H_
00040 #define _IMG_CORR_GEN_IQ_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_corr_gen_iq/c66/IMG_corr_gen_iq.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_corr_gen_iq/c64P/IMG_corr_gen_iq.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_CORR_GEN_IQ_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_corr_gen_iq.h                                         */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_dilate_bin.h Source File

IMG_dilate_bin.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_dilate_bin.h -- Optimized C source interface header file            *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_DILATE_BIN_H_
00040 #define _IMG_DILATE_BIN_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_dilate_bin/c66/IMG_dilate_bin.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_dilate_bin/c64P/IMG_dilate_bin.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_DILATE_BIN_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_dilate_bin.h                                          */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_erode_bin.h Source File

IMG_erode_bin.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_erode_bin.h -- Optimized C source interface header file             *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_ERODE_BIN_H_
00040 #define _IMG_ERODE_BIN_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_erode_bin/c66/IMG_erode_bin.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_erode_bin/c64P/IMG_erode_bin.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_ERODE_BIN_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_erode_bin.h                                           */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_errdif_bin_8.h Source File

IMG_errdif_bin_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_errdir_bin_8.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_ERRDIF_BIN_8_H_
00040 #define _IMG_ERRDIF_BIN_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_errdif_bin_8/c66/IMG_errdif_bin_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_errdif_bin_8/c64P/IMG_errdif_bin_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_ERRDIF_BIN_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_errdif_bin_8.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_errdif_bin_16.h Source File

IMG_errdif_bin_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_errdir_bin_16.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_ERRDIF_BIN_16_H_
00040 #define _IMG_ERRDIF_BIN_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_errdif_bin_16/c66/IMG_errdif_bin_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_errdif_bin_16/c64P/IMG_errdif_bin_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_ERRDIF_BIN_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_errdif_bin_16.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_fdct_8x8.h Source File

IMG_fdct_8x8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_fdct_8x8.h -- Optimized assembly interface header file              *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_FDCT_8X8_H_
00040 #define _IMG_FDCT_8X8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_fdct_8x8/c66/IMG_fdct_8x8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_fdct_8x8/c64P/IMG_fdct_8x8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_FDCT_8X8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_fdct_8x8.h                                            */
00054 /* ======================================================================== */


IMGLIB: IMG_histogram_8.h Source File

IMG_histogram_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_histogram_8.h -- Optimized C source interface header file           *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_HISTOGRAM_8_H_
00040 #define _IMG_HISTOGRAM_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_histogram_8/c66/IMG_histogram_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_histogram_8/c64P/IMG_histogram_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_HISTOGRAM_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_histogram_8.h                                         */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_histogram_16.h Source File

IMG_histogram_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_histogram_16.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_HISTOGRAM_16_H_
00040 #define _IMG_HISTOGRAM_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_histogram_16/c66/IMG_histogram_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_histogram_16/c64P/IMG_histogram_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_HISTOGRAM_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_histogram_16.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_idct_8x8_12q4.h Source File

IMG_idct_8x8_12q4.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_idct_8x8_12q4.h -- Optimized assembly interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_IDCT_8X8_12Q4_H_
00040 #define _IMG_IDCT_8X8_12Q4_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_idct_8x8_12q4/c66/IMG_idct_8x8_12q4.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_idct_8x8_12q4/c64P/IMG_idct_8x8_12q4.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_IDCT_8X8_12Q4_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_idct_8x8_12q4.h                                       */
00054 /* ======================================================================== */


IMGLIB: IMG_mad_8x8.h Source File

IMG_mad_8x8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_mad_8x8.h -- Optimized C source interface header file               *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_MAD_8X8_H_
00040 #define _IMG_MAD_8X8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_mad_8x8/c66/IMG_mad_8x8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_mad_8x8/c64P/IMG_mad_8x8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_MAD_8X8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_mad_8x8.h                                             */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_mad_16x16.h Source File

IMG_mad_16x16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_mad_16x16.h -- Optimized C source interface header file             *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_MAD_16X16_H_
00040 #define _IMG_MAD_16X16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_mad_16x16/c66/IMG_mad_16x16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_mad_16x16/c64P/IMG_mad_16x16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_MAD_16X16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_mad_16x16.h                                           */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_median_3x3_8.h Source File

IMG_median_3x3_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_median_3x3_8.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_MEDIAN_3X3_8_H_
00040 #define _IMG_MEDIAN_3X3_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_median_3x3_8/c66/IMG_median_3x3_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_median_3x3_8/c64P/IMG_median_3x3_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_MEDIAN_3X3_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_median_3x3_8.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_median_3x3_16.h Source File

IMG_median_3x3_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_median_3x3_16.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_MEDIAN_3X3_16_H_
00040 #define _IMG_MEDIAN_3X3_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_median_3x3_16/c66/IMG_median_3x3_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_median_3x3_16/c64P/IMG_median_3x3_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_MEDIAN_3X3_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_median_3x3_16.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_median_3x3_16s.h Source File

IMG_median_3x3_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_median_3x3_16s.h -- Optimized C source interface header file        *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_MEDIAN_3X3_16S_H_
00040 #define _IMG_MEDIAN_3X3_16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_median_3x3_16s/c66/IMG_median_3x3_16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_median_3x3_16s/c64P/IMG_median_3x3_16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_MEDIAN_3X3_16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_median_3x3_16s.h                                      */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_perimeter_8.h Source File

IMG_perimeter_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_perimeter_8.h -- Optimized C source interface header file           *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_PERIMETER_8_H_
00040 #define _IMG_PERIMETER_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_perimeter_8/c66/IMG_perimeter_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_perimeter_8/c64P/IMG_perimeter_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_PERIMETER_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_perimeter_8.h                                         */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_perimeter_16.h Source File

IMG_perimeter_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_perimeter_16.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_PERIMETER_16_H_
00040 #define _IMG_PERIMETER_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_perimeter_16/c66/IMG_perimeter_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_perimeter_16/c64P/IMG_perimeter_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_PERIMETER_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_perimeter_16.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_pix_expand.h Source File

IMG_pix_expand.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_pix_expand.h -- Optimized C source interface header file            *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_PIX_EXPAND_H_
00040 #define _IMG_PIX_EXPAND_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_pix_expand/c66/IMG_pix_expand.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_pix_expand/c64P/IMG_pix_expand.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_PIX_EXPAND_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_pix_expand.h                                          */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_pix_sat.h Source File

IMG_pix_sat.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_pix_sat.h -- Optimized C source interface header file               *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_PIX_SAT_H_
00040 #define _IMG_PIX_SAT_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_pix_sat/c66/IMG_pix_sat.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_pix_sat/c64P/IMG_pix_sat.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_PIX_SAT_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_pix_sat.h                                             */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_quantize.h Source File

IMG_quantize.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_quantize.h -- Optimized C source interface header file              *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_QUANTIZE_H_
00040 #define _IMG_QUANTIZE_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_quantize/c66/IMG_quantize.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_quantize/c64P/IMG_quantize.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_QUANTIZE_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_quantize.h                                            */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_sad_8x8.h Source File

IMG_sad_8x8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_sad_8x8.h -- Optimized C source interface header file               *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_SAD_8X8_H_
00040 #define _IMG_SAD_8X8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_sad_8x8/c66/IMG_sad_8x8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_sad_8x8/c64P/IMG_sad_8x8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_SAD_8X8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_sad_8x8.h                                             */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_sad_16x16.h Source File

IMG_sad_16x16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_sad_16x16.h -- Optimized C source interface header file             *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_SAD_16X16_H_
00040 #define _IMG_SAD_16X16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_sad_16x16/c66/IMG_sad_16x16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_sad_16x16/c64P/IMG_sad_16x16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_SAD_16X16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_sad_16x16.h                                           */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_sobel_3x3_8.h Source File

IMG_sobel_3x3_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_sobel_3x3_8.h -- Optimized C source interface header file           *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_SOBEL_3X3_8_H_
00040 #define _IMG_SOBEL_3X3_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_sobel_3x3_8/c66/IMG_sobel_3x3_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_sobel_3x3_8/c64P/IMG_sobel_3x3_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_SOBEL_3X3_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_sobel_3x3_8.h                                         */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_sobel_3x3_16.h Source File

IMG_sobel_3x3_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_sobel_3x3_16.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_SOBEL_3X3_16_H_
00040 #define _IMG_SOBEL_3X3_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_sobel_3x3_16/c66/IMG_sobel_3x3_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_sobel_3x3_16/c64P/IMG_sobel_3x3_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_SOBEL_3X3_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_sobel_3x3_16.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_sobel_3x3_16s.h Source File

IMG_sobel_3x3_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_sobel_3x3_16s.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_SOBEL_3X3_16S_H_
00040 #define _IMG_SOBEL_3X3_16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_sobel_3x3_16s/c66/IMG_sobel_3x3_16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_sobel_3x3_16s/c64P/IMG_sobel_3x3_16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_SOBEL_3X3_16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_sobel_3x3_16s.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_sobel_5x5_16s.h Source File

IMG_sobel_5x5_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_sobel_5x5_16s.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_SOBEL_5X5_16S_H_
00040 #define _IMG_SOBEL_5X5_16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_sobel_5x5_16s/c66/IMG_sobel_5x5_16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_sobel_5x5_16s/c64P/IMG_sobel_5x5_16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_SOBEL_5X5_16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_sobel_5x5_16s.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_sobel_7x7_16s.h Source File

IMG_sobel_7x7_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_sobel_7x7_16s.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_SOBEL_7X7_16S_H_
00040 #define _IMG_SOBEL_7X7_16S_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_sobel_7x7_16s/c66/IMG_sobel_7x7_16s.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_sobel_7x7_16s/c64P/IMG_sobel_7x7_16s.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_SOBEL_7X7_16S_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_sobel_7x7_16s.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_thr_gt2max_8.h Source File

IMG_thr_gt2max_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_thr_gt2max_8.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_THR_GT2MAX_8_H_
00040 #define _IMG_THR_GT2MAX_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_thr_gt2max_8/c66/IMG_thr_gt2max_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_thr_gt2max_8/c64P/IMG_thr_gt2max_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_THR_GT2MAX_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_thr_gt2max_8.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_thr_gt2max_16.h Source File

IMG_thr_gt2max_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_thr_gt2max_16.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_THR_GT2MAX_16_H_
00040 #define _IMG_THR_GT2MAX_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_thr_gt2max_16/c66/IMG_thr_gt2max_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_thr_gt2max_16/c64P/IMG_thr_gt2max_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_THR_GT2MAX_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_thr_gt2max_16.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_thr_gt2thr_8.h Source File

IMG_thr_gt2thr_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_thr_gt2thr_8.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_THR_GT2THR_8_H_
00040 #define _IMG_THR_GT2THR_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_thr_gt2thr_8/c66/IMG_thr_gt2thr_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_thr_gt2thr_8/c64P/IMG_thr_gt2thr_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_THR_GT2THR_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_thr_gt2thr_8.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_thr_gt2thr_16.h Source File

IMG_thr_gt2thr_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_thr_gt2thr_16.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_THR_GT2THR_16_H_
00040 #define _IMG_THR_GT2THR_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_thr_gt2thr_16/c66/IMG_thr_gt2thr_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_thr_gt2thr_16/c64P/IMG_thr_gt2thr_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_THR_GT2THR_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_thr_gt2thr_16.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_thr_le2min_8.h Source File

IMG_thr_le2min_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_thr_le2min_8.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_THR_LE2MIN_8_H_
00040 #define _IMG_THR_LE2MIN_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_thr_le2min_8/c66/IMG_thr_le2min_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_thr_le2min_8/c64P/IMG_thr_le2min_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_THR_LE2MIN_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_thr_le2min_8.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_thr_le2min_16.h Source File

IMG_thr_le2min_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_thr_le2min_16.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_THR_LE2MIN_16_H_
00040 #define _IMG_THR_LE2MIN_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_thr_le2min_16/c66/IMG_thr_le2min_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_thr_le2min_16/c64P/IMG_thr_le2min_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_THR_LE2MIN_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_thr_le2min_16.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_thr_le2thr_8.h Source File

IMG_thr_le2thr_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_thr_le2thr_8.h -- Optimized C source interface header file          *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_THR_LE2THR_8_H_
00040 #define _IMG_THR_LE2THR_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_thr_le2thr_8/c66/IMG_thr_le2thr_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_thr_le2thr_8/c64P/IMG_thr_le2thr_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_THR_LE2THR_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_thr_le2thr_8.h                                        */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_thr_le2thr_16.h Source File

IMG_thr_le2thr_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_thr_le2thr_16.h -- Optimized C source interface header file         *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_THR_LE2THR_16_H_
00040 #define _IMG_THR_LE2THR_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_thr_le2thr_16/c66/IMG_thr_le2thr_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_thr_le2thr_16/c64P/IMG_thr_le2thr_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_THR_LE2THR_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_thr_le2thr_16.h                                       */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_wave_horz.h Source File

IMG_wave_horz.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_wave_horz.h -- Optimized C source interface header file             *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_WAVE_HORZ_H_
00040 #define _IMG_WAVE_HORZ_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_wave_horz/c66/IMG_wave_horz.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_wave_horz/c64P/IMG_wave_horz.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_WAVE_HORZ_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_wave_horz.h                                           */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_wave_vert.h Source File

IMG_wave_vert.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_wave_vert.h -- Optimized C source interface header file             *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_WAVE_VERT_H_
00040 #define _IMG_WAVE_VERT_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_wave_vert/c66/IMG_wave_vert.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_wave_vert/c64P/IMG_wave_vert.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_WAVE_VERT_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_wave_vert.h                                           */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_yc_demux_be16_8.h Source File

IMG_yc_demux_be16_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_yc_demux_be16_8.h -- Optimized C source interface header file       *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_YC_DEMUX_BE16_8_H_
00040 #define _IMG_YC_DEMUX_BE16_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_yc_demux_be16_8/c66/IMG_yc_demux_be16_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_yc_demux_be16_8/c64P/IMG_yc_demux_be16_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_YC_DEMUX_BE16_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_yc_demux_be16_8.h                                     */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_yc_demux_be16_16.h Source File

IMG_yc_demux_be16_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_yc_demux_be16_16.h -- Optimized C source interface header file      *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_YC_DEMUX_BE16_16_H_
00040 #define _IMG_YC_DEMUX_BE16_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_yc_demux_be16_16/c66/IMG_yc_demux_be16_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_yc_demux_be16_16/c64P/IMG_yc_demux_be16_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_YC_DEMUX_BE16_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_yc_demux_be16_16.h                                    */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_yc_demux_le16_8.h Source File

IMG_yc_demux_le16_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_yc_demux_le16_8.h -- Optimized C source interface header file       *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_YC_DEMUX_LE16_8_H_
00040 #define _IMG_YC_DEMUX_LE16_8_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_yc_demux_le16_8/c66/IMG_yc_demux_le16_8.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_yc_demux_le16_8/c64P/IMG_yc_demux_le16_8.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_YC_DEMUX_LE16_8_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_yc_demux_le16_8.h                                     */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_yc_demux_le16_16.h Source File

IMG_yc_demux_le16_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_yc_demux_le16_16.h -- Optimized C source interface header file      *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_YC_DEMUX_LE16_16_H_
00040 #define _IMG_YC_DEMUX_LE16_16_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_yc_demux_le16_16/c66/IMG_yc_demux_le16_16.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_yc_demux_le16_16/c64P/IMG_yc_demux_le16_16.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_YC_DEMUX_LE16_16_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_yc_demux_le16_16.h                                    */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_ycbcr422pl_to_rgb565.h Source File

IMG_ycbcr422pl_to_rgb565.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *  IMG_ycbcr422pl_to_rgb565.h -- Optimized C source interface header file  *
00005  *                                                                          *
00006  *                                                                          *
00007  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00008  *                                                                          *
00009  *                                                                          *
00010  *  Redistribution and use in source and binary forms, with or without      *
00011  *  modification, are permitted provided that the following conditions      *
00012  *  are met:                                                                *
00013  *                                                                          *
00014  *    Redistributions of source code must retain the above copyright        *
00015  *    notice, this list of conditions and the following disclaimer.         *
00016  *                                                                          *
00017  *    Redistributions in binary form must reproduce the above copyright     *
00018  *    notice, this list of conditions and the following disclaimer in the   *
00019  *    documentation and/or other materials provided with the                *
00020  *    distribution.                                                         *
00021  *                                                                          *
00022  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00023  *    its contributors may be used to endorse or promote products derived   *
00024  *    from this software without specific prior written permission.         *
00025  *                                                                          *
00026  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00027  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00028  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00029  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00030  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00031  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00032  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00033  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00034  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00035  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00036  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00037  * ======================================================================== */
00038
00039 #ifndef _IMG_YCBCR422PL_TO_RGB565_H_
00040 #define _IMG_YCBCR422PL_TO_RGB565_H_ 1
00041
00042 #if defined (_TMS320C6600)
00043 #include <ti/imglib/src/IMG_ycbcr422pl_to_rgb565/c66/IMG_ycbcr422pl_to_rgb565.h>
00044 #elif defined (_TMS320C6400_PLUS)
00045 #include <ti/imglib/src/IMG_ycbcr422pl_to_rgb565/c64P/IMG_ycbcr422pl_to_rgb565.h>
00046 #else
00047 #error invalid target
00048 #endif
00049
00050 #endif /* _IMG_YCBCR422PL_TO_RGB565_H_ */
00051
00052 /* ======================================================================== */
00053 /*  End of file:  IMG_ycbcr422pl_to_rgb565.h                                */
00054 /* ======================================================================== */
00055


IMGLIB: IMG_boundary_8.h Source File

IMG_boundary_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_BOUNDARY_8_H_
00038 #define IMG_BOUNDARY_8_H_ 1
00039
00042 /* @{ */
00043
00088 void IMG_boundary_8
00089 (
00090     const unsigned char *restrict i_data,
00091     int rows, int cols,
00092     int *restrict o_coord,
00093     int *restrict o_grey
00094 );
00095
00098 #endif
00099
00100 /* ======================================================================== */
00101 /*  End of file:  IMG_boundary_8.h                                          */
00102 /* ======================================================================== */


IMGLIB: IMG_boundary_16s.h Source File

IMG_boundary_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_BOUNDARY_16S_H_
00038 #define IMG_BOUNDARY_16S_H_ 1
00039
00042 /* @{ */
00043
00088 void IMG_boundary_16s
00089 (
00090     const  short *restrict  i_data,
00091              int              rows,
00092              int              cols,
00093     unsigned int *restrict o_coord,
00094            short *restrict  o_grey
00095 );
00096
00099 #endif
00100
00101 /* ======================================================================== */
00102 /*  End of file:  IMG_boundary_16s.h                                        */
00103 /* ======================================================================== */


IMGLIB: IMG_clipping_16s.h Source File

IMG_clipping_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CLIPPING_16S_H_
00038 #define IMG_CLIPPING_16S_H_ 1
00039
00042 /* @{ */
00043
00085 void IMG_clipping_16s
00086 (
00087     const short *restrict x,        /* Input Matrix Pointer                */
00088     short              rows,        /* Height of input matrix              */
00089     short              cols,        /* Width of input matrix               */
00090     short       *restrict r,        /* Output matrix Pointer               */
00091     short         THRES_MAX,        /* Maximum Threshold Value             */
00092     short         THRES_MIN         /* Minimum Threshold Value             */
00093 );
00094
00097 #endif
00098
00099 /* ======================================================================= */
00100 /*  End of file:  IMG_clipping_16s.h                                       */
00101 /* ======================================================================= */


IMGLIB: IMG_conv_3x3_i8_c8s.h Source File

IMG_conv_3x3_i8_c8s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00039 /* @{ */
00040
00041 #ifndef IMG_CONV_3X3_I8_C8S_H_
00042 #define IMG_CONV_3X3_I8_C8S_H_ 1
00043
00092 void IMG_conv_3x3_i8_c8s
00093 (
00094     const unsigned char *restrict  imgin_ptr,
00095     unsigned char       *restrict imgout_ptr,
00096     short                              width,
00097     short                              pitch,
00098     const char          *restrict   mask_ptr,
00099     short                              shift
00100 );
00101
00102 #endif
00103
00106 /* ======================================================================== */
00107 /*  End of file:  IMG_conv_3x3_i8_c8s.h                                     */
00108 /* ======================================================================== */


IMGLIB: IMG_conv_3x3_i16_c16s.h Source File

IMG_conv_3x3_i16_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_CONV_3X3_I16_C16S_H_
00038 #define  IMG_CONV_3X3_I16_C16S_H_ 1
00039
00042 /* @{ */
00043
00089 void IMG_conv_3x3_i16_c16s
00090 (
00091     const unsigned short *restrict imgin_ptr,
00092           unsigned short *restrict imgout_ptr,
00093           int                      width,
00094     const          short *restrict mask_ptr,
00095           int                      shift
00096 );
00097
00100 #endif
00101
00102 /*========================================================================= */
00103 /*   End of file:  IMG_conv_3x3_i16_c16s.h                                  */
00104 /* ======================================================================== */
00105


IMGLIB: IMG_conv_3x3_i16s_c16s.h Source File

IMG_conv_3x3_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_CONV_3X3_I16S_C16S_H_
00038 #define  IMG_CONV_3X3_I16S_C16S_H_ 1
00039
00042 /* @{ */
00043
00099 void IMG_conv_3x3_i16s_c16s
00100 (
00101     const short   *restrict    imgin_ptr,
00102           short   *restrict   imgout_ptr,
00103           short                    width,
00104           short                    pitch,
00105     const short   *restrict     mask_ptr,
00106           short                    shift
00107 );
00108
00111 #endif
00112
00113 /* ======================================================================== */
00114 /*  End of file:  IMG_conv_3x3_i16s_c16s.h                                  */
00115 /* ======================================================================== */


IMGLIB: IMG_conv_5x5_i8_c8s.h Source File

IMG_conv_5x5_i8_c8s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00039 /* @{ */
00040
00041 #ifndef IMG_CONV_5X5_I8_C8S_H_
00042 #define IMG_CONV_5X5_I8_C8S_H_ 1
00043
00092 void IMG_conv_5x5_i8_c8s
00093 (
00094     const unsigned char *restrict  imgin_ptr,
00095     unsigned char       *restrict imgout_ptr,
00096     short                              width,
00097     short                              pitch,
00098     const char          *restrict   mask_ptr,
00099     short                              shift
00100 );
00101
00102 #endif
00103
00106 /* ======================================================================== */
00107 /*  End of file:  IMG_conv_5x5_i8_c8s.h                                     */
00108 /* ======================================================================== */


IMGLIB: IMG_conv_5x5_i8_c16s.h Source File

IMG_conv_5x5_i8_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CONV_5X5_I8_C16S_H_
00038 #define IMG_CONV_5X5_I8_C16S_H_ 1
00039
00042 /* @{ */
00043
00096 void IMG_conv_5x5_i8_c16s
00097 (
00098     const unsigned char *restrict  imgin_ptr,
00099           unsigned char *restrict imgout_ptr,
00100     short                              width,
00101     short                              pitch,
00102     const          short *restrict  mask_ptr,
00103     short                              shift
00104 );
00105
00108 #endif
00109
00110 /* ======================================================================== */
00111 /*  End of file:  IMG_conv_5x5_i8_c16s.h                                    */
00112 /* ======================================================================== */


IMGLIB: IMG_conv_5x5_i16s_c16s.h Source File

IMG_conv_5x5_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_CONV_5X5_I16S_C16S_H_
00038 #define  IMG_CONV_5X5_I16S_C16S_H_ 1
00039
00042 /* @{ */
00043
00099 void IMG_conv_5x5_i16s_c16s
00100 (
00101     const short   *restrict    imgin_ptr,
00102           short   *restrict   imgout_ptr,
00103           short                    width,
00104           short                    pitch,
00105     const short   *restrict     mask_ptr,
00106           short                    shift
00107 );
00108
00111 #endif
00112
00113 /* ======================================================================== */
00114 /*  End of file:  IMG_conv_5x5_i16s_c16s.h                                  */
00115 /* ======================================================================== */


IMGLIB: IMG_conv_7x7_i8_c8s.h Source File

IMG_conv_7x7_i8_c8s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CONV_7X7_I8_C8S_H_
00038 #define IMG_CONV_7X7_I8_C8S_H_ 1
00039
00042 /* @{ */
00043
00092 void IMG_conv_7x7_i8_c8s
00093 (
00094     const unsigned char *restrict  imgin_ptr,
00095     unsigned char       *restrict imgout_ptr,
00096     short                              width,
00097     short                              pitch,
00098     const char          *restrict   mask_ptr,
00099     short                              shift
00100 );
00101
00104 #endif
00105
00106 /* ======================================================================== */
00107 /*  End of file:  IMG_conv_7x7_i8_c8s.h                                     */
00108 /* ======================================================================== */


IMGLIB: IMG_conv_7x7_i8_c16s.h Source File

IMG_conv_7x7_i8_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CONV_7X7_I8_C16S_H_
00038 #define IMG_CONV_7X7_I8_C16S_H_ 1
00039
00042 /* @{ */
00043
00096 void IMG_conv_7x7_i8_c16s
00097 (
00098     const unsigned char *restrict  imgin_ptr,
00099     unsigned char       *restrict imgout_ptr,
00100     short                              width,
00101     short                              pitch,
00102     const          short *restrict  mask_ptr,
00103     int                                shift
00104 );
00105
00108 #endif
00109
00110 /* ======================================================================== */
00111 /*  End of file:  IMG_conv_7x7_i8_c16s.h                                    */
00112 /* ======================================================================== */


IMGLIB: IMG_conv_7x7_i16s_c16s.h Source File

IMG_conv_7x7_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CONV_7X7_I16S_C16S_H_
00038 #define IMG_CONV_7X7_I16S_C16S_H_ 1
00039
00042 /* @{ */
00043
00099 void IMG_conv_7x7_i16s_c16s
00100 (
00101     const short   *restrict    imgin_ptr,
00102           short   *restrict   imgout_ptr,
00103           short                    width,
00104           short                    pitch,
00105     const short   *restrict     mask_ptr,
00106           short                    shift
00107 );
00108
00111 #endif
00112
00113 /* ======================================================================== */
00114 /*  End of file:  IMG_conv_7x7_i16s_c16s.h                                  */
00115 /* ======================================================================== */


IMGLIB: IMG_conv_11x11_i8_c8s.h Source File

IMG_conv_11x11_i8_c8s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CONV_11X11_I8_C8S_H_
00038 #define IMG_CONV_11X11_I8_C8S_H_ 1
00039
00042 /* @{ */
00043
00092 void IMG_conv_11x11_i8_c8s
00093 (
00094     const unsigned char    *restrict  imgin_ptr,
00095           unsigned char    *restrict imgout_ptr,
00096                    short                  width,
00097                    short                  pitch,
00098     const          char    *restrict   mask_ptr,
00099                    short                  shift
00100 );
00101
00104 #endif
00105
00106 /* ======================================================================== */
00107 /*  End of file:  IMG_conv_11x11_i8_c8s.h                                   */
00108 /* ======================================================================== */


IMGLIB: IMG_conv_11x11_i16s_c16s.h Source File

IMG_conv_11x11_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CONV_11X11_I16S_C16S_H_
00038 #define IMG_CONV_11X11_I16S_C16S_H_ 1
00039
00042 /* @{ */
00043
00098 void IMG_conv_11x11_i16s_c16s
00099 (
00100     const short   *restrict    imgin_ptr,
00101           short   *restrict   imgout_ptr,
00102           short                    width,
00103           short                    pitch,
00104     const short   *restrict     mask_ptr,
00105           short                    shift
00106 );
00107
00110 #endif
00111
00112 /* ======================================================================== */
00113 /*  End of file:  IMG_conv_11x11_i16s_c16s.h                                */
00114 /* ======================================================================== */


IMGLIB: IMG_corr_3x3_i8_c8.h Source File

IMG_corr_3x3_i8_c8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CORR_3X3_I8_C8_H_
00038 #define IMG_CORR_3X3_I8_C8_H_ 1
00039
00042 /* @{ */
00043
00102 void IMG_corr_3x3_i8_c8
00103 (
00104     const unsigned char           *imgin_ptr,
00105           int           *restrict imgout_ptr,
00106           short                   width,
00107           short                   pitch,
00108     const unsigned char           *mask_ptr,
00109           short                   shift,
00110           int                     round
00111 );
00112
00115 #endif
00116
00117 /* ======================================================================== */
00118 /*  End of file:  IMG_corr_3x3_i8_c8.h                                      */
00119 /* ======================================================================== */


IMGLIB: IMG_corr_3x3_i8_c16s.h Source File

IMG_corr_3x3_i8_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CORR_3X3_I8_C16S_H_
00038 #define IMG_CORR_3X3_I8_C16S_H_ 1
00039
00042 /* @{ */
00043
00092 void IMG_corr_3x3_i8_c16s
00093 (
00094     const unsigned char *restrict  imgin_ptr,
00095     int                 *restrict imgout_ptr,
00096     short                              width,
00097     short                              pitch,
00098     const          short *restrict  mask_ptr
00099 );
00100
00103 #endif
00104
00105 /* ======================================================================== */
00106 /*  End of file:  IMG_corr_3x3_i8_c16s.h                                    */
00107 /* ======================================================================== */


IMGLIB: IMG_corr_3x3_i16_c16.h Source File

IMG_corr_3x3_i16_c16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_CORR_3X3_I16_C16_H_
00038 #define  IMG_CORR_3X3_I16_C16_H_ 1
00039
00042 /* @{ */
00043
00093 void IMG_corr_3x3_i16_c16
00094 (
00095     const unsigned short           *imgin_ptr,
00096           unsigned int    *restrict imgout_ptr,
00097     const unsigned short            *mask_ptr,
00098           short                     pitch,
00099           short                     width
00100 );
00101
00104 #endif
00105
00106 /* ======================================================================== */
00107 /*  End of file:  IMG_corr_3x3_i16_c16.h                                    */
00108 /* ======================================================================== */
00109


IMGLIB: IMG_corr_3x3_i16s_c16s.h Source File

IMG_corr_3x3_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_CORR_3X3_I16S_C16S_H_
00038 #define  IMG_CORR_3X3_I16S_C16S_H_ 1
00039
00042 /* @{ */
00043
00104 void IMG_corr_3x3_i16s_c16s
00105 (
00106     const  short    *restrict  imgin_ptr,
00107            int      *restrict imgout_ptr,
00108            short                   width,
00109            short                   pitch,
00110     const  short    *restrict   mask_ptr,
00111            short                   shift,
00112            int                     round
00113 );
00114
00117 #endif
00118
00119 /* ======================================================================== */
00120 /*  End of file:  IMG_corr_3x3_i16s_c16s.h                                  */
00121 /* ======================================================================== */


IMGLIB: IMG_corr_5x5_i16s_c16s.h Source File

IMG_corr_5x5_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_CORR_5X5_I16S_C16S_H_
00038 #define  IMG_CORR_5X5_I16S_C16S_H_ 1
00039
00042 /* @{ */
00043
00104 void IMG_corr_5x5_i16s_c16s
00105 (
00106     const  short    *restrict  imgin_ptr,
00107            int      *restrict imgout_ptr,
00108            short                   width,
00109            short                   pitch,
00110     const  short    *restrict   mask_ptr,
00111            short                   shift,
00112            int                     round
00113 );
00114
00117 #endif
00118
00119 /* ======================================================================== */
00120 /*  End of file:  IMG_corr_5x5_i16s_c16s.h                                  */
00121 /* ======================================================================== */


IMGLIB: IMG_corr_11x11_i8_c16s.h Source File

IMG_corr_11x11_i8_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CORR_11X11_I8_C16S_H_
00038 #define IMG_CORR_11X11_I8_C16S_H_ 1
00039
00042 /* @{ */
00043
00092 void IMG_corr_11x11_i8_c16s
00093 (
00094     const unsigned char    *restrict  imgin_ptr,
00095                    int     *restrict imgout_ptr,
00096                    short                  width,
00097                    short                  pitch,
00098     const          short   *restrict   mask_ptr
00099 );
00100
00103 #endif
00104
00105 /* ======================================================================== */
00106 /*  End of file:  IMG_corr_11x11_i8_c16s.h                                  */
00107 /* ======================================================================== */


IMGLIB: IMG_corr_11x11_i16s_c16s.h Source File

IMG_corr_11x11_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CORR_11X11_I16S_C16S_H_
00038 #define IMG_CORR_11X11_I16S_C16S_H_ 1
00039
00042 /* @{ */
00043
00100 void IMG_corr_11x11_i16s_c16s
00101 (
00102     const  short    *restrict  imgin_ptr,
00103            int      *restrict imgout_ptr,
00104            short                   width,
00105            short                   pitch,
00106     const  short    *restrict   mask_ptr,
00107            short                   shift,
00108            int                     round
00109 );
00110
00113 #endif
00114
00115 /* ======================================================================== */
00116 /*  End of file:  IMG_corr_11x11_i16s_c16s.h                                */
00117 /* ======================================================================== */


IMGLIB: IMG_corr_gen_i16s_c16s.h Source File

IMG_corr_gen_i16s_c16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CORR_GEN_I16S_C16S_H_
00038 #define IMG_CORR_GEN_I16S_C16S_H_ 1
00039
00042 /* @{ */
00043
00085 void IMG_corr_gen_i16s_c16s
00086 (
00087     short *restrict x,
00088     short *restrict h,
00089     short *restrict y,
00090     int             m,
00091     int             pitch
00092 );
00093
00096 #endif
00097
00098 /* ======================================================================== */
00099 /*  End of file:  IMG_corr_gen_i16s_c16s.h                                  */
00100 /* ======================================================================== */


IMGLIB: IMG_corr_gen_iq.h Source File

IMG_corr_gen_iq.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_CORR_GEN_IQ_H_
00038 #define IMG_CORR_GEN_IQ_H_ 1
00039
00042 /* @{ */
00043
00102 void IMG_corr_gen_iq
00103 (
00104     const int   *restrict x,
00105     const short *restrict h,
00106     int         *restrict y,
00107     int                   m,
00108     int               pitch,
00109     int               x_qpt,
00110     int               h_qpt,
00111     int               y_qpt
00112 );
00113
00116 #endif
00117
00118 /* ======================================================================== */
00119 /*  End of file:  IMG_corr_gen_iq.h                                         */
00120 /* ======================================================================== */


IMGLIB: IMG_dilate_bin.h Source File

IMG_dilate_bin.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_DILATE_BIN_H_
00038 #define IMG_DILATE_BIN_H_ 1
00039
00042 /* @{ */
00043
00127 void IMG_dilate_bin
00128 (
00129     const unsigned char *restrict in_data,
00130           unsigned char *restrict out_data,
00131     const          char *restrict mask,
00132     int                           cols
00133 );
00134
00137 #endif
00138
00139 /* ======================================================================== */
00140 /*  End of file:  IMG_dilate_bin.h                                          */
00141 /* ======================================================================== */


IMGLIB: IMG_erode_bin.h Source File

IMG_erode_bin.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_ERODE_BIN_H_
00038 #define IMG_ERODE_BIN_H_ 1
00039
00042 /* @{ */
00043
00127 void IMG_erode_bin
00128 (
00129     const unsigned char *restrict in_data,
00130           unsigned char *restrict out_data,
00131     const          char *restrict mask,
00132     int                           cols
00133 );
00134
00137 #endif
00138
00139 /* ======================================================================== */
00140 /*  End of file:  IMG_erode_bin.h                                           */
00141 /* ======================================================================== */


IMGLIB: IMG_errdif_bin_8.h Source File

IMG_errdif_bin_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_ERRDIF_BIN_8_H_
00038 #define  IMG_ERRDIF_BIN_8_H_ 1
00039
00042 /* @{ */
00043
00113 void IMG_errdif_bin_8
00114 (
00115     unsigned char *restrict errdif_data, /* Input/Output image ptr       */
00116     int           cols,                  /* Number of columns (Width)    */
00117     int           rows,                  /* Number of rows    (Height)   */
00118     short         *restrict err_buf,     /* row-to-row error buffer.     */
00119     unsigned char thresh                 /* Threshold from [0x00, 0xFF]  */
00120 );
00121
00124 #endif
00125
00126 /* ======================================================================== */
00127 /*  End of file:  IMG_errdif_bin_8.h                                        */
00128 /* ======================================================================== */


IMGLIB: IMG_errdif_bin_16.h Source File

IMG_errdif_bin_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_ERRDIF_BIN_16_H_
00038 #define  IMG_ERRDIF_BIN_16_H_ 1
00039
00042 /* @{ */
00043
00116 void IMG_errdif_bin_16
00117 (
00118     unsigned short *restrict errdif_data, /* Input/Output image ptr       */
00119     int                      cols,        /* Number of columns (Width)    */
00120     int                      rows,        /* Number of rows    (Height)   */
00121     short          *restrict err_buf,     /* row-to-row error buffer.     */
00122     unsigned short           thresh       /* Threshold from [0x00, 0xFF]  */
00123 );
00124
00127 #endif
00128
00129 /* ======================================================================== */
00130 /*  End of file:  IMG_errdif_bin_16.h                                       */
00131 /* ======================================================================== */


IMGLIB: IMG_fdct_8x8.h Source File

IMG_fdct_8x8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_FDCT_8X8_H_
00038 #define IMG_FDCT_8X8_H_ 1
00039
00042 /* @{ */
00043
00106 void IMG_fdct_8x8
00107 (
00108     short fdct_data[],
00109     unsigned num_fdcts
00110 );
00111
00114 #endif
00115
00116 /* ======================================================================== */
00117 /*  End of file:  IMG_fdct_8x8.h                                            */
00118 /* ======================================================================== */


IMGLIB: IMG_histogram_8.h Source File

IMG_histogram_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_HISTOGRAM_8_H_
00038 #define IMG_HISTOGRAM_8_H_ 1
00039
00042 /* @{ */
00043
00120 void IMG_histogram_8
00121 (
00122     const unsigned char *restrict image,
00123     int   n,
00124     short accumulate,
00125     short *restrict t_hist,
00126     short *restrict hist
00127 );
00128
00131 #endif
00132
00133 /* =========================================================================*/
00134 /*  End of file:  IMG_histogram_8.h                                         */
00135 /* =========================================================================*/


IMGLIB: IMG_histogram_16.h Source File

IMG_histogram_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_HISTOGRAM_16_H_
00038 #define IMG_HISTOGRAM_16_H_ 1
00039
00042 /* @{ */
00043
00136 void IMG_histogram_16
00137 (
00138      unsigned short *restrict    image,  /* input image data                */
00139                 int                  n,  /* number of input image pixels    */
00140                 int         accumulate,  /* define add/sum for histogtram   */
00141               short *restrict   t_hist,  /* temporary histogram bins        */
00142               short *restrict     hist,  /* running histogram bins          */
00143                 int           img_bits   /* number of data bits per pixel   */
00144 );
00145
00148 #endif
00149
00150 /* ======================================================================== */
00151 /*  End of file:  IMG_histogram_16.h                                        */
00152 /* ======================================================================== */


IMGLIB: IMG_idct_8x8_12q4.h Source File

IMG_idct_8x8_12q4.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_IDCT_8X8_12Q4_H_
00038 #define IMG_IDCT_8X8_12Q4_H_ 1
00039
00042 /* @{ */
00043
00104 void IMG_idct_8x8_12q4
00105 (
00106     short idct_data[],
00107     unsigned num_idcts
00108 );
00109
00112 #endif
00113
00114 /* ======================================================================== */
00115 /*  End of file:  IMG_idct_8x8_12q4.h                                       */
00116 /* ======================================================================== */


IMGLIB: IMG_mad_8x8.h Source File

IMG_mad_8x8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_MAD_8X8_H_
00038 #define IMG_MAD_8X8_H_ 1
00039
00042 /* @{ */
00043
00130 void IMG_mad_8x8
00131 (
00132     const unsigned char *ref_data,  /* Ref. image to search     */
00133     const unsigned char *src_data,  /* Source 8x8 block         */
00134     int                 pitch,      /* Width of ref image       */
00135     int                 sx,         /* Search window horz size  */
00136     int                 sy,         /* Search window vert size  */
00137     unsigned int        *match      /* Result                   */
00138 );
00139
00142 #endif
00143
00144 /* ======================================================================== */
00145 /*  End of file:  IMG_mad_8x8.h                                             */
00146 /* ======================================================================== */


IMGLIB: IMG_mad_16x16.h Source File

IMG_mad_16x16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_MAD_16X16_H_
00038 #define IMG_MAD_16X16_H_ 1
00039
00042 /* @{ */
00043
00118 void IMG_mad_16x16
00119 (
00120     const unsigned char *restrict refImg,
00121     const unsigned char *restrict srcImg,
00122     int                 pitch,
00123     int                 h,
00124     int                 v,
00125     unsigned            *restrict match
00126 );
00127
00130 #endif
00131
00132 /* ======================================================================== */
00133 /*  End of file:  IMG_mad_16x16.h                                           */
00134 /* ======================================================================== */


IMGLIB: IMG_median_3x3_8.h Source File

IMG_median_3x3_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_MEDIAN_3X3_8_H_
00038 #define IMG_MEDIAN_3X3_8_H_ 1
00039
00042 /* @{ */
00043
00114 void IMG_median_3x3_8
00115 (
00116     const unsigned char *restrict i_data,
00117     int                                n,
00118     unsigned char       *restrict o_data
00119 );
00120
00123 #endif
00124
00125 /* ======================================================================== */
00126 /*  End of file:  IMG_median_3x3_8.h                                        */
00127 /* ------------------------------------------------------------------------ */


IMGLIB: IMG_median_3x3_16.h Source File

IMG_median_3x3_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_MEDIAN_3X3_16_H_
00038 #define IMG_MEDIAN_3X3_16_H_ 1
00039
00042 /* @{ */
00043
00121 void IMG_median_3x3_16
00122 (
00123     const unsigned short *restrict i_data,
00124     int n,
00125     unsigned short      *restrict o_data
00126 );
00127
00130 #endif
00131
00132 /*========================================================================= */
00133 /*   End of file:  IMG_median_3x3_16.h                                      */
00134 /* ======================================================================== */
00135


IMGLIB: IMG_median_3x3_16s.h Source File

IMG_median_3x3_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_MEDIAN_3X3_16S_H_
00038 #define IMG_MEDIAN_3X3_16S_H_ 1
00039
00042 /* @{ */
00043
00119 void IMG_median_3x3_16s
00120 (
00121     const short *restrict i_data,
00122     int                        n,
00123     short       *restrict o_data
00124 );
00125
00128 #endif
00129
00130 /* =========================================================================*/
00131 /*  End of file:  IMG_median_3x3_16s.h                                      */
00132 /* =========================================================================*/


IMGLIB: IMG_perimeter_8.h Source File

IMG_perimeter_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_PERIMETER_8_H_
00038 #define IMG_PERIMETER_8_H_ 1
00039
00042 /* @{ */
00043
00118 int IMG_perimeter_8
00119 (
00120     const unsigned char *restrict in,  /* Input image    */
00121     int                         cols,  /* Width of input */
00122     unsigned char       *restrict out  /* Output image   */
00123 );
00124
00127 #endif
00128
00129 /* ======================================================================== */
00130 /*  End of file:  IMG_perimeter_8.h                                         */
00131 /* ======================================================================== */


IMGLIB: IMG_perimeter_16.h Source File

IMG_perimeter_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_PERIMETER_16_H_
00038 #define IMG_PERIMETER_16_H_ 1
00039
00042 /* @{ */
00043
00091 int IMG_perimeter_16
00092 (
00093     const unsigned short *restrict in,  /* Input image    */
00094     int cols,                           /* Width of input */
00095     unsigned short       *restrict out  /* Output image   */
00096 );
00097
00100 #endif
00101
00102 /* ======================================================================== */
00103 /*  End of file:  IMG_perimeter_16.h                                        */
00104 /* ======================================================================== */


IMGLIB: IMG_pix_expand.h Source File

IMG_pix_expand.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_PIX_EXPAND_H_
00038 #define IMG_PIX_EXPAND_H_ 1
00039
00042 /* @{ */
00043
00073 void IMG_pix_expand
00074 (
00075     int n,
00076     const unsigned char *restrict in_data,
00077     short               *restrict out_data
00078 );
00079
00082 #endif
00083
00084 /* ======================================================================== */
00085 /*  End of file:  IMG_pix_expand.h                                          */
00086 /* ======================================================================== */


IMGLIB: IMG_pix_sat.h Source File

IMG_pix_sat.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_PIX_SAT_H_
00038 #define IMG_PIX_SAT_H_ 1
00039
00042 /* @{ */
00043
00070 void IMG_pix_sat
00071 (
00072     int                     n,
00073     const short   *restrict in_data,
00074     unsigned char *restrict out_data
00075 );
00076
00079 #endif
00080
00081 /* ======================================================================== */
00082 /*  End of file:  IMG_pix_sat.h                                             */
00083 /* ======================================================================== */


IMGLIB: IMG_quantize.h Source File

IMG_quantize.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_QUANTIZE_H_
00038 #define IMG_QUANTIZE_H_ 1
00039
00042 /* @{ */
00043
00104 void IMG_quantize
00105 (
00106     short           *data,      /* Data to be quantized.        */
00107     unsigned short  num_blks,   /* Number of blocks to process. */
00108     unsigned short  blk_size,   /* Block size (multiple of 16);. */
00109     const short     *recip_tbl, /* Quant. values (reciprocals);. */
00110     int             q_pt        /* Q-point of Quant values.     */
00111 );
00112
00115 #endif
00116
00117 /* ======================================================================== */
00118 /*  End of file:  IMG_quantize.h                                            */
00119 /* ======================================================================== */


IMGLIB: IMG_sad_8x8.h Source File

IMG_sad_8x8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_SAD_8X8_H_
00038 #define IMG_SAD_8X8_H_ 1
00039
00042 /* @{ */
00043
00082 unsigned IMG_sad_8x8
00083 (
00084     const unsigned char *restrict srcImg,  /* 8x8 source block   */
00085     const unsigned char *restrict refImg,  /* Reference image    */
00086     int pitch                              /* Width of ref image */
00087 );
00088
00091 #endif
00092
00093 /* ======================================================================== */
00094 /*  End of file:  IMG_sad_8x8.h                                             */
00095 /* ======================================================================== */


IMGLIB: IMG_sad_16x16.h Source File

IMG_sad_16x16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_SAD_16X16_H_
00038 #define IMG_SAD_16X16_H_ 1
00039
00042 /* @{ */
00043
00082 unsigned IMG_sad_16x16
00083 (
00084     const unsigned char *restrict srcImg,  /* 16x16 source block */
00085     const unsigned char *restrict refImg,  /* Reference image    */
00086     int pitch                              /* Width of ref image */
00087 );
00088
00091 #endif
00092
00093 /* ======================================================================== */
00094 /*  End of file:  IMG_sad_16x16.h                                           */
00095 /* ======================================================================== */


IMGLIB: IMG_sobel_3x3_8.h Source File

IMG_sobel_3x3_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_SOBEL_3x3_8_H_
00038 #define IMG_SOBEL_3x3_8_H_ 1
00039
00042 /* @{ */
00043
00140 void IMG_sobel_3x3_8
00141 (
00142     const unsigned char *restrict in,   /* Input image data   */
00143           unsigned char *restrict out,  /* Output image data  */
00144     short                         cols, /* Image dimensions   */
00145     short                         rows  /* Image dimensions   */
00146 );
00147
00150 #endif
00151
00152 /* ======================================================================== */
00153 /*  End of file:  IMG_sobel_3x3_8.h                                         */
00154 /* ======================================================================== */


IMGLIB: IMG_sobel_3x3_16.h Source File

IMG_sobel_3x3_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_SOBEL_3X3_16_H_
00038 #define IMG_SOBEL_3X3_16_H_ 1
00039
00042 /* @{ */
00043
00140 void IMG_sobel_3x3_16
00141 (
00142     const unsigned short *restrict in,   /* Input image data   */
00143           unsigned short *restrict out,  /* Output image data  */
00144                    short           cols, /* Image columns      */
00145                    short           rows  /* Image rows         */
00146 );
00147
00150 #endif
00151
00152 /* ======================================================================== */
00153 /*   End of file:  IMG_sobel_3x3_16.h                                       */
00154 /* ======================================================================== */
00155


IMGLIB: IMG_sobel_3x3_16s.h Source File

IMG_sobel_3x3_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_SOBEL_3X3_16S_H_
00038 #define IMG_SOBEL_3X3_16S_H_ 1
00039
00042 /* @{ */
00043
00140 void IMG_sobel_3x3_16s
00141 (
00142     const short *restrict   in,  /* Input image data   */
00143           short *restrict  out,  /* Output image data  */
00144           short           cols,  /* image columns      */
00145           short           rows   /* Image rows         */
00146 );
00147
00150 #endif
00151
00152 /* ======================================================================== */
00153 /*  End of file:  IMG_sobel_3x3_16s.h                                       */
00154 /* ======================================================================== */


IMGLIB: IMG_sobel_5x5_16s.h Source File

IMG_sobel_5x5_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_SOBEL_5X5_16S_H_
00038 #define IMG_SOBEL_5X5_16S_H_ 1
00039
00042 /* @{ */
00043
00144 void IMG_sobel_5x5_16s
00145 (
00146     const short *restrict  in,   /* Input image data   */
00147           short *restrict out,   /* Output image data  */
00148           short          cols,   /* image columns      */
00149           short          rows    /* Image rows         */
00150 );
00151
00154 #endif
00155
00156 /* ======================================================================== */
00157 /*  End of file:  IMG_sobel_5x5_16s.h                                       */
00158 /* ======================================================================== */


IMGLIB: IMG_sobel_7x7_16s.h Source File

IMG_sobel_7x7_16s.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_SOBEL_7x7_16s_H_
00038 #define IMG_SOBEL_7x7_16s_H_ 1
00039
00042 /* @{ */
00043
00154 void IMG_sobel_7x7_16s
00155 (
00156     const short *restrict  in,   /* Input image data   */
00157           short *restrict out,   /* Output image data  */
00158           short          cols,   /* image columns      */
00159           short          rows    /* Image rows         */
00160 );
00161
00164 #endif
00165
00166 /* ======================================================================== */
00167 /*  End of file:  IMG_sobel_7x7_16s.h                                       */
00168 /* ======================================================================== */


IMGLIB: IMG_thr_gt2max_8.h Source File

IMG_thr_gt2max_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_THR_GT2MAX_8_H_
00038 #define IMG_THR_GT2MAX_8_H_ 1
00039
00042 /* @{ */
00043
00149 void IMG_thr_gt2max_8
00150 (
00151     const unsigned char *in_data,                /*  Input image data    */
00152     unsigned char       *restrict out_data,      /*  Output image data   */
00153     short cols, short rows,                      /*  Image dimensions    */
00154     unsigned char       threshold                /*  Threshold value     */
00155 );
00156
00159 #endif
00160
00161 /* ======================================================================== */
00162 /*  End of file:  IMG_thr_gt2max_8.h                                        */
00163 /* ======================================================================== */


IMGLIB: IMG_thr_gt2max_16.h Source File

IMG_thr_gt2max_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_THR_GT2MAX_16_H_
00038 #define IMG_THR_GT2MAX_16_H_ 1
00039
00042 /* @{ */
00043
00109 void IMG_thr_gt2max_16
00110 (
00111     const unsigned short *restrict in_data,      /*  Input image data    */
00112           unsigned short *restrict out_data,     /*  Output image data   */
00113                    short           cols,         /*  Image columns       */
00114                    short           rows,         /*  Image rows          */
00115           unsigned short           threshold     /*  Threshold value     */
00116 );
00117
00120 #endif
00121
00122 /*========================================================================= */
00123 /*   End of file:  IMG_thr_gt2max_16.h                                      */
00124 /* ======================================================================== */
00125


IMGLIB: IMG_thr_gt2thr_8.h Source File

IMG_thr_gt2thr_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_THR_GT2THR_8_H_
00038 #define IMG_THR_GT2THR_8_H_ 1
00039
00042 /* @{ */
00043
00139 void IMG_thr_gt2thr_8
00140 (
00141     const unsigned char *in_data,                /*  Input image data    */
00142     unsigned char       *restrict out_data,      /*  Output image data   */
00143     short cols, short rows,                      /*  Image dimensions    */
00144     unsigned char       threshold                /*  Threshold value     */
00145 );
00146
00149 #endif
00150
00151 /* ======================================================================== */
00152 /*  End of file:  IMG_thr_gt2thr_8.h                                        */
00153 /* ------------------------------------------------------------------------ */


IMGLIB: IMG_thr_gt2thr_16.h Source File

IMG_thr_gt2thr_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_THR_GT2THR_16_H_
00038 #define IMG_THR_GT2THR_16_H_ 1
00039
00042 /* @{ */
00043
00109 void IMG_thr_gt2thr_16
00110 (
00111     const unsigned short           *in_data,      /*  Input image data    */
00112           unsigned short *restrict out_data,      /*  Output image data   */
00113                    short           cols,          /*  Image columns       */
00114                    short           rows,          /*  Image rows          */
00115           unsigned short           threshold      /*  Threshold value     */
00116 );
00117
00120 #endif
00121
00122 /*========================================================================= */
00123 /*   End of file:  IMG_thr_gt2thr_16.h                                      */
00124 /* ======================================================================== */
00125


IMGLIB: IMG_thr_le2min_8.h Source File

IMG_thr_le2min_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_THR_LE2MIN_8_H_
00038 #define IMG_THR_LE2MIN_8_H_ 1
00039
00042 /* @{ */
00043
00149 void IMG_thr_le2min_8
00150 (
00151     const unsigned char *in_data,                /*  Input image data    */
00152     unsigned char       *restrict out_data,      /*  Output image data   */
00153     short cols, short rows,                      /*  Image dimensions    */
00154     unsigned char       threshold                /*  Threshold value     */
00155 );
00156
00159 #endif
00160
00161 /* ======================================================================== */
00162 /*  End of file:  IMG_thr_le2min_8.h                                        */
00163 /* ======================================================================== */


IMGLIB: IMG_thr_le2min_16.h Source File

IMG_thr_le2min_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_THR_LE2MIN_16_H_
00038 #define IMG_THR_LE2MIN_16_H_ 1
00039
00042 /* @{ */
00043
00109 void IMG_thr_le2min_16
00110 (
00111     const unsigned short *restrict in_data,      /*  Input image data    */
00112           unsigned short *restrict out_data,     /*  Output image data   */
00113                    short           cols,         /*  Image columns       */
00114                    short           rows,         /*  Image rows          */
00115           unsigned short           threshold     /*  Threshold value     */
00116 );
00117
00120 #endif
00121
00122 /*=========================================================================== */
00123 /*   End of file:  IMG_thr_le2min_16.h                                        */
00124 /* ========================================================================== */


IMGLIB: IMG_thr_le2thr_8.h Source File

IMG_thr_le2thr_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_THR_LE2THR_8_H_
00038 #define IMG_THR_LE2THR_8_H_ 1
00039
00042 /* @{ */
00043
00144 void IMG_thr_le2thr_8
00145 (
00146     const unsigned char *in_data,                /*  Input image data    */
00147     unsigned char       *restrict out_data,      /*  Output image data   */
00148     short cols, short rows,                      /*  Image dimensions    */
00149     unsigned char       threshold                /*  Threshold value     */
00150 );
00151
00154 #endif
00155
00156 /* ======================================================================== */
00157 /*  End of file:  IMG_thr_le2thr_8.h                                        */
00158 /* ======================================================================== */


IMGLIB: IMG_thr_le2thr_16.h Source File

IMG_thr_le2thr_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_THR_LE2THR_16_H_
00038 #define IMG_THR_LE2THR_16_H_ 1
00039
00042 /* @{ */
00043
00109 void IMG_thr_le2thr_16
00110 (
00111     const unsigned short           *in_data,      /*  Input image data    */
00112           unsigned short *restrict out_data,      /*  Output image data   */
00113                    short           cols,          /*  Image columns       */
00114                    short           rows,          /*  Image rows          */
00115           unsigned short           threshold      /*  Threshold value     */
00116 );
00117
00120 #endif
00121
00122 /*========================================================================= */
00123 /*   End of file:  IMG_thr_le2thr_16.h                                      */
00124 /* ======================================================================== */


IMGLIB: IMG_wave_horz.h Source File

IMG_wave_horz.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_WAVE_HORZ_H_
00038 #define  IMG_WAVE_HORZ_H_ 1
00039
00042 /* @{ */
00043
00102 void IMG_wave_horz
00103 (
00104     short *iptr,
00105     short *qmf,
00106     short *filter,
00107     short *optr,
00108     int   ish_x_dim
00109 );
00110
00113 #endif
00114
00115 /* ======================================================================== */
00116 /*  End of file:  IMG_wave_horz.h                                           */
00117 /* ======================================================================== */


IMGLIB: IMG_wave_vert.h Source File

IMG_wave_vert.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_WAVE_VERT_H_
00038 #define  IMG_WAVE_VERT_H_ 1
00039
00042 /* @{ */
00043
00155 void IMG_wave_vert
00156 (
00157     const short *restrict
00158                 *restrict in_data,   /* Array of row pointers */
00159     const short *restrict qmf,       /* Low pass QMF filter   */
00160     const short *restrict mqmf,      /* High pass QMF filter  */
00161     short       *restrict out_ldata, /* Low pass output data  */
00162     short       *restrict out_hdata, /* High pass output data */
00163     int cols                     /* Length of rows to process */
00164 );
00165
00168 #endif
00169
00170 /* ======================================================================== */
00171 /*  End of file:  IMG_wave_vert.h                                           */
00172 /* ======================================================================== */


IMGLIB: IMG_yc_demux_be16_8.h Source File

IMG_yc_demux_be16_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_YC_DEMUX_BE16_8_H_
00038 #define  IMG_YC_DEMUX_BE16_8_H_ 1
00039
00042 /* @{ */
00043
00105 void IMG_yc_demux_be16_8
00106 (
00107     int n,                               /* Number of luma pixels    */
00108     const unsigned char *restrict yc,    /* Interbeaved luma/chroma  */
00109     short         *restrict y,           /* Luma plane (8-bit)       */
00110     short         *restrict cr,          /* Cr chroma plane (8-bit)  */
00111     short         *restrict cb           /* Cb chroma plane (8-bit)  */
00112 );
00113
00116 #endif
00117
00118 /* ======================================================================== */
00119 /*  End of file:  IMG_yc_demux_be16_8.h                                     */
00120 /* ======================================================================== */


IMGLIB: IMG_yc_demux_be16_16.h Source File

IMG_yc_demux_be16_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_WAVE_HORZ_H_
00038 #define  IMG_WAVE_HORZ_H_ 1
00039
00042 /* @{ */
00043
00105 void IMG_yc_demux_be16_16
00106 (
00107     int n,                    /* Number of luma pixels    */
00108     const unsigned short *yc, /* Interleaved luma/chroma  */
00109     short *restrict y,        /* Luma plane (16-bit)      */
00110     short *restrict cr,       /* Cr chroma plane (16-bit) */
00111     short *restrict cb        /* Cb chroma plane (16-bit) */
00112 );
00113
00116 #endif
00117
00118 /*========================================================================= */
00119 /*   End of file:  IMG_yc_demux_be16_16.h                                   */
00120 /* ======================================================================== */


IMGLIB: IMG_yc_demux_le16_8.h Source File

IMG_yc_demux_le16_8.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_YC_DEMUX_LE16_8_H_
00038 #define  IMG_YC_DEMUX_LE16_8_H_ 1
00039
00042 /* @{ */
00043
00105 void IMG_yc_demux_le16_8
00106 (
00107     int n,                               /* Number of luma pixels    */
00108     const unsigned char *restrict yc,    /* Interbeaved luma/chroma  */
00109     short         *restrict y,           /* Luma plane (8-bit)       */
00110     short         *restrict cr,          /* Cr chroma plane (8-bit)  */
00111     short         *restrict cb           /* Cb chroma plane (8-bit)  */
00112 );
00113
00116 #endif
00117
00118 /* ======================================================================== */
00119 /*  End of file:  IMG_yc_demux_le16_8.h                                     */
00120 /* ======================================================================== */


IMGLIB: IMG_yc_demux_le16_16.h Source File

IMG_yc_demux_le16_16.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef  IMG_YC_DEMUX_LE16_16_H_
00038 #define  IMG_YC_DEMUX_LE16_16_H_ 1
00039
00042 /* @{ */
00043
00105 void IMG_yc_demux_le16_16
00106 (
00107     int n,                    /* Number of luma pixels    */
00108     const unsigned short *yc, /* Interleaved luma/chroma  */
00109     short *restrict y,        /* Luma plane (16-bit)      */
00110     short *restrict cr,       /* Cr chroma plane (16-bit) */
00111     short *restrict cb        /* Cb chroma plane (16-bit) */
00112 );
00113
00116 #endif
00117
00118 /*========================================================================= */
00119 /*   End of file:  IMG_yc_demux_le16_16.h                                   */
00120 /* ======================================================================== */
00121


IMGLIB: IMG_ycbcr422pl_to_rgb565.h Source File

IMG_ycbcr422pl_to_rgb565.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *                                                                          *
00005  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00006  *                                                                          *
00007  *                                                                          *
00008  *  Redistribution and use in source and binary forms, with or without      *
00009  *  modification, are permitted provided that the following conditions      *
00010  *  are met:                                                                *
00011  *                                                                          *
00012  *    Redistributions of source code must retain the above copyright        *
00013  *    notice, this list of conditions and the following disclaimer.         *
00014  *                                                                          *
00015  *    Redistributions in binary form must reproduce the above copyright     *
00016  *    notice, this list of conditions and the following disclaimer in the   *
00017  *    documentation and/or other materials provided with the                *
00018  *    distribution.                                                         *
00019  *                                                                          *
00020  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00021  *    its contributors may be used to endorse or promote products derived   *
00022  *    from this software without specific prior written permission.         *
00023  *                                                                          *
00024  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00025  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00026  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00027  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00028  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00029  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00030  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00031  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00032  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00033  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00034  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00035  * ======================================================================== */
00036
00037 #ifndef IMG_YCBCR422PL_TO_RGB565_H_
00038 #define IMG_YCBCR422PL_TO_RGB565_H_ 1
00039
00042 /* @{ */
00043
00229 void IMG_ycbcr422pl_to_rgb565
00230 (
00231     const short                   coeff[5],  /* Matrix coefficients.          */
00232     const unsigned char *restrict y_data,    /* Luminence data        (Y')    */
00233     const unsigned char *restrict cb_data,   /* Blue color-difference (B'-Y') */
00234     const unsigned char *restrict cr_data,   /* Red color-difference  (R'-Y') */
00235     unsigned short      *restrict rgb_data,  /* RGB 5:6:5 packed pixel output */
00236     unsigned                      num_pixels /* # of luma pixels to process.  */
00237 );
00238
00241 #endif
00242
00243 /* ======================================================================== */
00244 /*  End of file:  IMG_ycbcr422pl_to_rgb565.h                                */
00245 /* ======================================================================== */


IMGLIB: doxygen.h Source File

doxygen.h

Go to the documentation of this file.
00001 /* ======================================================================== *
00002  * IMGLIB -- TI Image and Video Processing Library                          *
00003  *                                                                          *
00004  *   Doxygen generation header file                                         *
00005  *                                                                          *
00006  * Copyright (C) 2012 Texas Instruments Incorporated - http://www.ti.com/   *
00007  *                                                                          *
00008  *                                                                          *
00009  *  Redistribution and use in source and binary forms, with or without      *
00010  *  modification, are permitted provided that the following conditions      *
00011  *  are met:                                                                *
00012  *                                                                          *
00013  *    Redistributions of source code must retain the above copyright        *
00014  *    notice, this list of conditions and the following disclaimer.         *
00015  *                                                                          *
00016  *    Redistributions in binary form must reproduce the above copyright     *
00017  *    notice, this list of conditions and the following disclaimer in the   *
00018  *    documentation and/or other materials provided with the                *
00019  *    distribution.                                                         *
00020  *                                                                          *
00021  *    Neither the name of Texas Instruments Incorporated nor the names of   *
00022  *    its contributors may be used to endorse or promote products derived   *
00023  *    from this software without specific prior written permission.         *
00024  *                                                                          *
00025  *  THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS     *
00026  *  "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT       *
00027  *  LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR   *
00028  *  A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT    *
00029  *  OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,   *
00030  *  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT        *
00031  *  LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,   *
00032  *  DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY   *
00033  *  THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT     *
00034  *  (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE   *
00035  *  OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.    *
00036  * ======================================================================== */
00037


IMGLIB: Data Fields

  • All
  • Functions
  • Defines
  • _
  • i

- _ -

  • _IMG_BOUNDARY_16S_H_ : IMG_boundary_16s.h
  • _IMG_BOUNDARY_8_H_ : IMG_boundary_8.h
  • _IMG_CLIPPING_16S_H_ : IMG_clipping_16s.h
  • _IMG_CONV_11X11_I16S_C16S_H_ : IMG_conv_11x11_i16s_c16s.h
  • _IMG_CONV_11X11_I8_C8S_H_ : IMG_conv_11x11_i8_c8s.h
  • _IMG_CONV_3X3_I16_C16S_H_ : IMG_conv_3x3_i16_c16s.h
  • _IMG_CONV_3X3_I16S_C16S_H_ : IMG_conv_3x3_i16s_c16s.h
  • _IMG_CONV_3X3_I8_C8S_H_ : IMG_conv_3x3_i8_c8s.h
  • _IMG_CONV_5X5_I16S_C16S_H_ : IMG_conv_5x5_i16s_c16s.h
  • _IMG_CONV_5X5_I8_C16S_H_ : IMG_conv_5x5_i8_c16s.h
  • _IMG_CONV_5X5_I8_C8S_H_ : IMG_conv_5x5_i8_c8s.h
  • _IMG_CONV_7X7_I16S_C16S_H_ : IMG_conv_7x7_i16s_c16s.h
  • _IMG_CONV_7X7_I8_C16S_H_ : IMG_conv_7x7_i8_c16s.h
  • _IMG_CONV_7X7_I8_C8S_H_ : IMG_conv_7x7_i8_c8s.h
  • _IMG_CORR_11X11_I16S_C16S_H_ : IMG_corr_11x11_i16s_c16s.h
  • _IMG_CORR_11X11_I8_C16S_H_ : IMG_corr_11x11_i8_c16s.h
  • _IMG_CORR_3X3_I16_C16_H_ : IMG_corr_3x3_i16_c16.h
  • _IMG_CORR_3X3_I16S_C16S_H_ : IMG_corr_3x3_i16s_c16s.h
  • _IMG_CORR_3X3_I8_C16S_H_ : IMG_corr_3x3_i8_c16s.h
  • _IMG_CORR_3X3_I8_C8_H_ : IMG_corr_3x3_i8_c8.h
  • _IMG_CORR_5X5_I16S_C16S_H_ : IMG_corr_5x5_i16s_c16s.h
  • _IMG_CORR_GEN_I16S_C16S_H_ : IMG_corr_gen_i16s_c16s.h
  • _IMG_CORR_GEN_IQ_H_ : IMG_corr_gen_iq.h
  • _IMG_DILATE_BIN_H_ : IMG_dilate_bin.h
  • _IMG_ERODE_BIN_H_ : IMG_erode_bin.h
  • _IMG_ERRDIF_BIN_16_H_ : IMG_errdif_bin_16.h
  • _IMG_ERRDIF_BIN_8_H_ : IMG_errdif_bin_8.h
  • _IMG_FDCT_8X8_H_ : IMG_fdct_8x8.h
  • _IMG_HISTOGRAM_16_H_ : IMG_histogram_16.h
  • _IMG_HISTOGRAM_8_H_ : IMG_histogram_8.h
  • _IMG_IDCT_8X8_12Q4_H_ : IMG_idct_8x8_12q4.h
  • _IMG_MAD_16X16_H_ : IMG_mad_16x16.h
  • _IMG_MAD_8X8_H_ : IMG_mad_8x8.h
  • _IMG_MEDIAN_3X3_16_H_ : IMG_median_3x3_16.h
  • _IMG_MEDIAN_3X3_16S_H_ : IMG_median_3x3_16s.h
  • _IMG_MEDIAN_3X3_8_H_ : IMG_median_3x3_8.h
  • _IMG_PERIMETER_16_H_ : IMG_perimeter_16.h
  • _IMG_PERIMETER_8_H_ : IMG_perimeter_8.h
  • _IMG_PIX_EXPAND_H_ : IMG_pix_expand.h
  • _IMG_PIX_SAT_H_ : IMG_pix_sat.h
  • _IMG_QUANTIZE_H_ : IMG_quantize.h
  • _IMG_SAD_16X16_H_ : IMG_sad_16x16.h
  • _IMG_SAD_8X8_H_ : IMG_sad_8x8.h
  • _IMG_SOBEL_3X3_16_H_ : IMG_sobel_3x3_16.h
  • _IMG_SOBEL_3X3_16S_H_ : IMG_sobel_3x3_16s.h
  • _IMG_SOBEL_3X3_8_H_ : IMG_sobel_3x3_8.h
  • _IMG_SOBEL_5X5_16S_H_ : IMG_sobel_5x5_16s.h
  • _IMG_SOBEL_7X7_16S_H_ : IMG_sobel_7x7_16s.h
  • _IMG_THR_GT2MAX_16_H_ : IMG_thr_gt2max_16.h
  • _IMG_THR_GT2MAX_8_H_ : IMG_thr_gt2max_8.h
  • _IMG_THR_GT2THR_16_H_ : IMG_thr_gt2thr_16.h
  • _IMG_THR_GT2THR_8_H_ : IMG_thr_gt2thr_8.h
  • _IMG_THR_LE2MIN_16_H_ : IMG_thr_le2min_16.h
  • _IMG_THR_LE2MIN_8_H_ : IMG_thr_le2min_8.h
  • _IMG_THR_LE2THR_16_H_ : IMG_thr_le2thr_16.h
  • _IMG_THR_LE2THR_8_H_ : IMG_thr_le2thr_8.h
  • _IMG_WAVE_HORZ_H_ : IMG_wave_horz.h
  • _IMG_WAVE_VERT_H_ : IMG_wave_vert.h
  • _IMG_YC_DEMUX_BE16_16_H_ : IMG_yc_demux_be16_16.h
  • _IMG_YC_DEMUX_BE16_8_H_ : IMG_yc_demux_be16_8.h
  • _IMG_YC_DEMUX_LE16_16_H_ : IMG_yc_demux_le16_16.h
  • _IMG_YC_DEMUX_LE16_8_H_ : IMG_yc_demux_le16_8.h
  • _IMG_YCBCR422PL_TO_RGB565_H_ : IMG_ycbcr422pl_to_rgb565.h

- i -

  • IMG_BOUNDARY_16S_H_ : c64P/IMG_boundary_16s.h
  • IMG_BOUNDARY_8_H_ : c64P/IMG_boundary_8.h
  • IMG_CLIPPING_16S_H_ : c64P/IMG_clipping_16s.h
  • IMG_CONV_11X11_I16S_C16S_H_ : c64P/IMG_conv_11x11_i16s_c16s.h
  • IMG_CONV_11X11_I8_C8S_H_ : c64P/IMG_conv_11x11_i8_c8s.h
  • IMG_CONV_3X3_I16_C16S_H_ : c64P/IMG_conv_3x3_i16_c16s.h
  • IMG_CONV_3X3_I16S_C16S_H_ : c64P/IMG_conv_3x3_i16s_c16s.h
  • IMG_CONV_3X3_I8_C8S_H_ : c64P/IMG_conv_3x3_i8_c8s.h
  • IMG_CONV_5X5_I16S_C16S_H_ : c64P/IMG_conv_5x5_i16s_c16s.h
  • IMG_CONV_5X5_I8_C16S_H_ : c64P/IMG_conv_5x5_i8_c16s.h
  • IMG_CONV_5X5_I8_C8S_H_ : c64P/IMG_conv_5x5_i8_c8s.h
  • IMG_CONV_7X7_I16S_C16S_H_ : c64P/IMG_conv_7x7_i16s_c16s.h
  • IMG_CONV_7X7_I8_C16S_H_ : c64P/IMG_conv_7x7_i8_c16s.h
  • IMG_CONV_7X7_I8_C8S_H_ : c64P/IMG_conv_7x7_i8_c8s.h
  • IMG_CORR_11X11_I16S_C16S_H_ : c64P/IMG_corr_11x11_i16s_c16s.h
  • IMG_CORR_11X11_I8_C16S_H_ : c64P/IMG_corr_11x11_i8_c16s.h
  • IMG_CORR_3X3_I16_C16_H_ : c64P/IMG_corr_3x3_i16_c16.h
  • IMG_CORR_3X3_I16S_C16S_H_ : c64P/IMG_corr_3x3_i16s_c16s.h
  • IMG_CORR_3X3_I8_C16S_H_ : c64P/IMG_corr_3x3_i8_c16s.h
  • IMG_CORR_3X3_I8_C8_H_ : c64P/IMG_corr_3x3_i8_c8.h
  • IMG_CORR_5X5_I16S_C16S_H_ : c64P/IMG_corr_5x5_i16s_c16s.h
  • IMG_CORR_GEN_I16S_C16S_H_ : c64P/IMG_corr_gen_i16s_c16s.h
  • IMG_CORR_GEN_IQ_H_ : c64P/IMG_corr_gen_iq.h
  • IMG_DILATE_BIN_H_ : c64P/IMG_dilate_bin.h
  • IMG_ERODE_BIN_H_ : c64P/IMG_erode_bin.h
  • IMG_ERRDIF_BIN_16_H_ : c64P/IMG_errdif_bin_16.h
  • IMG_ERRDIF_BIN_8_H_ : c64P/IMG_errdif_bin_8.h
  • IMG_FDCT_8X8_H_ : c64P/IMG_fdct_8x8.h
  • IMG_HISTOGRAM_16_H_ : c64P/IMG_histogram_16.h
  • IMG_HISTOGRAM_8_H_ : c64P/IMG_histogram_8.h
  • IMG_IDCT_8X8_12Q4_H_ : c64P/IMG_idct_8x8_12q4.h
  • IMG_MAD_16X16_H_ : c64P/IMG_mad_16x16.h
  • IMG_MAD_8X8_H_ : c64P/IMG_mad_8x8.h
  • IMG_MEDIAN_3X3_16_H_ : c64P/IMG_median_3x3_16.h
  • IMG_MEDIAN_3X3_16S_H_ : c64P/IMG_median_3x3_16s.h
  • IMG_MEDIAN_3X3_8_H_ : c64P/IMG_median_3x3_8.h
  • IMG_PERIMETER_16_H_ : c64P/IMG_perimeter_16.h
  • IMG_PERIMETER_8_H_ : c64P/IMG_perimeter_8.h
  • IMG_PIX_EXPAND_H_ : c64P/IMG_pix_expand.h
  • IMG_PIX_SAT_H_ : c64P/IMG_pix_sat.h
  • IMG_QUANTIZE_H_ : c64P/IMG_quantize.h
  • IMG_SAD_16X16_H_ : c64P/IMG_sad_16x16.h
  • IMG_SAD_8X8_H_ : c64P/IMG_sad_8x8.h
  • IMG_SOBEL_3X3_16_H_ : c64P/IMG_sobel_3x3_16.h
  • IMG_SOBEL_3X3_16S_H_ : c64P/IMG_sobel_3x3_16s.h
  • IMG_SOBEL_3x3_8_H_ : c64P/IMG_sobel_3x3_8.h
  • IMG_SOBEL_5X5_16S_H_ : c64P/IMG_sobel_5x5_16s.h
  • IMG_SOBEL_7x7_16s_H_ : c64P/IMG_sobel_7x7_16s.h
  • IMG_THR_GT2MAX_16_H_ : c64P/IMG_thr_gt2max_16.h
  • IMG_THR_GT2MAX_8_H_ : c64P/IMG_thr_gt2max_8.h
  • IMG_THR_GT2THR_16_H_ : c64P/IMG_thr_gt2thr_16.h
  • IMG_THR_GT2THR_8_H_ : c64P/IMG_thr_gt2thr_8.h
  • IMG_THR_LE2MIN_16_H_ : c64P/IMG_thr_le2min_16.h
  • IMG_THR_LE2MIN_8_H_ : c64P/IMG_thr_le2min_8.h
  • IMG_THR_LE2THR_16_H_ : c64P/IMG_thr_le2thr_16.h
  • IMG_THR_LE2THR_8_H_ : c64P/IMG_thr_le2thr_8.h
  • IMG_WAVE_HORZ_H_ : c64P/IMG_wave_horz.h , c64P/IMG_yc_demux_be16_16.h
  • IMG_WAVE_VERT_H_ : c64P/IMG_wave_vert.h
  • IMG_YC_DEMUX_BE16_8_H_ : c64P/IMG_yc_demux_be16_8.h
  • IMG_YC_DEMUX_LE16_16_H_ : c64P/IMG_yc_demux_le16_16.h
  • IMG_YC_DEMUX_LE16_8_H_ : c64P/IMG_yc_demux_le16_8.h
  • IMG_YCBCR422PL_TO_RGB565_H_ : c64P/IMG_ycbcr422pl_to_rgb565.h


IMGLIB: Data Fields

  • All
  • Functions
  • Defines
  • i

- i -

  • IMG_boundary_16s() : c64P/IMG_boundary_16s.h
  • IMG_boundary_8() : c64P/IMG_boundary_8.h
  • IMG_clipping_16s() : c64P/IMG_clipping_16s.h
  • IMG_conv_11x11_i16s_c16s() : c64P/IMG_conv_11x11_i16s_c16s.h
  • IMG_conv_11x11_i8_c8s() : c64P/IMG_conv_11x11_i8_c8s.h
  • IMG_conv_3x3_i16_c16s() : c64P/IMG_conv_3x3_i16_c16s.h
  • IMG_conv_3x3_i16s_c16s() : c64P/IMG_conv_3x3_i16s_c16s.h
  • IMG_conv_3x3_i8_c8s() : c64P/IMG_conv_3x3_i8_c8s.h
  • IMG_conv_5x5_i16s_c16s() : c64P/IMG_conv_5x5_i16s_c16s.h
  • IMG_conv_5x5_i8_c16s() : c64P/IMG_conv_5x5_i8_c16s.h
  • IMG_conv_5x5_i8_c8s() : c64P/IMG_conv_5x5_i8_c8s.h
  • IMG_conv_7x7_i16s_c16s() : c64P/IMG_conv_7x7_i16s_c16s.h
  • IMG_conv_7x7_i8_c16s() : c64P/IMG_conv_7x7_i8_c16s.h
  • IMG_conv_7x7_i8_c8s() : c64P/IMG_conv_7x7_i8_c8s.h
  • IMG_corr_11x11_i16s_c16s() : c64P/IMG_corr_11x11_i16s_c16s.h
  • IMG_corr_11x11_i8_c16s() : c64P/IMG_corr_11x11_i8_c16s.h
  • IMG_corr_3x3_i16_c16() : c64P/IMG_corr_3x3_i16_c16.h
  • IMG_corr_3x3_i16s_c16s() : c64P/IMG_corr_3x3_i16s_c16s.h
  • IMG_corr_3x3_i8_c16s() : c64P/IMG_corr_3x3_i8_c16s.h
  • IMG_corr_3x3_i8_c8() : c64P/IMG_corr_3x3_i8_c8.h
  • IMG_corr_5x5_i16s_c16s() : c64P/IMG_corr_5x5_i16s_c16s.h
  • IMG_corr_gen_i16s_c16s() : c64P/IMG_corr_gen_i16s_c16s.h
  • IMG_corr_gen_iq() : c64P/IMG_corr_gen_iq.h
  • IMG_dilate_bin() : c64P/IMG_dilate_bin.h
  • IMG_erode_bin() : c64P/IMG_erode_bin.h
  • IMG_errdif_bin_16() : c64P/IMG_errdif_bin_16.h
  • IMG_errdif_bin_8() : c64P/IMG_errdif_bin_8.h
  • IMG_fdct_8x8() : c64P/IMG_fdct_8x8.h
  • IMG_histogram_16() : c64P/IMG_histogram_16.h
  • IMG_histogram_8() : c64P/IMG_histogram_8.h
  • IMG_idct_8x8_12q4() : c64P/IMG_idct_8x8_12q4.h
  • IMG_mad_16x16() : c64P/IMG_mad_16x16.h
  • IMG_mad_8x8() : c64P/IMG_mad_8x8.h
  • IMG_median_3x3_16() : c64P/IMG_median_3x3_16.h
  • IMG_median_3x3_16s() : c64P/IMG_median_3x3_16s.h
  • IMG_median_3x3_8() : c64P/IMG_median_3x3_8.h
  • IMG_perimeter_16() : c64P/IMG_perimeter_16.h
  • IMG_perimeter_8() : c64P/IMG_perimeter_8.h
  • IMG_pix_expand() : c64P/IMG_pix_expand.h
  • IMG_pix_sat() : c64P/IMG_pix_sat.h
  • IMG_quantize() : c64P/IMG_quantize.h
  • IMG_sad_16x16() : c64P/IMG_sad_16x16.h
  • IMG_sad_8x8() : c64P/IMG_sad_8x8.h
  • IMG_sobel_3x3_16() : c64P/IMG_sobel_3x3_16.h
  • IMG_sobel_3x3_16s() : c64P/IMG_sobel_3x3_16s.h
  • IMG_sobel_3x3_8() : c64P/IMG_sobel_3x3_8.h
  • IMG_sobel_5x5_16s() : c64P/IMG_sobel_5x5_16s.h
  • IMG_sobel_7x7_16s() : c64P/IMG_sobel_7x7_16s.h
  • IMG_thr_gt2max_16() : c64P/IMG_thr_gt2max_16.h
  • IMG_thr_gt2max_8() : c64P/IMG_thr_gt2max_8.h
  • IMG_thr_gt2thr_16() : c64P/IMG_thr_gt2thr_16.h
  • IMG_thr_gt2thr_8() : c64P/IMG_thr_gt2thr_8.h
  • IMG_thr_le2min_16() : c64P/IMG_thr_le2min_16.h
  • IMG_thr_le2min_8() : c64P/IMG_thr_le2min_8.h
  • IMG_thr_le2thr_16() : c64P/IMG_thr_le2thr_16.h
  • IMG_thr_le2thr_8() : c64P/IMG_thr_le2thr_8.h
  • IMG_wave_horz() : c64P/IMG_wave_horz.h
  • IMG_wave_vert() : c64P/IMG_wave_vert.h
  • IMG_yc_demux_be16_16() : c64P/IMG_yc_demux_be16_16.h
  • IMG_yc_demux_be16_8() : c64P/IMG_yc_demux_be16_8.h
  • IMG_yc_demux_le16_16() : c64P/IMG_yc_demux_le16_16.h
  • IMG_yc_demux_le16_8() : c64P/IMG_yc_demux_le16_8.h
  • IMG_ycbcr422pl_to_rgb565() : c64P/IMG_ycbcr422pl_to_rgb565.h


IMGLIB: Graph Legend

Graph Legend

This page explains how to interpret the graphs that are generated by doxygen.

Consider the following example:

/*! Invisible class because of truncation */
class Invisible { };

/*! Truncated class, inheritance relation is hidden */
class Truncated : public Invisible { };

/* Class not documented with doxygen comments */
class Undocumented { };

/*! Class that is inherited using public inheritance */
class PublicBase : public Truncated { };

/*! A template class */
template<class T> class Templ { };

/*! Class that is inherited using protected inheritance */
class ProtectedBase { };

/*! Class that is inherited using private inheritance */
class PrivateBase { };

/*! Class that is used by the Inherited class */
class Used { };

/*! Super class that inherits a number of other classes */
class Inherited : public PublicBase,
                  protected ProtectedBase,
                  private PrivateBase,
                  public Undocumented
                  public Templ<int>
{
  private:
    Used *m_usedClass;
};
If the MAX_DOT_GRAPH_HEIGHT tag in the configuration file is set to 240 this will result in the following graph:

The boxes in the above graph have the following meaning:

  • A filled black box represents the struct or class for which the graph is generated.
  • A box with a black border denotes a documented struct or class.
  • A box with a grey border denotes an undocumented struct or class.
  • A box with a red border denotes a documented struct or class forwhich not all inheritance/containment relations are shown. A graph is truncated if it does not fit within the specified boundaries.
The arrows have the following meaning:
  • A dark blue arrow is used to visualize a public inheritance relation between two classes.
  • A dark green arrow is used for protected inheritance.
  • A dark red arrow is used for private inheritance.
  • A purple dashed arrow is used if a class is contained or used by another class. The arrow is labeled with the variable(s) through which the pointed class or struct is accessible.
  • A yellow dashed arrow denotes a relation between a template instance and the template class it was instantiated from. The arrow is labeled with the template parameters of the instance.